summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2023-10-02 16:01:16 +0200
committerkleintux2023-10-02 16:01:16 +0200
commit221bc72d7b436c8ecffd5904635700769ab159cd (patch)
tree5bb3a3765da5f15b329efb1fc1b231e2235bbd05
parentfbaa4cccad9b7fd07c5c45edfafc4fd8455b4929 (diff)
downloadaur-221bc72d7b436c8ecffd5904635700769ab159cd.tar.gz
adopted and fixed
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5462c708cb56..413b1f03d8df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
-# Generated by mksrcinfo v8
-# Wed Jun 8 13:46:15 UTC 2016
pkgbase = xmlfs
pkgdesc = Mount XML files as directory structures
pkgver = 0.1.1
- pkgrel = 2
+ pkgrel = 3
url = http://github.com/halhen/xmlfs
- arch = x86_64
- arch = i686
+ arch = any
license = GPL
depends = fuse
depends = libxml2
- source = git://github.com/halhen/xmlfs.git#tag=0.1.1
- md5sums = SKIP
+ source = https://github.com/halhen/xmlfs/archive/refs/tags/0.1.1.tar.gz
+ sha256sums = 1b6e4d8d3f6615f2c82a5ff65524f5b33cc43eb92a4f301d8020f2144ad24985
pkgname = xmlfs
-
diff --git a/PKGBUILD b/PKGBUILD
index 256b57517e80..f4ff88ed277b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
-# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: halhen <halhen at k2h dot se>
pkgname=xmlfs
pkgver=0.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Mount XML files as directory structures'
license=('GPL')
-arch=('x86_64' 'i686')
+arch=('any')
url='http://github.com/halhen/xmlfs'
depends=('fuse' 'libxml2')
-source=("git://github.com/halhen/xmlfs.git#tag=$pkgver")
-md5sums=('SKIP')
+source=("https://github.com/halhen/xmlfs/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('1b6e4d8d3f6615f2c82a5ff65524f5b33cc43eb92a4f301d8020f2144ad24985')
build() {
- make -C "$pkgname"
+ cd "${pkgname}-${pkgver}"
+ make -C .
}
package() {
- cd "$pkgname"
-
- make PREFIX=/usr MANPREFIX=/usr/man DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${pkgname}-${pkgver}"
+ make PREFIX=/usr MANPREFIX=/usr/man DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: