summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-06-08 15:46:19 +0200
committerAlexander F Rødseth2016-06-08 15:46:19 +0200
commitfbaa4cccad9b7fd07c5c45edfafc4fd8455b4929 (patch)
tree70485d20001cabb8f81741636687a7cfb2b39879
parent7045674982713436914128cc6e4b459b3fd917c6 (diff)
downloadaur-fbaa4cccad9b7fd07c5c45edfafc4fd8455b4929.tar.gz
Fix and modernize the PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD48
2 files changed, 25 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf021da6d16e..5462c708cb56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Jun 8 13:46:15 UTC 2016
pkgbase = xmlfs
- pkgdesc = mount xml files as directory structures
+ pkgdesc = Mount XML files as directory structures
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/halhen/xmlfs
- arch = i686
arch = x86_64
+ arch = i686
license = GPL
- depends = fuse>=2.6
+ depends = fuse
depends = libxml2
+ source = git://github.com/halhen/xmlfs.git#tag=0.1.1
+ md5sums = SKIP
pkgname = xmlfs
diff --git a/PKGBUILD b/PKGBUILD
index e119c9cb4dcd..256b57517e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,26 @@
-# PKGBUILD for ArchLinux
-# Uses the main git repository as source
-# Not using _gitroot and _gitname, since this PKGBUILD
-# is for installing tagged and released versions,
-# not the latest release.
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: halhen <halhen at k2h dot se>
pkgname=xmlfs
pkgver=0.1.1
-pkgrel=1
-pkgdesc="mount xml files as directory structures"
-license=(GPL)
-arch=('i686' 'x86_64')
-url=http://github.com/halhen/xmlfs
-depends=('fuse>=2.6' libxml2)
-source=()
+pkgrel=2
+pkgdesc='Mount XML files as directory structures'
+license=('GPL')
+arch=('x86_64' 'i686')
+url='http://github.com/halhen/xmlfs'
+depends=('fuse' 'libxml2')
+source=("git://github.com/halhen/xmlfs.git#tag=$pkgver")
+md5sums=('SKIP')
build() {
- cd "$srcdir"
- msg "Connecting to git server..."
-
- if [[ -d "$srcdir/$pkgname" ]]; then
- (cd "$pkgname" && git pull origin master) || return 1
- msg "Repository updated"
- else
- git clone "http://github.com/halhen/xmlfs.git" || return 1
- msg "Repository cloned"
- fi
-
- rm -rf "$srcdir/$pkgname-build"
- cp -R "$srcdir/$pkgname"{,"-build"}
- cd "$srcdir/$pkgname-build"
+ make -C "$pkgname"
+}
- msg "Using version $pkgver..."
- git checkout $pkgver || return 1
+package() {
+ cd "$pkgname"
- msg "Starting make ..."
- make PREFIX=/usr MANPREFIX=/usr/man DESTDIR=$startdir/pkg install || return 1
- install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+ make PREFIX=/usr MANPREFIX=/usr/man DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim:set ts=2 sw=2 et: