summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm dragon2015-09-18 16:56:29 -0400
committerStorm dragon2015-09-18 16:56:29 -0400
commit81be3e2253fc1fa0f2bc359fac8db79daed61f14 (patch)
tree14fe2c1549cd06f1945d257392fed12835126a92
parent4d97adbb0089455e8ae97938d66a120a6cd60abd (diff)
downloadaur-81be3e2253fc1fa0f2bc359fac8db79daed61f14.tar.gz
Removed pythong bindings from the build because they break things currently.
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28ca21cea58a..b82cbf5b6a6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,7 +79,7 @@ build() {
cd "$srcdir/xmms2-devel"
./waf configure --prefix=/usr --sbindir=/usr/bin --without-ldconfig \
--with-ruby-archdir=`ruby -e 'puts RbConfig::CONFIG["vendorarchdir"]'` \
- --with-ruby-libdir=`ruby -e 'puts RbConfig::CONFIG["vendorlibdir"]'`
+ --with-ruby-libdir=`ruby -e 'puts RbConfig::CONFIG["vendorlibdir"]'` --without-optionals=python
./waf build
}
@@ -99,9 +99,11 @@ package() {
install -Dm0644 "$srcdir/user.service" \
"$pkgdir/usr/lib/systemd/user/xmms2d.service"
+ # Python/cython are causing problems.
+ # So, I commented it out until I or someone else can figure out how to fix it.
## also install python2 bindings
- PYTHON=/usr/bin/python2 ./waf configure --prefix=/usr \
- --with-optionals=python --without-xmms2d
- ./waf build
+ #PYTHON=/usr/bin/python2 ./waf configure --prefix=/usr \
+ #--with-optionals=python --without-xmms2d
+ #./waf build
./waf --destdir="$pkgdir" install
}