summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy B2017-09-29 23:39:00 +0200
committerAndy B2017-09-29 23:39:00 +0200
commit62da75c24c3113cd75ac9833d7fca710b5507261 (patch)
treea2c50aa7a5e5cbb63bd79fd1d6767c97870b7e85
parent78b276aaf4853a272da8d5f72b36d56e66054cdb (diff)
downloadaur-62da75c24c3113cd75ac9833d7fca710b5507261.tar.gz
added dbus and mpd support
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5b05b20eae9..316a9866aabc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = xmobar-alsa
pkgdesc = A Minimalistic Text Based Status Bar compiled with ALSA
pkgver = 0.24.5
- pkgrel = 2
+ pkgrel = 3
url = https://hackage.haskell.org/package/xmobar
arch = i686
arch = x86_64
license = BSD
+ makedepends = ghc
depends = haskell-alsa-core>=0.5.0
depends = haskell-alsa-mixer>0.2.0.2
depends = libxft
@@ -13,7 +14,7 @@ pkgbase = xmobar-alsa
depends = wireless_tools
depends = libxrandr
depends = libxpm
- depends = ghc
+ depends = ghc-libs
depends = haskell-x11
depends = haskell-x11-xft
depends = haskell-utf8-string
@@ -25,9 +26,11 @@ pkgbase = xmobar-alsa
depends = haskell-regex-base
depends = haskell-regex-compat
depends = haskell-http
+ depends = haskell-dbus
+ depends = haskell-libmpd
conflicts = xmobar
source = https://hackage.haskell.org/packages/archive/xmobar/0.24.5/xmobar-0.24.5.tar.gz
- md5sums = 9befdb157b5adedd7150e4e07f0efbde
+ sha512sums = b7f4c8b206640d7d0fc60e326fffdc31f4c00df0ffac86102d40035bc632c808cfa19485073059a9c9a01c45b7a9e0aa2bba8dfa27ce9df79d1247a3a13073d4
pkgname = xmobar-alsa
diff --git a/PKGBUILD b/PKGBUILD
index 6c1498fd930c..3b4bcac10e3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
pkgname=xmobar-alsa
pkgver=0.24.5
-pkgrel=2
+pkgrel=3
pkgdesc="A Minimalistic Text Based Status Bar compiled with ALSA"
url="https://hackage.haskell.org/package/xmobar"
license=('BSD')
arch=('i686' 'x86_64')
conflicts=('xmobar')
depends=('haskell-alsa-core>=0.5.0' 'haskell-alsa-mixer>0.2.0.2' 'libxft'
- 'libxinerama' 'wireless_tools' 'libxrandr' 'libxpm' 'ghc' 'haskell-x11'
+ 'libxinerama' 'wireless_tools' 'libxrandr' 'libxpm' 'ghc-libs' 'haskell-x11'
'haskell-x11-xft' 'haskell-utf8-string' 'haskell-network-uri' 'haskell-hinotify'
'haskell-stm' 'haskell-parsec' 'haskell-mtl' 'haskell-regex-base'
- 'haskell-regex-compat' 'haskell-http')
+ 'haskell-regex-compat' 'haskell-http' 'haskell-dbus' 'haskell-libmpd')
+makedepends=('ghc')
source=(https://hackage.haskell.org/packages/archive/xmobar/$pkgver/xmobar-$pkgver.tar.gz)
-md5sums=('9befdb157b5adedd7150e4e07f0efbde')
+sha512sums=('b7f4c8b206640d7d0fc60e326fffdc31f4c00df0ffac86102d40035bc632c808cfa19485073059a9c9a01c45b7a9e0aa2bba8dfa27ce9df79d1247a3a13073d4')
build() {
cd xmobar-$pkgver
@@ -24,7 +25,7 @@ build() {
--prefix=/usr \
--enable-executable-dynamic \
--disable-library-vanilla \
- --flags="with_utf8 with_xft with_iwlib with_xpm with_inotify with_alsa"
+ --flags="with_utf8 with_xft with_iwlib with_xpm with_inotify with_mpd with_dbus with_alsa"
runhaskell Setup build
}