summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy B2018-03-19 18:52:51 +0100
committerAndy B2018-03-19 18:52:51 +0100
commit70b8f909cc3d4eb9af84751aaae713a7c158fe13 (patch)
treef3a9cb0519e4b3df947add994f7fab2d2c8592a6
parent62da75c24c3113cd75ac9833d7fca710b5507261 (diff)
downloadaur-70b8f909cc3d4eb9af84751aaae713a7c158fe13.tar.gz
xmobar-0.25
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 316a9866aabc..bc490759d131 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xmobar-alsa
pkgdesc = A Minimalistic Text Based Status Bar compiled with ALSA
- pkgver = 0.24.5
- pkgrel = 3
+ pkgver = 0.25
+ pkgrel = 1
url = https://hackage.haskell.org/package/xmobar
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = xmobar-alsa
depends = haskell-alsa-mixer>0.2.0.2
depends = libxft
depends = libxinerama
- depends = wireless_tools
depends = libxrandr
depends = libxpm
depends = ghc-libs
@@ -28,9 +27,11 @@ pkgbase = xmobar-alsa
depends = haskell-http
depends = haskell-dbus
depends = haskell-libmpd
+ depends = haskell-iwlib
+ depends = wireless_tools
conflicts = xmobar
- source = https://hackage.haskell.org/packages/archive/xmobar/0.24.5/xmobar-0.24.5.tar.gz
- sha512sums = b7f4c8b206640d7d0fc60e326fffdc31f4c00df0ffac86102d40035bc632c808cfa19485073059a9c9a01c45b7a9e0aa2bba8dfa27ce9df79d1247a3a13073d4
+ source = xmobar-alsa-0.25.tar.gz::https://github.com/jaor/xmobar/archive/0.25.tar.gz
+ sha512sums = ca11d93d7bff9e6fd623607b25dbbd3d38c9f7b356183616d2c2050597b56b5f4636351a606d32acab232b32315f3639b78ae9f7e4385f68c810af30895c5717
pkgname = xmobar-alsa
diff --git a/PKGBUILD b/PKGBUILD
index 3b4bcac10e3f..ff4de47ef96b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Andy B. <brofi.archlinux at gmail dot com>
pkgname=xmobar-alsa
-pkgver=0.24.5
-pkgrel=3
+pkgver=0.25
+pkgrel=1
pkgdesc="A Minimalistic Text Based Status Bar compiled with ALSA"
url="https://hackage.haskell.org/package/xmobar"
license=('BSD')
arch=('i686' 'x86_64')
conflicts=('xmobar')
depends=('haskell-alsa-core>=0.5.0' 'haskell-alsa-mixer>0.2.0.2' 'libxft'
- 'libxinerama' 'wireless_tools' 'libxrandr' 'libxpm' 'ghc-libs' 'haskell-x11'
- 'haskell-x11-xft' 'haskell-utf8-string' 'haskell-network-uri' 'haskell-hinotify'
- 'haskell-stm' 'haskell-parsec' 'haskell-mtl' 'haskell-regex-base'
- 'haskell-regex-compat' 'haskell-http' 'haskell-dbus' 'haskell-libmpd')
+ 'libxinerama' 'libxrandr' 'libxpm' 'ghc-libs' 'haskell-x11'
+ 'haskell-x11-xft' 'haskell-utf8-string' 'haskell-network-uri'
+ 'haskell-hinotify' 'haskell-stm' 'haskell-parsec' 'haskell-mtl'
+ 'haskell-regex-base' 'haskell-regex-compat' 'haskell-http'
+ 'haskell-dbus' 'haskell-libmpd' 'haskell-iwlib' 'wireless_tools')
makedepends=('ghc')
-source=(https://hackage.haskell.org/packages/archive/xmobar/$pkgver/xmobar-$pkgver.tar.gz)
-sha512sums=('b7f4c8b206640d7d0fc60e326fffdc31f4c00df0ffac86102d40035bc632c808cfa19485073059a9c9a01c45b7a9e0aa2bba8dfa27ce9df79d1247a3a13073d4')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/jaor/xmobar/archive/${pkgver}.tar.gz)
+sha512sums=('ca11d93d7bff9e6fd623607b25dbbd3d38c9f7b356183616d2c2050597b56b5f4636351a606d32acab232b32315f3639b78ae9f7e4385f68c810af30895c5717')
build() {
cd xmobar-$pkgver
@@ -32,6 +33,6 @@ build() {
package() {
cd xmobar-$pkgver
runhaskell Setup copy --destdir="$pkgdir"
- install -D -m644 license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}