summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy B2016-04-06 21:53:51 +0200
committerAndy B2016-04-06 22:01:22 +0200
commit9b9ef5f1c058a045ed76bc99c8d6cc5c595c3092 (patch)
tree8a09f82589c9a708615a19c88eb647362e6d4fad
downloadaur-9b9ef5f1c058a045ed76bc99c8d6cc5c595c3092.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD29
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90e595959acb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = xmobar-alsa
+ pkgdesc = A Minimalistic Text Based Status Bar compiled with ALSA
+ pkgver = 0.23.1
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/xmobar
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = ghc=7.10.3
+ makedepends = haskell-x11
+ makedepends = haskell-x11-xft
+ makedepends = haskell-utf8-string
+ makedepends = haskell-network-uri
+ makedepends = haskell-stm
+ makedepends = haskell-parsec
+ makedepends = haskell-mtl
+ makedepends = haskell-regex-base
+ makedepends = haskell-regex-compat
+ makedepends = haskell-http
+ depends = haskell-alsa-core>=0.5.0
+ depends = haskell-alsa-mixer>=0.2.0
+ depends = gmp
+ depends = libxft
+ depends = libxinerama
+ depends = wireless_tools
+ depends = libxrandr
+ depends = libxpm
+ conflicts = xmobar
+ source = http://hackage.haskell.org/packages/archive/xmobar/0.23.1/xmobar-0.23.1.tar.gz
+ md5sums = f97a10f049796f55cc3d13ee68d07eac
+
+pkgname = xmobar-alsa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70e7f4b4b4fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andy B. <brofi.archlinux at gmail dot com>
+
+pkgname=xmobar-alsa
+pkgver=0.23.1
+pkgrel=1
+pkgdesc="A Minimalistic Text Based Status Bar compiled with ALSA"
+url="http://hackage.haskell.org/package/xmobar"
+license=('BSD')
+arch=('i686' 'x86_64')
+conflicts=('xmobar')
+depends=('haskell-alsa-core>=0.5.0' 'haskell-alsa-mixer>=0.2.0' 'gmp' 'libxft' 'libxinerama' 'wireless_tools' 'libxrandr' 'libxpm')
+makedepends=('ghc=7.10.3' 'haskell-x11' 'haskell-x11-xft' 'haskell-utf8-string' 'haskell-network-uri'
+ 'haskell-stm' 'haskell-parsec' 'haskell-mtl' 'haskell-regex-base' 'haskell-regex-compat' 'haskell-http')
+source=(http://hackage.haskell.org/packages/archive/xmobar/$pkgver/xmobar-$pkgver.tar.gz)
+
+build() {
+ cd xmobar-$pkgver
+
+ runhaskell Setup configure --prefix=/usr --flags="with_utf8 with_xft with_iwlib with_xpm with_alsa"
+ runhaskell Setup build
+}
+
+package() {
+ cd xmobar-$pkgver
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+md5sums=('f97a10f049796f55cc3d13ee68d07eac')