summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy B2018-04-08 18:49:04 +0200
committerAndy B2018-04-08 18:49:04 +0200
commite153a667308c8f1aeed4a7dba0bbb0d707375949 (patch)
treec04f478f264e1413137d9a94b9017b4aa4aff944
parent559424e670e772c7dcfa78db724ed794840b63d9 (diff)
downloadaur-e153a667308c8f1aeed4a7dba0bbb0d707375949.tar.gz
xmobar 0.26
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 265970ebebe1..cfc63deaabf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xmobar-alsa
pkgdesc = A Minimalistic Text Based Status Bar compiled with ALSA
- pkgver = 0.25
- pkgrel = 2
+ pkgver = 0.26
+ pkgrel = 1
url = https://hackage.haskell.org/package/xmobar
arch = i686
arch = x86_64
@@ -25,14 +25,14 @@ pkgbase = xmobar-alsa
depends = haskell-regex-base
depends = haskell-regex-compat
depends = haskell-http
- depends = haskell-dbus
+ depends = haskell-dbus0.10
depends = haskell-libmpd
depends = haskell-iwlib
depends = wireless_tools
depends = haskell-text
conflicts = xmobar
- source = xmobar-alsa-0.25.tar.gz::https://github.com/jaor/xmobar/archive/0.25.tar.gz
- sha512sums = ca11d93d7bff9e6fd623607b25dbbd3d38c9f7b356183616d2c2050597b56b5f4636351a606d32acab232b32315f3639b78ae9f7e4385f68c810af30895c5717
+ source = xmobar-alsa-0.26.tar.gz::https://github.com/jaor/xmobar/archive/0.26.tar.gz
+ sha512sums = c67c1552f7183a6f33b472f19686cda41cca27c0de89a8d0dcb1f8ea008aea85a143d75608d4392a1a1c9933737a6cbe881cff9ddd13f632d581cd0e10ca8d4d
pkgname = xmobar-alsa
diff --git a/PKGBUILD b/PKGBUILD
index 90f156cc2ba7..38413eaa5c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Andy B. <brofi.archlinux at gmail dot com>
pkgname=xmobar-alsa
-pkgver=0.25
-pkgrel=2
+pkgver=0.26
+pkgrel=1
pkgdesc="A Minimalistic Text Based Status Bar compiled with ALSA"
url="https://hackage.haskell.org/package/xmobar"
license=('BSD')
@@ -13,27 +13,27 @@ depends=('haskell-alsa-core>=0.5.0' 'haskell-alsa-mixer>0.2.0.2' 'libxft'
'haskell-x11-xft' 'haskell-utf8-string' 'haskell-network-uri'
'haskell-hinotify' 'haskell-stm' 'haskell-parsec' 'haskell-mtl'
'haskell-regex-base' 'haskell-regex-compat' 'haskell-http'
- 'haskell-dbus' 'haskell-libmpd' 'haskell-iwlib' 'wireless_tools'
+ 'haskell-dbus0.10' 'haskell-libmpd' 'haskell-iwlib' 'wireless_tools'
'haskell-text')
makedepends=('ghc')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/jaor/xmobar/archive/${pkgver}.tar.gz)
-sha512sums=('ca11d93d7bff9e6fd623607b25dbbd3d38c9f7b356183616d2c2050597b56b5f4636351a606d32acab232b32315f3639b78ae9f7e4385f68c810af30895c5717')
+sha512sums=('c67c1552f7183a6f33b472f19686cda41cca27c0de89a8d0dcb1f8ea008aea85a143d75608d4392a1a1c9933737a6cbe881cff9ddd13f632d581cd0e10ca8d4d')
build() {
cd xmobar-$pkgver
- runhaskell Setup configure -O \
+ runhaskell setup configure -O \
--enable-shared \
--prefix=/usr \
--enable-executable-dynamic \
--disable-library-vanilla \
--flags="with_utf8 with_xft with_iwlib with_xpm with_inotify with_mpd with_dbus with_mpris with_alsa"
- runhaskell Setup build
+ runhaskell setup build
}
package() {
cd xmobar-$pkgver
- runhaskell Setup copy --destdir="$pkgdir"
+ runhaskell setup copy --destdir="$pkgdir"
install -Dm 644 license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}