summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-13 12:49:46 +0300
committervlad2015-07-13 12:49:46 +0300
commitbf1d111a05cc7cd7224c9a899bc2bf53d8d38c07 (patch)
tree45286ae53e47da3b7b1afd936cd50ab2058fb814
parent567895d2b80f333c02eae7d3ad0efc6739888775 (diff)
downloadaur-bf1d111a05cc7cd7224c9a899bc2bf53d8d38c07.tar.gz
pkgrel=2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD73
2 files changed, 38 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92c8e59a3927..0d51dd7f325e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xmobar-git
- pkgdesc = A minimal status bar for the XMonad Window Manager.
- pkgver = 20140211
- pkgrel = 1
+ pkgdesc = A minimal status bar for the XMonad Window Manager
+ pkgver = 0.23.1.r12.g1b46609
+ pkgrel = 2
url = http://projects.haskell.org/xmobar/
arch = i686
arch = x86_64
@@ -30,6 +30,8 @@ pkgbase = xmobar-git
optdepends = haskell-timezone-series: With haskell-timezone-olson, enables DateZone plugin
conflicts = xmobar
conflicts = xmobar-darcs
+ source = xmobar-git::git+https://github.com/jaor/xmobar.git
+ md5sums = SKIP
pkgname = xmobar-git
diff --git a/PKGBUILD b/PKGBUILD
index 44d565ca7f44..fe1ee239b631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,12 @@
+# Maintainer: Vlad M. <vlad@archlinux.net>
+# Contributer: euclio
# Contributer: Cedric Girard <girard.cedric@gmail.com>
-# Maintainer: Colin Woodbury <colingw@gmail.com>
+# Contributer: Colin Woodbury <colingw@gmail.com>
+
pkgname=xmobar-git
-pkgver=20140211
-pkgrel=1
-pkgdesc="A minimal status bar for the XMonad Window Manager."
+pkgver=0.23.1.r12.g1b46609
+pkgrel=2
+pkgdesc="A minimal status bar for the XMonad Window Manager"
arch=('i686' 'x86_64')
url="http://projects.haskell.org/xmobar/"
license=('custom:BSD3')
@@ -27,52 +30,42 @@ optdepends=(
'haskell-timezone-olson: With haskell-timezone-series, enables DateZone plugin'
'haskell-timezone-series: With haskell-timezone-olson, enables DateZone plugin')
conflicts=('xmobar' 'xmobar-darcs')
-source=()
-md5sums=()
-
_gitroot="https://github.com/jaor/xmobar.git"
-_gitname="xmobar"
+source=("${pkgname}::git+${_gitroot}")
+md5sums=('SKIP')
-build() {
- cd "${srcdir}"
- msg "Connecting to GIT server...."
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
+build() {
+ cd "${pkgname}"
- msg "GIT checkout done or server timeout"
- msg "Starting make..."
+ # XMOBAR INSTALLATION
+ # Several possible setup options are offered below. Choose whichever is
+ # best for you. Uncomment and recomment as necessary.
+ # See http://projects.haskell.org/xmobar/#optional-features for more information.
- rm -rf "${srcdir}/$_gitname-build"
- git clone "${srcdir}/$_gitname" "${srcdir}/$_gitname-build"
- cd "${srcdir}/$_gitname-build"
+ # Default setup.
+ runhaskell Setup configure --flags="with_xft with_iwlib" --prefix=/usr
- # XMOBAR INSTALLATION
- # Several possible setup options are offered below. Choose whichever is
- # best for you. Uncomment and recomment as necessary.
- # See http://projects.haskell.org/xmobar/#optional-features for more information.
+ # MPD Support. Must have `haskell-libmpd` installed.
+ # runhaskell Setup configure --flags="with_xft with_iwlib with_mpd" --prefix=/usr
- # Default setup.
- runhaskell Setup configure --flags="with_xft with_iwlib" --prefix=/usr
+ # Alsa Support. Must have `haskell-alsa-mixer` installed.
+ # Be warned, its dependencies can be troublesome.
+ # runhaskell Setup configure --flags="with_xft with_iwlib with_alsa" --prefix=/usr
- # MPD Support. Must have `haskell-libmpd` installed.
- # runhaskell Setup configure --flags="with_xft with_iwlib with_mpd" --prefix=/usr
+ # If you have _all_ of the optdepends installed, and want all extentions:
+ # runhaskell Setup configure --flags="all_extensions" --prefix=/usr
- # Alsa Support. Must have `haskell-alsa-mixer` installed.
- # Be warned, its dependencies can be troublesome.
- # runhaskell Setup configure --flags="with_xft with_iwlib with_alsa" --prefix=/usr
-
- # If you have _all_ of the optdepends installed, and want all extentions:
- # runhaskell Setup configure --flags="all_extensions" --prefix=/usr
- runhaskell Setup build
+ runhaskell Setup build
}
package() {
- cd "${srcdir}/$_gitname-build"
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 license ${pkgdir}/usr/share/licenses/$pkgname/BSD3
+ cd "${pkgname}"
+
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -Dm644 license ${pkgdir}/usr/share/licenses/$pkgname/BSD3
}