summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago Mota2021-11-11 17:17:58 -0300
committerThiago Mota2021-11-11 17:17:58 -0300
commit5c57294dfb92e4e9df9d230d9eda75006f57e139 (patch)
tree5a89b69033432c065a89ef6887e94978965da946
parent4f80d65d97c87e920dbb922af9b51c69faaa63ae (diff)
downloadaur-5c57294dfb92e4e9df9d230d9eda75006f57e139.tar.gz
automatic pkgver based on official xmobar pkg
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85d5c76b92b2..3a8858f43adc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xmobar-dynamic
pkgdesc = Minimalistic Text Based Status Bar
- pkgver = 0.39
- pkgrel = 24
+ pkgver = 0.39.rel24
+ pkgrel = 1
url = https://hackage.haskell.org/package/xmobar
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 6b91260a9894..5a808a3dd643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer Thiago Mota <thiagomota510@gmail.com>
pkgname=xmobar-dynamic
-pkgver=0.39
-pkgrel=24
+pkgver=0.39.rel24
+rpkgver=${pkgver%.*}
+pkgrel=1
pkgdesc='Minimalistic Text Based Status Bar'
url='https://hackage.haskell.org/package/xmobar'
license=('BSD')
@@ -19,19 +20,23 @@ depends=('libxft' 'libxinerama' 'libxrandr' 'libxpm' 'ghc-libs' 'haskell-x11'
'haskell-extensible-exceptions' 'haskell-http-conduit'
'haskell-http-types' 'haskell-http-client-tls' 'haskell-alsa-core' 'haskell-alsa-mixer')
makedepends=('ghc' 'uusi' 'haskell-hspec' 'haskell-temporary')
-source=(https://github.com/jaor/xmobar/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
+source=(https://github.com/jaor/xmobar/archive/${rpkgver}/${pkgname}-${rpkgver}.tar.gz
dynamic.patch)
sha512sums=('a47d7cf16fdea4bece1d622db1c2ac76acc9d9369043eec6ff41a22c1f59c9757932fbcebfe804a636c783e9a66317bb3aaf72edc4a373c48e7db3c9292d9658'
'7a8d6f157716c41f1e0f5749b79477fb560bb36c8f0eb244f9659a4e17918fb792b81e0622be00429445186e2a3f89caaa0bbdd30d3bd52975472e64502460f5')
prepare() {
- cd xmobar-${pkgver}
+ cd xmobar-${rpkgver}
patch -i "${srcdir}/dynamic.patch" src/Xmobar/App/Compile.hs
uusi -u base xmobar.cabal
}
+pkgver() {
+ pacman -Ss '^xmobar$' | head -1 | cut -d' ' -f2 | sed 's/-/.rel/'
+}
+
build() {
- cd xmobar-${pkgver}
+ cd xmobar-${rpkgver}
_flags=(with_xft with_utf8 with_inotify with_mpd with_alsa with_nl80211
with_datezone with_mpris with_dbus with_xpm with_threaded
@@ -56,12 +61,12 @@ build() {
}
check() {
- cd xmobar-${pkgver}
+ cd xmobar-${rpkgver}
runhaskell setup test
}
package() {
- cd xmobar-${pkgver}
+ cd xmobar-${rpkgver}
install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/xmobar.sh"
install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/xmobar.sh"
runhaskell setup copy --destdir="${pkgdir}"