summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeif Warner2015-09-01 14:33:56 -0700
committerLeif Warner2015-09-01 14:33:56 -0700
commit53b7e6fb4acae656d7503392ad043c8c5ba89360 (patch)
treed37ba72ed69f11074c1a75849de62dfe59bd60b7
downloadaur-53b7e6fb4acae656d7503392ad043c8c5ba89360.tar.gz
Initial import v20110814
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD64
-rw-r--r--xmonad-extras-darcs.install18
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9430780ebb92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = xmonad-extras-darcs
+ pkgdesc = Third party extensions for xmonad with wacky dependencies
+ pkgver = 20110814
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/xmonad-extras
+ install = xmonad-extras-darcs.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ makedepends = darcs
+ depends = haskell-x11>=1.4.3
+ depends = haskell-containers
+ depends = haskell-directory
+ depends = haskell-mtl
+ depends = haskell-old-locale
+ depends = haskell-old-time
+ depends = haskell-process
+ depends = haskell-random
+ depends = haskell-unix
+ depends = haskell-xmonad-contrib
+ depends = haskell-parsec
+ depends = haskell-split
+ provides = xmonad-extras
+ conflicts = xmonad-extras
+ options = staticlibs
+
+pkgname = xmonad-extras-darcs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca59db45c13e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Leif Warner <abimelech@gmail.com>
+_hkgname=xmonad-extras
+pkgname=xmonad-extras-darcs
+pkgver=20110814
+pkgrel=1
+pkgdesc="Third party extensions for xmonad with wacky dependencies"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=('darcs')
+provides=('xmonad-extras')
+conflicts=('xmonad-extras')
+depends=('haskell-x11>=1.4.3' 'haskell-containers' 'haskell-directory' 'haskell-mtl' 'haskell-old-locale' 'haskell-old-time' 'haskell-process' 'haskell-random' 'haskell-unix' 'haskell-xmonad-contrib'
+# Uncomment the following two lines for XMonad.Actions.Volume
+'haskell-parsec'
+'haskell-split'
+# Uncomment this for XMonad.Prompt.MPD
+# 'haskell-libmpd'
+# Uncomment this for XMonad.Util.WindowPropertiesRE
+# 'haskell-regex-posix'
+# Uncomment these two lines for XMonad.Actions.Eval & XMonad.Prompt.Eval
+# 'haskell-hint'
+# 'haskell-network'
+# Uncomment these two lines for XMonad.Config.Alt
+# 'haskell-hlist'
+# 'haskell-template-haskell'
+)
+options=('staticlibs')
+source=()
+install=${pkgname}.install
+
+_darcsmod="xmonad-extras"
+_darcstrunk="http://code.haskell.org"
+
+build() {
+ cd ${srcdir}
+ if [[ -d ${srcdir}/$_darcsmod/_darcs ]]
+ then
+ msg "Retrieving missing patches"
+ cd $_darcsmod
+ darcs pull -a $_darcstrunk/$_darcsmod
+ else
+ msg "Retrieving complete sources"
+ darcs get --set-scripts-executable $_darcstrunk/$_darcsmod
+ cd $_darcsmod
+ fi
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/xmonad-extras-darcs.install b/xmonad-extras-darcs.install
new file mode 100644
index 000000000000..8ec819220160
--- /dev/null
+++ b/xmonad-extras-darcs.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/xmonad-extras-darcs
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}