summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian2017-10-16 02:39:21 +0200
committerAlexander Sulfrian2017-10-16 02:39:21 +0200
commit51e4a1ae8c135e13029ffd88279df0dc2af75729 (patch)
treec917f7560541693bb32f8c40c1b69110a5a99b77
downloadaur-51e4a1ae8c135e13029ffd88279df0dc2af75729.tar.gz
Initial version
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84cc993ee73a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xmonad-log
+ pkgdesc = DBus monitor for xmonad log events
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/xintron/xmonad-log
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ makedepends = dbus-go
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/xintron/xmonad-log/archive/0.1.0.tar.gz
+ sha256sums = b08ca8db87c0418819f6f0c546fe18da336adbc9d0b3e95205bb2690095d6dd4
+
+pkgname = xmonad-log
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0cd1c4c079c3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0f4a235996d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander Sulfrian <asulfrian at zedat dot fu-berlin dot de>
+
+pkgname=xmonad-log
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="DBus monitor for xmonad log events"
+arch=('x86_64' 'i686')
+url="https://github.com/xintron/xmonad-log"
+license=('MIT')
+makedepends=('go' 'dbus-go')
+options=('!strip' '!emptydirs')
+source=("https://github.com/xintron/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('b08ca8db87c0418819f6f0c546fe18da336adbc9d0b3e95205bb2690095d6dd4')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname-$pkgver" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: