summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2023-11-29 13:57:07 +0100
committerChristopher Arndt2023-11-29 13:58:27 +0100
commitd268780dbe99d38ee73c756df13a44432af797e4 (patch)
tree6d550a2540dbf5c381f5d3a51117657407e29ecd
downloadaur-d268780dbe99d38ee73c756df13a44432af797e4.tar.gz
Moved from pkg xmonk-lv2-git and updated
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD54
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e2d945e48dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = xmonk.lv2-git
+ pkgdesc = A simple sound generator LV2 plugin to have some fun with (git version)
+ pkgver = 0.4.r56.3f69d90
+ pkgrel = 1
+ url = https://github.com/brummer10/Xmonk.lv2
+ arch = x86_64
+ groups = pro-audio
+ groups = lv2-plugins
+ license = 0BSD
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ depends = cairo
+ depends = libx11
+ provides = xmonk.lv2
+ provides = xmonk-lv2-git
+ conflicts = xmonk.lv2
+ conflicts = xmonk-lv2-git
+ source = Xmonk.lv2::git+https://github.com/brummer10/Xmonk.lv2.git
+ source = libxputty::git+https://github.com/brummer10/libxputty.git
+ source = libxputty-fix-asprintf.patch::https://github.com/brummer10/libxputty/commit/7eb70bf3f7bce0af9e1919d6c875cdb8efca734e.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 15fe7e3e2ec8efe62dc9bb4c0830eaf3ed0373cd39ebd755f2d9193710ebbf76
+
+pkgname = xmonk.lv2-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..13b7f58470cc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+libxputty/
+libxputty-fix-*.patch
+pkg/
+src/
+Xmonk.lv2/
+xmonk-lv2-git-*.pkg.tar.*
+xmonk-lv2-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50ff6361afe8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_name=Xmonk.lv2
+_pkgname=${_name,,}
+_plugin_uri="https://github.com/brummer10/$_name"
+pkgname=$_pkgname-git
+pkgver=0.4.r56.3f69d90
+pkgrel=1
+pkgdesc='A simple sound generator LV2 plugin to have some fun with (git version)'
+arch=(x86_64)
+url="https://github.com/brummer10/$_name"
+license=(0BSD)
+depends=(gcc-libs glibc cairo libx11)
+makedepends=(git)
+groups=(pro-audio lv2-plugins)
+provides=($_pkgname ${_pkgname/./-}-git)
+conflicts=($_pkgname ${_pkgname/./-}-git)
+source=("$_name::git+https://github.com/brummer10/$_name.git"
+ 'libxputty::git+https://github.com/brummer10/libxputty.git'
+ 'libxputty-fix-asprintf.patch::https://github.com/brummer10/libxputty/commit/7eb70bf3f7bce0af9e1919d6c875cdb8efca734e.patch')
+sha256sums=('SKIP'
+ 'SKIP'
+ '15fe7e3e2ec8efe62dc9bb4c0830eaf3ed0373cd39ebd755f2d9193710ebbf76')
+
+
+pkgver() {
+ cd $_name
+ local ver="$(grep '^\s*VER =' Xmonk/Makefile | cut -d ' ' -f 3)"
+ echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_name
+ git submodule init
+ git submodule set-url libxputty "$srcdir"/libxputty
+ git -c protocol.file.allow=always submodule update
+ cd libxputty
+ patch -p1 -N -r - -i "$srcdir"/libxputty-fix-asprintf.patch || true
+}
+
+build() {
+ cd $_name
+ make
+}
+
+check() {
+ lv2lint -M pack -I $_name/${_name/.lv2/}/$_name "$_plugin_uri"
+}
+
+package() {
+ cd $_name
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+}