summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrimi2015-06-08 18:49:27 +0200
committergrimi2015-06-08 18:49:27 +0200
commit3ebe671182c91e9a3f45965af126f1b94d65d3c6 (patch)
tree5893329fa93b98e4c63a426f230c47c9b0a09f77
downloadaur-3ebe671182c91e9a3f45965af126f1b94d65d3c6.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3f1cf56cfc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xmp
+ pkgdesc = The Extended Module Player is a portable command-line module player that supports over 90 module formats (Amiga, Atari, ..)
+ pkgver = 4.0.10
+ pkgrel = 1
+ url = http://xmp.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxmp
+ depends = libpulse
+ backup = etc/xmp/xmp.conf
+ backup = etc/xmp/modules.conf
+ source = http://downloads.sourceforge.net/sourceforge/xmp/xmp-4.0.10.tar.gz
+ md5sums = ffe79874f29aac2ac6da2f9f9bd72da0
+
+pkgname = xmp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de3891efc1af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: grimi <grimi at poczta dot fm>
+# Maintainer: speps <speps at aur dot archlinux dot org>
+# Contributor: john_schaf <john_schaf@hotmail.fr>
+
+pkgname=xmp
+pkgver=4.0.10
+pkgrel=1
+pkgdesc="The Extended Module Player is a portable command-line module player that supports over 90 module formats (Amiga, Atari, ..)"
+arch=(i686 x86_64)
+url="http://xmp.sourceforge.net/"
+license=('GPL')
+depends=('libxmp' 'libpulse')
+backup=('etc/xmp/xmp.conf' 'etc/xmp/modules.conf')
+source=("http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('ffe79874f29aac2ac6da2f9f9bd72da0')
+
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}
+