summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHui Yiqun2017-06-07 15:54:40 +0800
committerHui Yiqun2017-06-07 15:54:40 +0800
commitcdaf1f5fd6e34cf68acf4283d9ff92425afa6d18 (patch)
tree964ec81ea22115f09761fcc3aa192fe3f8abf75c
downloadaur-cdaf1f5fd6e34cf68acf4283d9ff92425afa6d18.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
-rw-r--r--no-donate.patch10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77713e1104eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xmr-stak-cpu-git
+ pkgdesc = Monero CPU miner
+ pkgver = r127.d0f991c
+ pkgrel = 1
+ url = https://github.com/nicehash/xmr-stak-cpu
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = libmicrohttpd
+ depends = openssl
+ source = git+https://github.com/fireice-uk/xmr-stak-cpu.git
+ sha256sums = SKIP
+
+pkgname = xmr-stak-cpu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2404076d0f05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=xmr-stak-cpu-git
+pkgver=r127.d0f991c
+pkgrel=1
+pkgdesc="Monero CPU miner"
+arch=('x86_64')
+url="https://github.com/nicehash/xmr-stak-cpu"
+license=('GPL3')
+makedepends=('git' 'cmake')
+depends=('libmicrohttpd' 'openssl')
+source=('git+https://github.com/fireice-uk/xmr-stak-cpu.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/xmr-stak-cpu"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/xmr-stak-cpu"
+ #patch -p1 -i ../../no-donate.patch
+}
+
+build() {
+ cd "$srcdir/xmr-stak-cpu"
+ cmake .
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ install -m 0755 "$srcdir/xmr-stak-cpu/bin/xmr-stak-cpu" "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/etc/"
+ install -m 0644 "$srcdir/xmr-stak-cpu/config.txt" "$pkgdir/etc/xmr-stak-cpu.json"
+}
diff --git a/no-donate.patch b/no-donate.patch
new file mode 100644
index 000000000000..8a04e9a2aab7
--- /dev/null
+++ b/no-donate.patch
@@ -0,0 +1,10 @@
+diff --git a/donate-level.h b/donate-level.h
+index 7b30212..02085c8 100644
+--- a/donate-level.h
++++ b/donate-level.h
+@@ -8,4 +8,4 @@
+ * Switching is instant, and only happens after a successful connection, so you never loose any hashes.
+ */
+
+-constexpr double fDevDonationLevel = 1.0 / 100.0;
++constexpr double fDevDonationLevel = 0.0 / 100.0;