summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-01-08 23:33:02 +0100
committerFelix Golatofski2020-01-08 23:33:02 +0100
commita9b92108a3e8ad2e0b19242ccea88ab30cfc50c9 (patch)
tree1653670c00f0d713b21f6f3fcfa929eab1631139
parentf2acf92caac1bbb06ea3a7205fe8d0cbaa281563 (diff)
downloadaur-a9b92108a3e8ad2e0b19242ccea88ab30cfc50c9.tar.gz
Changed over to new branch
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD44
-rw-r--r--no-donate.patch10
3 files changed, 31 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89dc54f20c4b..aa3d47e666d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = xmr-stak-nvidia-git
pkgdesc = Monero Miner (NVIDIA)
- pkgver = r38.915ed85
+ pkgver = r1457.67cf951
pkgrel = 1
- url = https://github.com/nicehash/xmr-stak-nvidia
+ url = https://github.com/fireice-urk/xmr-stak
arch = x86_64
license = GPL3
makedepends = git
@@ -10,10 +10,9 @@ pkgbase = xmr-stak-nvidia-git
depends = libmicrohttpd
depends = openssl
depends = cuda
- source = git+https://github.com/fireice-uk/xmr-stak-nvidia.git
- source = no-donate.patch
- sha256sums = SKIP
- sha256sums = b936a4db91f4c35e5ff0ac51c4c1590493ddf6427a82dd0e1f57ef931950e46f
+ depends = hwloc
+ source = git+https://github.com/fireice-uk/xmr-stak.git
+ sha512sums = SKIP
pkgname = xmr-stak-nvidia-git
diff --git a/PKGBUILD b/PKGBUILD
index a32e3f9afe0f..8402dd498748 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,47 @@
# Contributor: Saren Arterius <saren at wtako dot net>
# Contributor: Hui Yiqun <huiyiqun at gmail dot com>
pkgname=xmr-stak-nvidia-git
-pkgver=r38.915ed85
+pkgver=r1457.67cf951
pkgrel=1
pkgdesc="Monero Miner (NVIDIA)"
arch=('x86_64')
-url="https://github.com/nicehash/xmr-stak-nvidia"
+url="https://github.com/fireice-urk/xmr-stak"
license=('GPL3')
makedepends=('git' 'cmake')
-depends=('libmicrohttpd' 'openssl' 'cuda')
-source=('git+https://github.com/fireice-uk/xmr-stak-nvidia.git'
- 'no-donate.patch')
-sha256sums=('SKIP'
- 'b936a4db91f4c35e5ff0ac51c4c1590493ddf6427a82dd0e1f57ef931950e46f')
+depends=('libmicrohttpd' 'openssl' 'cuda' 'hwloc')
+source=('git+https://github.com/fireice-uk/xmr-stak.git')
+sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/xmr-stak-nvidia"
+ cd "$srcdir/xmr-stak"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/xmr-stak-nvidia"
- #patch -p1 -i ../../no-donate.patch
-}
-
build() {
- cd "$srcdir/xmr-stak-nvidia"
+ cd "$srcdir/xmr-stak"
+
+ mkdir build
+ cd build
+
+ # https://github.com/fireice-uk/xmr-stak/blob/master/doc/compile/compile_Linux.md
+ cmake \
+ .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_LINK_STATIC=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DMICROHTTPD_ENABLE=ON \
+ -DOpenSSL_ENABLE=ON \
+ -DXMR-STAK_COMPILE=native \
+ -DCPU_ENABLE=ON \
+ -DHWLOC_ENABLE=ON \
+ -DOpenCL_ENABLE=OFF \
+ -DCUDA_ENABLE=ON
- # CUDA 9 lacks support for architectures 20 and 21. Explicitly naming the remaining ones:
- CC=/usr/bin/gcc-6 CXX=/usr/bin/g++-6 cmake . -DCUDA_COMPILER="nvcc" -DCUDA_ARCH="30;32;35;37;50;52;53;60;61;62"
make
}
package() {
- install -D -m755 "$srcdir/xmr-stak-nvidia/bin/xmr-stak-nvidia" -t "$pkgdir/usr/bin/"
- install -D -m644 "$srcdir/xmr-stak-nvidia/config.txt" "$pkgdir/etc/xmr-stak-nvidia.json"
+ cd "xmr-stak/build"
+ make DESTDIR="$pkgdir/" install
}
diff --git a/no-donate.patch b/no-donate.patch
deleted file mode 100644
index 8a04e9a2aab7..000000000000
--- a/no-donate.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/donate-level.h b/donate-level.h
-index 7b30212..02085c8 100644
---- a/donate-level.h
-+++ b/donate-level.h
-@@ -8,4 +8,4 @@
- * Switching is instant, and only happens after a successful connection, so you never loose any hashes.
- */
-
--constexpr double fDevDonationLevel = 1.0 / 100.0;
-+constexpr double fDevDonationLevel = 0.0 / 100.0;