summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-02-17 14:39:59 +0000
committerHans-Nikolai Viessmann2019-02-17 14:39:59 +0000
commit24a674f62bef749744344911f9d54d3da43c7772 (patch)
tree6513a0535bf2bd7303383d33c1b719ee52f495ee
parent3b6abd819e23dd001804edfc9917a58f86147aa1 (diff)
downloadaur-24a674f62bef749744344911f9d54d3da43c7772.tar.gz
bump to 2.12.0
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md34
-rw-r--r--PKGBUILD8
3 files changed, 42 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 928a0aaa6c1b..fbb42575c35c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-bin
pkgdesc = Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level
- pkgver = 2.8.3
+ pkgver = 2.12.0
pkgrel = 1
url = https://github.com/xmrig/xmrig
install = xmrig.install
@@ -9,10 +9,10 @@ pkgbase = xmrig-bin
license = GPL
depends = glibc
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig/releases/download/v2.8.3/xmrig-2.8.3-xenial-amd64.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig/v2.8.3/README.md
- md5sums = 0ce630da99b6c81f6a6d2d4a6dd5c0ed
- md5sums = c4be72c7a852afe6a7b8ce042b1d063a
+ source = https://github.com/xmrig/xmrig/releases/download/v2.12.0/xmrig-2.12.0-xenial-x64.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig/v2.12.0/README.md
+ md5sums = 2087c4002eed30ebf0f79c091879a86c
+ md5sums = 4f18b339fa6ce249539e412574ea9f65
pkgname = xmrig-bin
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e6e646d3be1a..a9624400fe9f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,37 @@
+# v2.12.0
+- [#929](https://github.com/xmrig/xmrig/pull/929) Added support for new algorithm `cryptonight/wow`, short alias `cn/wow` (also known as CryptonightR), for upcoming [Wownero](http://wownero.org) fork on February 14.
+
+# v2.11.0
+- [#928](https://github.com/xmrig/xmrig/issues/928) Added support for new algorithm `cryptonight/gpu`, short alias `cn/gpu` (original name `cryptonight-gpu`), for upcoming [Ryo currency](https://ryo-currency.com) fork on February 14.
+- [#749](https://github.com/xmrig/xmrig/issues/749) Added support for detect hardware AES in runtime on ARMv8 platforms.
+- [#292](https://github.com/xmrig/xmrig/issues/292) Fixed build on ARMv8 platforms if compiler not support hardware AES.
+
+# v2.10.0
+- [#904](https://github.com/xmrig/xmrig/issues/904) Added new algorithm `cn-pico/trtl` (aliases `cryptonight-turtle`, `cn-trtl`) for upcoming TurtleCoin (TRTL) fork.
+- Default value for option `max-cpu-usage` changed to `100` also this option now deprecated.
+
+# v2.9.4
+- [#913](https://github.com/xmrig/xmrig/issues/913) Fixed Masari (MSR) support (this update required for upcoming fork).
+- [#915](https://github.com/xmrig/xmrig/pull/915) Improved security, JIT memory now read-only after patching.
+
+# v2.9.3
+- [#909](https://github.com/xmrig/xmrig/issues/909) Fixed compile errors on FreeBSD.
+- [#912](https://github.com/xmrig/xmrig/pull/912) Fixed, C++ implementation of `cn/half` was produce up to 13% of invalid hashes.
+
+# v2.9.2
+- [#907](https://github.com/xmrig/xmrig/pull/907) Fixed crash on Linux.
+
+# v2.9.1
+- Restored compatibility with https://stellite.hashvault.pro.
+
+# v2.9.0
+- [#899](https://github.com/xmrig/xmrig/issues/899) Added support for new algorithm `cn/half` for Masari and Stellite forks.
+- [#834](https://github.com/xmrig/xmrig/pull/834) Added ASM optimized code for AMD Bulldozer.
+- [#839](https://github.com/xmrig/xmrig/issues/839) Fixed FreeBSD compile.
+- [#857](https://github.com/xmrig/xmrig/pull/857) Fixed impossible to build for macOS without clang.
+
# v2.8.3
-- [#813](https://github.com/xmrig/xmrig/issues/813) Fixed critical bug in Minergate pool with variant 2.
+- [#813](https://github.com/xmrig/xmrig/issues/813) Fixed critical bug with Minergate pool and variant 2.
# v2.8.1
- [#768](https://github.com/xmrig/xmrig/issues/768) Fixed build with Visual Studio 2015.
diff --git a/PKGBUILD b/PKGBUILD
index c9d8eeb19849..1f341d540c70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
_pkgname=xmrig
pkgname=${_pkgname}-bin
-pkgver=2.8.3
+pkgver=2.12.0
pkgrel=1
pkgdesc="Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level"
arch=('x86_64')
@@ -11,10 +11,10 @@ depends=('glibc')
optdepends=('monero: wallet')
install=${_pkgname}.install
changelog=CHANGELOG.md
-source=("https://github.com/xmrig/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-xenial-amd64.tar.gz"
+source=("https://github.com/xmrig/xmrig/releases/download/v${pkgver}/${_pkgname}-${pkgver}-xenial-x64.tar.gz"
"https://raw.githubusercontent.com/xmrig/xmrig/v${pkgver}/README.md")
-md5sums=('0ce630da99b6c81f6a6d2d4a6dd5c0ed'
- 'c4be72c7a852afe6a7b8ce042b1d063a')
+md5sums=('2087c4002eed30ebf0f79c091879a86c'
+ '4f18b339fa6ce249539e412574ea9f65')
package() {
cd "${_pkgname}-$pkgver"