summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-06-21 19:33:03 +0100
committerHans-Nikolai Viessmann2018-06-21 19:33:03 +0100
commit80ca199d3934ebbd89f4d52aceaea2caff4fab77 (patch)
tree22d04cb3bd4a0dd0721f86b9759e8c70ae600ba0
parent546f5c39d96e91d8742ecb9c5ed787fbfe847d74 (diff)
downloadaur-80ca199d3934ebbd89f4d52aceaea2caff4fab77.tar.gz
bump to version 2.6.3
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md11
-rw-r--r--PKGBUILD6
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 661a647cd7be..7f4a7b34c07b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-bin
pkgdesc = Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level
- pkgver = 2.6.2
+ pkgver = 2.6.3
pkgrel = 1
url = https://github.com/xmrig/xmrig
install = xmrig.install
@@ -9,10 +9,10 @@ pkgbase = xmrig-bin
license = GPL
depends = glibc
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig/releases/download/v2.6.2/xmrig-2.6.2-xenial-amd64.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig/v2.6.2/README.md
- md5sums = 001f6e297081607fe0cc234a99ce43a9
- md5sums = 189a1483ad90895eb18337fc9d01cdd7
+ source = https://github.com/xmrig/xmrig/releases/download/v2.6.3/xmrig-2.6.3-xenial-amd64.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig/v2.6.3/README.md
+ md5sums = dd36396e5fd96291315140cd658a56c0
+ md5sums = 83a66c67b836e0c0b7f32f1960759735
pkgname = xmrig-bin
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c99e646f461a..4b8f8a671955 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,14 @@
+# v2.6.3
+- **Added support for new cryptonight-heavy variant xhv** (`cn-heavy/xhv`) for upcoming Haven Protocol fork.
+- **Added support for new cryptonight variant msr** (`cn/msr`) also known as `cryptonight-fast` for upcoming Masari fork.
+- Added new detailed hashrate report.
+- [#446](https://github.com/xmrig/xmrig/issues/446) Likely fixed SIGBUS error on 32 bit ARM CPUs.
+- [#551](https://github.com/xmrig/xmrig/issues/551) Fixed `cn-heavy` algorithm on ARMv8.
+- [#614](https://github.com/xmrig/xmrig/issues/614) Fixed display issue with huge pages percentage when colors disabled.
+- [#615](https://github.com/xmrig/xmrig/issues/615) Fixed build without libcpuid.
+- [#629](https://github.com/xmrig/xmrig/pull/629) Fixed file logging with non-seekable files.
+- [#672](https://github.com/xmrig/xmrig/pull/672) Reverted back `cryptonight-light` and exit if no valid algorithm specified.
+
# v2.6.2
- [#607](https://github.com/xmrig/xmrig/issues/607) Fixed donation bug.
- [#610](https://github.com/xmrig/xmrig/issues/610) Fixed ARM build.
diff --git a/PKGBUILD b/PKGBUILD
index 72a831a80c24..e1f1f32ca102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
_pkgname=xmrig
pkgname=${_pkgname}-bin
-pkgver=2.6.2
+pkgver=2.6.3
pkgrel=1
pkgdesc="Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level"
arch=('x86_64')
@@ -13,8 +13,8 @@ install=${_pkgname}.install
changelog=CHANGELOG.md
source=("https://github.com/xmrig/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-xenial-amd64.tar.gz"
"https://raw.githubusercontent.com/xmrig/xmrig/v${pkgver}/README.md")
-md5sums=('001f6e297081607fe0cc234a99ce43a9'
- '189a1483ad90895eb18337fc9d01cdd7')
+md5sums=('dd36396e5fd96291315140cd658a56c0'
+ '83a66c67b836e0c0b7f32f1960759735')
package() {
cd "${_pkgname}-$pkgver"