summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-12-01 16:36:41 +0100
committerHans-Nikolai Viessmann2019-12-01 16:36:41 +0100
commit86931a494c97dc63c1925198de2393bf211f657e (patch)
tree43651292f646dd24bf214fca021a4791e421e057
parentf824de4789968ae59700f4c6e6cad330c0a3dfb3 (diff)
downloadaur-86931a494c97dc63c1925198de2393bf211f657e.tar.gz
bump version to 5.1.0
-rw-r--r--.SRCINFO11
-rw-r--r--CHANGELOG.md10
-rw-r--r--PKGBUILD9
3 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e26180fe2a9..7a64844d5176 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-bin
pkgdesc = Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level
- pkgver = 5.0.1
+ pkgver = 5.1.0
pkgrel = 1
url = https://github.com/xmrig/xmrig
install = xmrig.install
@@ -9,13 +9,14 @@ pkgbase = xmrig-bin
license = GPL
depends = glibc
optdepends = monero: wallet
+ optdepends = xmrig-cuda: CUDA plugin to mine on NVidia GPU
provides = xmrig
conflicts = xmrig
replaces = xmrig
- source = https://github.com/xmrig/xmrig/releases/download/v5.0.1/xmrig-5.0.1-xenial-x64.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig/v5.0.1/README.md
- md5sums = ae1d2aef3fb9808cf68cd2a5334b2605
- md5sums = 5ea59462c852286746050b0ab6d32a51
+ source = https://github.com/xmrig/xmrig/releases/download/v5.1.0/xmrig-5.1.0-xenial-x64.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig/v5.1.0/README.md
+ md5sums = 4404e786ff8636d2184261bd61072e9d
+ md5sums = 9579101c49e73625325237bff5066335
pkgname = xmrig-bin
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 8fb2fc4a513f..d70d0fc73927 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,13 @@
+# v5.1.0
+- [#1351](https://github.com/xmrig/xmrig/pull/1351) RandomX optimizations and fixes.
+ - Improved RandomX performance (up to +6-7% on Intel CPUs, +2-3% on Ryzen CPUs)
+ - Added workaround for Intel JCC erratum bug see https://www.phoronix.com/scan.php?page=article&item=intel-jcc-microcode&num=1 for details.
+ - Note! Always disable "Hardware prefetcher" and "Adjacent cacheline prefetch" in BIOS for Intel CPUs to get the optimal RandomX performance.
+- [#1307](https://github.com/xmrig/xmrig/issues/1307) Fixed mining resume after donation round for pools with `self-select` feature.
+- [#1318](https://github.com/xmrig/xmrig/issues/1318#issuecomment-559676080) Added option `"mode"` (or `--randomx-mode`) for RandomX.
+ - Added memory information on miner startup.
+ - Added `resources` field to summary API with memory information and load average.
+
# v5.0.1
- [#1234](https://github.com/xmrig/xmrig/issues/1234) Fixed compatibility with some AMD GPUs.
- [#1284](https://github.com/xmrig/xmrig/issues/1284) Fixed build without RandomX.
diff --git a/PKGBUILD b/PKGBUILD
index c6fec5bf97bb..20753c435286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
_pkgname=xmrig
pkgname=${_pkgname}-bin
-pkgver=5.0.1
+pkgver=5.1.0
pkgrel=1
pkgdesc="Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level"
arch=('x86_64')
url="https://github.com/xmrig/xmrig"
license=('GPL')
depends=('glibc')
-optdepends=('monero: wallet')
+optdepends=('monero: wallet'
+ 'xmrig-cuda: CUDA plugin to mine on NVidia GPU')
provides=('xmrig')
conflicts=('xmrig')
replaces=('xmrig')
@@ -16,8 +17,8 @@ install=${_pkgname}.install
changelog=CHANGELOG.md
source=("https://github.com/xmrig/xmrig/releases/download/v${pkgver}/${_pkgname}-${pkgver}-xenial-x64.tar.gz"
"https://raw.githubusercontent.com/xmrig/xmrig/v${pkgver}/README.md")
-md5sums=('ae1d2aef3fb9808cf68cd2a5334b2605'
- '5ea59462c852286746050b0ab6d32a51')
+md5sums=('4404e786ff8636d2184261bd61072e9d'
+ '9579101c49e73625325237bff5066335')
package() {
cd "${_pkgname}-$pkgver"