summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-03-17 22:33:18 +0000
committerHans-Nikolai Viessmann2018-03-17 22:33:18 +0000
commit927f747ab1a0536bbb9c14cfe5c6bc0886ba4039 (patch)
tree6fc705e341d6fc9e855f8cdaa7834b54c499498c
parent5d5dbb340893d8f32bd914ab3f771a561d605135 (diff)
downloadaur-927f747ab1a0536bbb9c14cfe5c6bc0886ba4039.tar.gz
updated 2.5.0, supports Monero v7
-rw-r--r--.SRCINFO12
-rw-r--r--CHANGELOG.md9
-rw-r--r--PKGBUILD10
3 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46565c342593..b4b3503ebe24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-bin
- pkgdesc = Monero cryptocurrency CPU miner, HTTP API disabled
- pkgver = 2.4.5
+ pkgdesc = Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/xmrig/xmrig
install = xmrig.install
@@ -9,10 +9,10 @@ pkgbase = xmrig-bin
license = GPL
depends = glibc
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig/releases/download/v2.4.5/xmrig-2.4.5-gcc7-xenial-amd64-no-api.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig/v2.4.5/README.md
- md5sums = 1a139c54c353ac5e660686ab19cbc369
- md5sums = 421660aca4c27e3f51ed790313045b50
+ source = https://github.com/xmrig/xmrig/releases/download/v2.5.0/xmrig-2.5.0-xenial-amd64.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig/v2.5.0/README.md
+ md5sums = d9a6891440c73f16273178e5869ccf29
+ md5sums = 259324cd8ea066bc1ef600ace2925bc1
pkgname = xmrig-bin
diff --git a/CHANGELOG.md b/CHANGELOG.md
index c23c5d290968..b00b1f1d52cb 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,7 +1,14 @@
+# v2.5.0
+- [#434](https://github.com/xmrig/xmrig/issues/434) **Added support for Monero v7 PoW, scheduled on March 28.**
+- Added full IPv6 support.
+- Added protocol extension, when use the miner with xmrig-proxy 2.5+ no more need manually specify `nicehash` option.
+- [#123](https://github.com/xmrig/xmrig-proxy/issues/123) Fixed regression (all versions since 2.4 affected) fragmented responses from pool/proxy was parsed incorrectly.
+- [#428](https://github.com/xmrig/xmrig/issues/428) Fixed regression (version 2.4.5 affected) with CPU cache size detection.
+
# v2.4.5
- [#324](https://github.com/xmrig/xmrig/pull/324) Fixed build without libmicrohttpd (CMake cache issue).
- [#341](https://github.com/xmrig/xmrig/issues/341) Fixed wrong exit code and added command line option `--dry-run`.
-- [#385](https://github.com/xmrig/xmrig/pull/385) Up to 20% performance increase with for non-AES CPU and fixed Intel Core 2 cache detection.
+- [#385](https://github.com/xmrig/xmrig/pull/385) Up to 20% performance increase for non-AES CPU and fixed Intel Core 2 cache detection.
# v2.4.4
- Added libmicrohttpd version to --version output.
diff --git a/PKGBUILD b/PKGBUILD
index 9f037bdb7d76..f1fe1d7a28fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
_pkgname=xmrig
pkgname=${_pkgname}-bin
-pkgver=2.4.5
+pkgver=2.5.0
pkgrel=1
-pkgdesc="Monero cryptocurrency CPU miner, HTTP API disabled"
+pkgdesc="Monero cryptocurrency CPU miner, HTTP API enabled, with default donation level"
arch=('x86_64')
url="https://github.com/xmrig/xmrig"
license=('GPL')
@@ -11,10 +11,10 @@ depends=('glibc')
optdepends=('monero: wallet')
install=${_pkgname}.install
changelog=CHANGELOG.md
-source=("https://github.com/xmrig/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-gcc7-xenial-amd64-no-api.tar.gz"
+source=("https://github.com/xmrig/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-xenial-amd64.tar.gz"
"https://raw.githubusercontent.com/xmrig/xmrig/v${pkgver}/README.md")
-md5sums=('1a139c54c353ac5e660686ab19cbc369'
- '421660aca4c27e3f51ed790313045b50')
+md5sums=('d9a6891440c73f16273178e5869ccf29'
+ '259324cd8ea066bc1ef600ace2925bc1')
package() {
cd "${_pkgname}-$pkgver"