summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-05-23 11:19:05 +0100
committerHans-Nikolai Viessmann2018-05-23 11:19:05 +0100
commit1d53aa0b1533b224cb3bd1e03ebac0ded5bb2b7e (patch)
tree3fe5fe34b859fc4e8b42c24448480aacea3993cc
parentc1887705288ab0e5daa3674649912bd06e476183 (diff)
downloadaur-1d53aa0b1533b224cb3bd1e03ebac0ded5bb2b7e.tar.gz
version bump to 2.6.1
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md11
-rw-r--r--PKGBUILD5
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0913ebcda972..d4adf8e294c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-nvidia
pkgdesc = Monero cryptocurrency GPU miner, HTTP API disabled, donation percentage is 0.
- pkgver = 2.5.2
+ pkgver = 2.6.1
pkgrel = 1
url = https://github.com/xmrig/xmrig-nvidia
install = xmrig-nvidia.install
@@ -13,8 +13,8 @@ pkgbase = xmrig-nvidia
depends = libuv
depends = cuda>=9
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig-nvidia/archive/v2.5.2.tar.gz
- sha256sums = 5a8290cafdbf92ad1f16d45d6a385ef8e278f8a21cfd6a522a3074b2c2ba984d
+ source = https://github.com/xmrig/xmrig-nvidia/archive/v2.6.1.tar.gz
+ sha256sums = 189f55f60234d0d099266364f1f731af7deff81f4a7a56f34525563405cd0fd9
pkgname = xmrig-nvidia
diff --git a/CHANGELOG.md b/CHANGELOG.md
index e5daa770c6a1..cec311b5cd1f 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,10 +1,19 @@
+# v2.6.1
+- Fixed critical bug, in some cases miner was can't recovery connection and switch to failover pool, version 2.5.2 and v2.6.0-beta1 affected.
+- [#499](https://github.com/xmrig/xmrig/issues/499) IPv6 support disabled for internal HTTP API.
+- Added workaround for nicehash.com if you use `cryptonightv7.<region>.nicehash.com` option `variant=1` will be set automatically.
+
+# v2.6.0-beta1
+ - [#476](https://github.com/xmrig/xmrig/issues/476) **Added Cryptonight-Heavy support for Sumokoin and Haven Protocol ASIC resistance fork.**
+ - Added short aliases for algorithm names: `cn`, `cn-lite` and `cn-heavy`.
+
# v2.5.2
- [#448](https://github.com/xmrig/xmrig/issues/478) Fixed broken reconnect.
# v2.5.1
- [#454](https://github.com/xmrig/xmrig/issues/454) Fixed build with libmicrohttpd version below v0.9.35.
- [#456](https://github.com/xmrig/xmrig/issues/459) Verbose errors related to donation pool was not fully silenced.
-- [#459](https://github.com/xmrig/xmrig/issues/459) Fixed regression (version 2.5.0 affected) with connection to **xmr.f2pool.com**.
+- [#459](https://github.com/xmrig/xmrig/issues/459) Fixed regression (version 2.5.0 affected) with connection to **xmr.f2pool.com**.
# v2.5.0
- [#434](https://github.com/xmrig/xmrig/issues/434) **Added support for Monero v7 PoW, scheduled on April 6.**
diff --git a/PKGBUILD b/PKGBUILD
index 4bc17affcbf6..96bff902cc61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
pkgname='xmrig-nvidia'
-pkgver=2.5.2
+pkgver=2.6.1
pkgrel=1
pkgdesc='Monero cryptocurrency GPU miner, HTTP API disabled, donation percentage is 0.'
arch=('x86_64')
@@ -13,7 +13,7 @@ license=('GPL')
install='xmrig-nvidia.install'
changelog=CHANGELOG.md
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('5a8290cafdbf92ad1f16d45d6a385ef8e278f8a21cfd6a522a3074b2c2ba984d')
+sha256sums=('189f55f60234d0d099266364f1f731af7deff81f4a7a56f34525563405cd0fd9')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -22,6 +22,7 @@ prepare() {
[ -d build ] || mkdir build
# reset default donate level
+ msg2 "Reseting donation level to zero"
sed -i -e 's/constexpr const int kDonateLevel = 5;/constexpr const int kDonateLevel = 0;/g' src/donate.h
}