summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-03-17 22:34:24 +0000
committerHans-Nikolai Viessmann2018-03-17 22:34:24 +0000
commit490cf6e770dd782d06774cf48f6262349eac7011 (patch)
tree323356e9b45298ec68220f881ce2b9563a81b5e2
parent9debf33ce57cd8b4fb19a8f267ebd8f0b184bf18 (diff)
downloadaur-490cf6e770dd782d06774cf48f6262349eac7011.tar.gz
updated to 2.5.0, includes support for Monero v7
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md8
-rw-r--r--PKGBUILD6
3 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70908895f7b3..d1c71540646e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xmrig-nvidia
pkgdesc = Monero cryptocurrency GPU miner, HTTP API disabled
- pkgver = 2.4.5
+ pkgver = 2.5.0
pkgrel = 1
url = https://github.com/xmrig/xmrig-nvidia
changelog = CHANGELOG.md
@@ -12,10 +12,10 @@ pkgbase = xmrig-nvidia
depends = libuv
depends = cuda>=9
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig-nvidia/archive/v2.4.5.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v2.4.5/README.md
- sha256sums = b8865a332c5202031c56141a4b0ae4d2034c4998923749a0d68f2a2f16af9b49
- sha256sums = a202320bf2916f44813dd217d8ba0930fe062e3ec8b2492b2e6ee562039c2b8a
+ source = https://github.com/xmrig/xmrig-nvidia/archive/v2.5.0.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v2.5.0/README.md
+ sha256sums = 459c072f4aaf1c6eb0d35d14a2c7acdb62204bb249aba79f47853c5a3068bf17
+ sha256sums = 261a0ff3bf231aa7df694b9794a22defd3232df7ee1d6d5bcef29eda3a6dddf7
pkgname = xmrig-nvidia
diff --git a/CHANGELOG.md b/CHANGELOG.md
index dbbd13b7f467..61f82d3cdbc0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,11 @@
+# v2.5.0
+- [#434](https://github.com/xmrig/xmrig/issues/434) **Added support for Monero v7 PoW, scheduled on March 28.**
+- Improved automatic configuration, previous may give not usable suggested config.
+- Added full IPv6 support.
+- Added protocol extension, when use the miner with xmrig-proxy 2.5+ no more need manually specify `nicehash` option.
+- [#51](https://github.com/xmrig/xmrig-amd/issues/51) Fixed multiple pools in initial config was saved incorrectly.
+- [#123](https://github.com/xmrig/xmrig-proxy/issues/123) Fixed regression (all versions since 2.4 affected) fragmented responses from pool/proxy was parsed incorrectly.
+
# v2.4.5
- [#49](https://github.com/xmrig/xmrig-amd/issues/49) Fixed, in some cases, pause was cause an infinite loop.
- [#64](https://github.com/xmrig/xmrig-nvidia/issues/64) Fixed compatibility with CUDA 9.1.
diff --git a/PKGBUILD b/PKGBUILD
index ee03d0c180be..11a52d150ed9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
pkgname='xmrig-nvidia'
-pkgver=2.4.5
+pkgver=2.5.0
pkgrel=1
pkgdesc='Monero cryptocurrency GPU miner, HTTP API disabled'
arch=('x86_64')
@@ -13,8 +13,8 @@ license=('GPL')
changelog=CHANGELOG.md
source=("${url}/archive/v${pkgver}.tar.gz"
"https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v${pkgver}/README.md")
-sha256sums=('b8865a332c5202031c56141a4b0ae4d2034c4998923749a0d68f2a2f16af9b49'
- 'a202320bf2916f44813dd217d8ba0930fe062e3ec8b2492b2e6ee562039c2b8a')
+sha256sums=('459c072f4aaf1c6eb0d35d14a2c7acdb62204bb249aba79f47853c5a3068bf17'
+ '261a0ff3bf231aa7df694b9794a22defd3232df7ee1d6d5bcef29eda3a6dddf7')
prepare() {
cd "${pkgname}-${pkgver}"