summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-03-07 12:05:02 +0000
committerHans-Nikolai Viessmann2018-03-07 12:05:02 +0000
commit9debf33ce57cd8b4fb19a8f267ebd8f0b184bf18 (patch)
treecba05fef0c4b70c323e78ef7eb3a8079f552aa94
parentfc1ab5facc8a525142f406107a9144e7d6354ddb (diff)
downloadaur-9debf33ce57cd8b4fb19a8f267ebd8f0b184bf18.tar.gz
updated to 2.4.5
-rw-r--r--.SRCINFO16
-rw-r--r--CHANGELOG.md9
-rw-r--r--PKGBUILD20
-rw-r--r--README.md105
4 files changed, 24 insertions, 126 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ada3c2dc67dc..70908895f7b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xmrig-nvidia
pkgdesc = Monero cryptocurrency GPU miner, HTTP API disabled
- pkgver = 2.4.2
- pkgrel = 4
+ pkgver = 2.4.5
+ pkgrel = 1
url = https://github.com/xmrig/xmrig-nvidia
changelog = CHANGELOG.md
arch = x86_64
@@ -10,14 +10,12 @@ pkgbase = xmrig-nvidia
makedepends = libuv
makedepends = cuda-toolkit
depends = libuv
- depends = cuda
+ depends = cuda>=9
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig-nvidia/archive/v2.4.2.tar.gz
- source = README.md
- source = CHANGELOG.md
- sha256sums = 9a51fb5494131ec516bfd708c82ebf6eb2b39309181ca7e395b581ab5299d267
- sha256sums = fb078354728344095ad35ca85d26ffd69ea89de293ca2950ed40e5bce16d576b
- sha256sums = 17207f715a2b1245965ac95d68273bd853235db2e4446ffdbc5de39770e3c22f
+ source = https://github.com/xmrig/xmrig-nvidia/archive/v2.4.5.tar.gz
+ source = https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v2.4.5/README.md
+ sha256sums = b8865a332c5202031c56141a4b0ae4d2034c4998923749a0d68f2a2f16af9b49
+ sha256sums = a202320bf2916f44813dd217d8ba0930fe062e3ec8b2492b2e6ee562039c2b8a
pkgname = xmrig-nvidia
diff --git a/CHANGELOG.md b/CHANGELOG.md
index ba7b2b6513ad..dbbd13b7f467 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,12 @@
+# v2.4.5
+ - [#49](https://github.com/xmrig/xmrig-amd/issues/49) Fixed, in some cases, pause was cause an infinite loop.
+ - [#64](https://github.com/xmrig/xmrig-nvidia/issues/64) Fixed compatibility with CUDA 9.1.
+ - [#84](https://github.com/xmrig/xmrig-nvidia/issues/84) In some cases miner was doesn't write log to stdout.
+ - Added libmicrohttpd version to --version output.
+ - Fixed bug in singal handler, in some cases miner wasn't shutdown properly.
+ - Fixed recent MSVC 2017 version detection.
+ - Fixed, config file options `cuda-bfactor` and `cuda-bsleep` was ignored.
+
# v2.4.2
- Added [HTTP API](https://github.com/xmrig/xmrig/wiki/API).
- Added CUDA 9 and Volta GPUs support.
diff --git a/PKGBUILD b/PKGBUILD
index 7b22ea27e9fe..ee03d0c180be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
pkgname='xmrig-nvidia'
-pkgver=2.4.2
-pkgrel=4
+pkgver=2.4.5
+pkgrel=1
pkgdesc='Monero cryptocurrency GPU miner, HTTP API disabled'
arch=('x86_64')
url='https://github.com/xmrig/xmrig-nvidia'
-depends=('libuv' 'cuda')
+depends=('libuv' 'cuda>=9')
optdepends=('monero: wallet')
makedepends=('cmake' 'libuv' 'cuda-toolkit')
license=('GPL')
changelog=CHANGELOG.md
source=("${url}/archive/v${pkgver}.tar.gz"
- "README.md"
- "CHANGELOG.md")
-sha256sums=('9a51fb5494131ec516bfd708c82ebf6eb2b39309181ca7e395b581ab5299d267'
- 'fb078354728344095ad35ca85d26ffd69ea89de293ca2950ed40e5bce16d576b'
- '17207f715a2b1245965ac95d68273bd853235db2e4446ffdbc5de39770e3c22f')
+ "https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v${pkgver}/README.md")
+sha256sums=('b8865a332c5202031c56141a4b0ae4d2034c4998923749a0d68f2a2f16af9b49'
+ 'a202320bf2916f44813dd217d8ba0930fe062e3ec8b2492b2e6ee562039c2b8a')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -24,16 +22,14 @@ prepare() {
# create build dir
[ -d build ] || mkdir build
- # fix compilation issue affecting CUDA9.1 (is backwards compatible)
- # NOTE: only needed for xmrig-nvidia version 2.4.2, already fixed upstream
- sed -i -e 's/#include <device_functions.hpp>/#include <device_functions.h>/' src/nvidia/cuda_extra.cu
-
# reset default donate level
sed -i -e 's/constexpr const int kDonateLevel = 5;/constexpr const int kDonateLevel = 0;/g' src/donate.h
}
build() {
cd "${pkgname}-${pkgver}/build"
+
+ # the C/CXX flags are specific to CUDA 9/9.1 which has a hard dep on gcc6
cmake -DWITH_HTTPD=OFF -DCMAKE_C_COMPILER=gcc-6 -DCMAKE_CXX_COMPILER=g++-6 ..
make
}
diff --git a/README.md b/README.md
deleted file mode 100644
index de0dd3b864fd..000000000000
--- a/README.md
+++ /dev/null
@@ -1,105 +0,0 @@
-# XMRig
-XMRig is high performance Monero (XMR) NVIDIA miner, with the official full Windows support.
-
-GPU mining part based on [psychocrypt](https://github.com/psychocrypt) code used in xmr-stak-nvidia.
-
-* This is the NVIDIA GPU mining version, there is also a [CPU version](https://github.com/xmrig/xmrig).
-
-<img src="https://i.imgur.com/wRCZ3IJ.png" width="620" >
-
-#### Table of contents
-* [Features](#features)
-* [Download](#download)
-* [Usage](#usage)
-* [Build](https://github.com/xmrig/xmrig-nvidia/wiki/Build)
-* [Donations](#donations)
-* [Contacts](#contacts)
-
-## Features
-* High performance.
-* Official Windows support.
-* Support for backup (failover) mining server.
-* CryptoNight-Lite support for AEON.
-* Automatic GPU configuration.
-* GPU health monitoring (clocks, power, temperature, fan speed)
-* Nicehash support.
-* It's open source software.
-
-## Download
-* Binary releases: https://github.com/xmrig/xmrig-nvidia/releases
-* Git tree: https://github.com/xmrig/xmrig-nvidia.git
- * Clone with `git clone https://github.com/xmrig/xmrig-nvidia.git` :hammer: [Build instructions](https://github.com/xmrig/xmrig-nvidia/wiki/Build).
-
-## Usage
-
-### Command line options
-```
- -a, --algo=ALGO cryptonight (default) or cryptonight-lite
- -o, --url=URL URL of mining server
- -O, --userpass=U:P username:password pair for mining server
- -u, --user=USERNAME username for mining server
- -p, --pass=PASSWORD password for mining server
- -k, --keepalive send keepalived for prevent timeout (need pool support)
- -r, --retries=N number of times to retry before switch to backup server (default: 5)
- -R, --retry-pause=N time to pause between retries (default: 5)
- --no-color disable colored output
- --donate-level=N donate level, default 5% (5 minutes in 100 minutes)
- --user-agent set custom user-agent string for pool
- -B, --background run the miner in the background
- -c, --config=FILE load a JSON-format configuration file
- -l, --log-file=FILE log all output to a file
- --nicehash enable nicehash support
- --print-time=N print hashrate report every N seconds
- -h, --help display this help and exit
- -V, --version output version information and exit
-
-Auto-configuration specific options:
- --bfactor=[0-12] run CryptoNight core kernel in smaller pieces
- from 0 (ui freeze) to 12 (smooth), Windows default is 6
- --bsleep=N insert a delay of N microseconds between kernel launches
- --max-gpu-threads=N limit maximum count of GPU threads
-```
-
-### Config file.
-GPU configuration now possible only via config file. Sample config:
-```json
-{
- "background": false,
- "colors": true,
- "donate-level": 5,
- "log-file": null,
- "print-time": 60,
- "retries": 5,
- "retry-pause": 5,
- "syslog": false,
- "threads": [
- {
- "index": 0,
- "threads": 42,
- "blocks": 18,
- "bfactor": 6,
- "bsleep": 25
- }
- ],
- "pools": [
- {
- "url": "pool.minemonero.pro:5555",
- "user": "",
- "pass": "x",
- "keepalive": true,
- "nicehash": false
- }
- ]
-}
-```
-If `threads` option not specified the miner will try automatically create optimal configuration for your GPUs.
-
-## Donations
-Default donation 5% (5 minutes in 100 minutes) can be reduced to 1% via command line option `--donate-level`.
-
-* XMR: `48edfHu7V9Z84YzzMa6fUueoELZ9ZRXq9VetWzYGzKt52XU5xvqgzYnDK9URnRoJMk1j8nLwEVsaSWJ4fhdUyZijBGUicoD`
-* BTC: `1P7ujsXeX7GxQwHNnJsRMgAdNkFZmNVqJT`
-
-## Contacts
-* support@xmrig.com
-* [reddit](https://www.reddit.com/user/XMRig/)