summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2018-03-31 15:51:49 +0100
committerHans-Nikolai Viessmann2018-03-31 15:51:49 +0100
commitc1887705288ab0e5daa3674649912bd06e476183 (patch)
treed3633fc27f30312b15a655a54f6d57fec4490478
parent490cf6e770dd782d06774cf48f6262349eac7011 (diff)
downloadaur-c1887705288ab0e5daa3674649912bd06e476183.tar.gz
updated to 2.5.2
-rw-r--r--.SRCINFO11
-rw-r--r--CHANGELOG.md10
-rw-r--r--PKGBUILD15
-rw-r--r--xmrig-nvidia.install12
4 files changed, 33 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1c71540646e..0913ebcda972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = xmrig-nvidia
- pkgdesc = Monero cryptocurrency GPU miner, HTTP API disabled
- pkgver = 2.5.0
+ pkgdesc = Monero cryptocurrency GPU miner, HTTP API disabled, donation percentage is 0.
+ pkgver = 2.5.2
pkgrel = 1
url = https://github.com/xmrig/xmrig-nvidia
+ install = xmrig-nvidia.install
changelog = CHANGELOG.md
arch = x86_64
license = GPL
@@ -12,10 +13,8 @@ pkgbase = xmrig-nvidia
depends = libuv
depends = cuda>=9
optdepends = monero: wallet
- source = https://github.com/xmrig/xmrig-nvidia/archive/v2.5.0.tar.gz
- source = https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v2.5.0/README.md
- sha256sums = 459c072f4aaf1c6eb0d35d14a2c7acdb62204bb249aba79f47853c5a3068bf17
- sha256sums = 261a0ff3bf231aa7df694b9794a22defd3232df7ee1d6d5bcef29eda3a6dddf7
+ source = https://github.com/xmrig/xmrig-nvidia/archive/v2.5.2.tar.gz
+ sha256sums = 5a8290cafdbf92ad1f16d45d6a385ef8e278f8a21cfd6a522a3074b2c2ba984d
pkgname = xmrig-nvidia
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 61f82d3cdbc0..e5daa770c6a1 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,13 @@
+# v2.5.2
+- [#448](https://github.com/xmrig/xmrig/issues/478) Fixed broken reconnect.
+
+# v2.5.1
+- [#454](https://github.com/xmrig/xmrig/issues/454) Fixed build with libmicrohttpd version below v0.9.35.
+- [#456](https://github.com/xmrig/xmrig/issues/459) Verbose errors related to donation pool was not fully silenced.
+- [#459](https://github.com/xmrig/xmrig/issues/459) Fixed regression (version 2.5.0 affected) with connection to **xmr.f2pool.com**.
+
# v2.5.0
-- [#434](https://github.com/xmrig/xmrig/issues/434) **Added support for Monero v7 PoW, scheduled on March 28.**
+- [#434](https://github.com/xmrig/xmrig/issues/434) **Added support for Monero v7 PoW, scheduled on April 6.**
- Improved automatic configuration, previous may give not usable suggested config.
- Added full IPv6 support.
- Added protocol extension, when use the miner with xmrig-proxy 2.5+ no more need manually specify `nicehash` option.
diff --git a/PKGBUILD b/PKGBUILD
index 11a52d150ed9..4bc17affcbf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
pkgname='xmrig-nvidia'
-pkgver=2.5.0
+pkgver=2.5.2
pkgrel=1
-pkgdesc='Monero cryptocurrency GPU miner, HTTP API disabled'
+pkgdesc='Monero cryptocurrency GPU miner, HTTP API disabled, donation percentage is 0.'
arch=('x86_64')
url='https://github.com/xmrig/xmrig-nvidia'
depends=('libuv' 'cuda>=9')
optdepends=('monero: wallet')
makedepends=('cmake' 'libuv' 'cuda-toolkit')
license=('GPL')
+install='xmrig-nvidia.install'
changelog=CHANGELOG.md
-source=("${url}/archive/v${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/xmrig/xmrig-nvidia/v${pkgver}/README.md")
-sha256sums=('459c072f4aaf1c6eb0d35d14a2c7acdb62204bb249aba79f47853c5a3068bf17'
- '261a0ff3bf231aa7df694b9794a22defd3232df7ee1d6d5bcef29eda3a6dddf7')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('5a8290cafdbf92ad1f16d45d6a385ef8e278f8a21cfd6a522a3074b2c2ba984d')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -38,6 +37,6 @@ package() {
cd "${pkgname}-${pkgver}"
install -Dm775 "build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 src/config.json "${pkgdir}/usr/share/doc/xmrig-nvidia/config.json.example"
- install -Dm644 "${srcdir}/README.md" "${pkgdir}/usr/share/doc/xmrig-nvidia/README.md"
- install -Dm644 "${srcdir}/CHANGELOG.md" "${pkgdir}/usr/share/doc/xmrig-nvidia/CHANGELOG.md"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/xmrig-nvidia/README.md"
+ install -Dm644 CHANGELOG.md "${pkgdir}/usr/share/doc/xmrig-nvidia/CHANGELOG.md"
}
diff --git a/xmrig-nvidia.install b/xmrig-nvidia.install
new file mode 100644
index 000000000000..52f43955bbb4
--- /dev/null
+++ b/xmrig-nvidia.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo ""
+ echo "Example config.json file is located at:"
+ echo " /usr/share/docs/xmrig-nvidia/config.json.example"
+ echo ""
+ echo "Don't forget to use \`--config' when using xmrig."
+ echo ""
+}
+
+post_upgrade() {
+ post_install
+}