summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2015-06-09 00:28:49 +0100
committerEmmanuel Gil Peyrot2015-06-09 00:28:49 +0100
commitf304f95312d37b4050fee71d5b8739f692e932bd (patch)
treec35a92eaa55c0e5a92c59693ccfa3d520e4bd750
downloadaur-f304f95312d37b4050fee71d5b8739f692e932bd.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--fix-alignment.patch37
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ab03f8c279e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = xnp2
+ pkgdesc = X Neko Project II, a PC-9801 emulator
+ pkgver = 20140607
+ pkgrel = 2
+ url = http://www.nonakap.org/np2/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = gtk2
+ depends = sdl_mixer
+ source = http://www.nonakap.org/np2/xnp2-20140607.tar.bz2
+ source = fix-alignment.patch
+ md5sums = 4e2e01bc75479ef196b0056a78d31bd6
+ md5sums = 8aa797282e965289d59b1ca0c7160435
+
+pkgname = xnp2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe16872e9330
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Score_Under <seejay.11@gmail.com>
+
+pkgname=xnp2
+pkgver=20140607
+pkgrel=2
+pkgdesc="X Neko Project II, a PC-9801 emulator"
+arch=('i686' 'x86_64')
+url="http://www.nonakap.org/np2/"
+license=('BSD')
+depends=('gtk2' 'sdl_mixer')
+source=("http://www.nonakap.org/np2/${pkgname}-${pkgver}.tar.bz2"
+ "fix-alignment.patch")
+md5sums=('4e2e01bc75479ef196b0056a78d31bd6'
+ '8aa797282e965289d59b1ca0c7160435')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p0 < ../fix-alignment.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/x11"
+ ./configure --prefix=/usr --enable-ia32
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/x11"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sts=2 sw=2 et:
diff --git a/fix-alignment.patch b/fix-alignment.patch
new file mode 100644
index 000000000000..69ea170bbc0d
--- /dev/null
+++ b/fix-alignment.patch
@@ -0,0 +1,37 @@
+--- x11/gtk2/gtk_wrapper.c 2014-06-07 02:05:23.000000000 +0000
++++ x11/gtk2/gtk_wrapper.c 2014-11-04 16:43:15.844542526 +0000
+@@ -124,14 +124,29 @@
+ static gint orig_x, orig_y;
+
+ static inline Bool
+-XF86VidModeGetModeInfo(Display *d, int s, XF86VidModeModeInfo *info)
++XF86VidModeGetModeInfo(Display *dpy, int scr, XF86VidModeModeInfo *info)
+ {
+- XF86VidModeModeLine *line;
++ // Slightly adapted from SDL_x11modes.c
++ Bool retval;
++ XF86VidModeModeLine l;
+
+- memset(info, 0, sizeof(*info));
+- line = (void *)((char *)info + sizeof(info->dotclock));
++ memset(&l, 0, sizeof(l));
++ retval = XF86VidModeGetModeLine(dpy, scr, &info->dotclock, &l);
+
+- return XF86VidModeGetModeLine(d, s, (int *)&info->dotclock, line);
++ info->hdisplay = l.hdisplay;
++ info->hsyncstart = l.hsyncstart;
++ info->hsyncend = l.hsyncend;
++ info->htotal = l.htotal;
++ info->hskew = l.hskew;
++ info->vdisplay = l.vdisplay;
++ info->vsyncstart = l.vsyncstart;
++ info->vsyncend = l.vsyncend;
++ info->vtotal = l.vtotal;
++ info->flags = l.flags;
++ info->privsize = l.privsize;
++ info->private = l.private;
++
++ return retval;
+ }
+
+ static int