summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-07-25 12:24:54 +0200
committerGustavo Alvarez2016-07-25 12:24:54 +0200
commit1b3362e1a8e55489c0317b589833d8a46ef16959 (patch)
treef0c6ea09b9dfc1a35534e3450d8193ec75e3e74e
downloadaur-1b3362e1a8e55489c0317b589833d8a46ef16959.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d67fd33cbac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jul 25 10:24:54 UTC 2016
+pkgbase = xnp2-svn
+ pkgdesc = X Neko Project II, a PC-9801 emulator. (SVN Version)
+ pkgver = 0.86.2805
+ pkgrel = 1
+ url = http://www.nonakap.org/np2
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = gtk2
+ depends = sdl2_mixer
+ provides = xnp2
+ source = xnp2::svn+http://amethyst.yui.ne.jp/svn/pc98/np2/trunk/
+ sha1sums = SKIP
+
+pkgname = xnp2-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..517dd126fdc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gustavo Alvarez Lopez <sl1pkn07@gmail.com>
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Score_Under <seejay.11@gmail.com>
+
+pkgname=xnp2-svn
+pkgver=0.86.2805
+pkgrel=1
+pkgdesc="X Neko Project II, a PC-9801 emulator. (SVN Version)"
+arch=('i686' 'x86_64')
+url='http://www.nonakap.org/np2'
+license=('BSD')
+depends=('gtk2'
+ 'sdl2_mixer'
+ )
+conclicts=('xnp2')
+provides=('xnp2')
+source=("xnp2::svn+http://amethyst.yui.ne.jp/svn/pc98/np2/trunk/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd xnp2
+ _ver="$(cat np2ver.h | grep -m1 'NP2VER_CORE' | sed 's|NP2|NPTWO|g' | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "${_ver}.$(svnversion)"
+}
+
+prepare() {
+ cd xnp2/x11
+ ./autogen.sh
+}
+
+build() {
+ cd xnp2/x11
+ ./configure \
+ --prefix=/usr \
+ --enable-build-all \
+ #--enable-gtk3
+ LC_ALL=C make
+}
+
+package() {
+ make -C "xnp2/x11" DESTDIR="${pkgdir}/" install
+}