aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew2020-07-09 18:01:11 -0400
committerMatthew2020-07-09 18:01:11 -0400
commit2e5d20e7e6e71d7da657429be82f3812246aa79d (patch)
treea8bf347cbb61c9d15de270b24bc2f1339f1b187d
downloadaur-2e5d20e7e6e71d7da657429be82f3812246aa79d.tar.gz
First PKGBUILD version.
-rwxr-xr-x.SRCINFO23
-rw-r--r--.gitignore4
-rwxr-xr-xPKGBUILD49
-rw-r--r--README.md2
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..57c1c8243ad9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xnp2kai-azo234
+ pkgver = rev.22
+ pkgrel = 1
+ pkgdesc = AZO234\'s version of Neko Project II kai. NP2kai is PC-9801 series emulator.
+ url = https://github.com/AZO234/NP2kai
+ source = https://github.com/AZO234/NP2kai/archive/$pkgver.tar.gz
+ arch = x86_64
+ license = MIT
+
+ md5sums = 502c7123224b542ec9daf904dcd96b3c
+
+ makedepends = automake
+ makedepends = git
+ makedepends = cmake
+ makedepends = glibc
+
+ depends = libx11
+ depends = gtk2
+ depends = sdl2
+ depends = sdl2_ttf
+ depends = sdl2_mixer
+ depends = libusb
+pkgname = xnp2kai-azo234
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..32f0ae164510
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..e6c4a9d197a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Matt Kleiner <mkleinertwosixsevenzero@liamg.moc>
+
+pkgname="xnp2kai-azo234"
+pkgver="rev.22"
+pkgrel="1"
+pkgdesc="AZO234's version of Neko Project II kai. NP2kai is PC-9801 series emulator."
+url="https://github.com/AZO234/NP2kai"
+source=("https://github.com/AZO234/NP2kai/archive/$pkgver.tar.gz")
+arch=("x86_64")
+license=("MIT")
+md5sums=("502c7123224b542ec9daf904dcd96b3c")
+
+makedepends=(
+ "automake"
+ "cmake"
+ "glibc"
+)
+
+depends=(
+ "libx11"
+ "gtk2"
+ "sdl2"
+ "sdl2_ttf"
+ "sdl2_mixer"
+ "libusb"
+)
+
+prepare() {
+ tar -xf "$pkgver.tar.gz"
+}
+
+build() {
+ cd "$srcdir/NP2kai-$pkgver/x11"
+ ./autogen.sh
+ ./configure --enable-ia32
+ make
+}
+
+check() {
+ cd "$srcdir/NP2kai-$pkgver/x11"
+ if [[ -e "xnp21kai" ]]; then
+ echo 'Checks passed!'
+ fi
+}
+
+package() {
+ cd "$srcdir/NP2kai-$pkgver/x11"
+ make prefix="$pkgdir/usr/" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..73da32905f9c
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# xnp2kai-azo234
+PKGBUILD by me for AZO234's version of Neko Project II Kai (X11/SDL2): https://github.com/AZO234/NP2kai