summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brodsky2017-01-17 19:35:44 +0000
committerKevin Brodsky2017-01-17 22:12:54 +0000
commit046b879cc8aa7d8bd0faddc8685098362fdd7375 (patch)
treeccef99d93c9b903a31027d6c20548ce8609eb378
parent201705cf225d7c94398efaaf724dd099760f73c2 (diff)
downloadaur-046b879cc8aa7d8bd0faddc8685098362fdd7375.tar.gz
updpkg: 0.84 + remove bundled libs
The bundled libs are broken in 0.84, some Qt 5 libraries are 5.6.1 and others 5.6.2, the former depending on icu 54 and the latter on icu 56, which is not even provided. Since it actually works with the system libs, let's remove all that mess. It may break at some point, but at least for now it's the easiest option (and it's also much better to use the system libs). Also added some cleanup (we use our own desktop file).
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49ff18ad13ff..d00b0b670e20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Oct 9 15:58:45 UTC 2016
+# Tue Jan 17 22:12:42 UTC 2017
pkgbase = xnviewmp
pkgdesc = An efficient multimedia viewer, browser and converter.
- pkgver = 0.83
+ pkgver = 0.84
pkgrel = 1
url = http://www.xnview.com/en/xnviewmp/
arch = x86_64
@@ -20,9 +20,9 @@ pkgbase = xnviewmp
depends = qt5-x11extras
optdepends = gvfs: support for moving files to trash
source_x86_64 = http://download.xnview.com/XnViewMP-linux-x64.tgz
- md5sums_x86_64 = 3c2c5032a0be2b1f0976b50adad8c80b
+ md5sums_x86_64 = bbb8bfac5a212103830c9b1dca51c2ae
source_i686 = http://download.xnview.com/XnViewMP-linux.tgz
- md5sums_i686 = 4673c827de8aa326761433b2eda85a6b
+ md5sums_i686 = 75e9e03aa41da988eb66524574794b31
pkgname = xnviewmp
diff --git a/PKGBUILD b/PKGBUILD
index 035092af623b..0df97ff47ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Martin Poljak <martin 'at' poljak 'dot' cz>
pkgname=xnviewmp
-pkgver=0.83
+pkgver=0.84
pkgrel=1
pkgdesc="An efficient multimedia viewer, browser and converter."
url="http://www.xnview.com/en/xnviewmp/"
@@ -18,10 +18,10 @@ license=('custom')
depends=('glib2' 'expat' 'libpng12' 'gstreamer0.10-base' 'desktop-file-utils' 'libxslt' 'qt5-multimedia' 'qt5-webkit' 'qt5-svg' 'qt5-x11extras')
optdepends=('gvfs: support for moving files to trash')
-source_i686=("http://download.xnview.com/XnViewMP-linux.tgz")
source_x86_64=("http://download.xnview.com/XnViewMP-linux-x64.tgz")
-md5sums_x86_64=('3c2c5032a0be2b1f0976b50adad8c80b')
-md5sums_i686=('4673c827de8aa326761433b2eda85a6b')
+md5sums_x86_64=('bbb8bfac5a212103830c9b1dca51c2ae')
+source_i686=("http://download.xnview.com/XnViewMP-linux.tgz")
+md5sums_i686=('75e9e03aa41da988eb66524574794b31')
package() {
install -d -m755 "${pkgdir}/opt/${pkgname}"
@@ -33,6 +33,15 @@ package() {
install -m644 "${startdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -D -m644 "${srcdir}/XnView/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Remove the bundled framework libs (Qt and icu). They don't even work in 0.84,
+ # and at least for now it works with the system libraries. Also everyone likes
+ # dividing their package size by 4 :-)
+ rm "${pkgdir}/opt/${pkgname}/lib/"lib*
+
+ # Clean up
+ rm "${pkgdir}/opt/${pkgname}/XnView.desktop"{,~}
+ chmod -x "${pkgdir}/opt/${pkgname}/xnview.png"
}
# vim:set ts=2 sw=2 et: