summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brodsky2017-02-12 19:10:56 +0000
committerKevin Brodsky2017-02-12 19:10:56 +0000
commit6bec52c17223cfd9e753e3eec9ad648cbe09f0bb (patch)
tree95e53e4e847ddf5fff82efe7613478517e8c170c
parent65092ecc9ca1e0a22a7cfdb55aaaffaedfb6747e (diff)
downloadaur-6bec52c17223cfd9e753e3eec9ad648cbe09f0bb.tar.gz
updpkg: 0.84-3
So apparently setting QT_QPA_PLATFORMTHEME was not enough to fix the font issue. I found out that using QT_PLUGIN_PATH=/usr/lib/qt/plugins didn't work for me because of an obscure issue in the OpenGL xcb integration. So my idea was to use the system Qt plugins, but not the whole directory as some stuff doesn't work. Symlinking just platforms and platformthemes seems to do the trick: no segfault and no font problem. Do keep in mind that this package is experimental and things may break as I am experimenting. But of course, when this happens, let me know and I'll try my best to make it work for everyone.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1509d9fc086b..eac6fabd6420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Feb 8 22:41:59 UTC 2017
+# Sun Feb 12 19:10:53 UTC 2017
pkgbase = xnviewmp-system-libs
pkgdesc = An efficient multimedia viewer, browser and converter (using system libraries).
pkgver = 0.84
- pkgrel = 2
+ pkgrel = 3
url = http://www.xnview.com/en/xnviewmp/
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 1008fc717ca5..4dfaa5924a69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=xnviewmp-system-libs
_pkgname=xnviewmp
pkgver=0.84
srcrel=2 # Incremented when there is a new release for the same version number
-pkgrel=2
+pkgrel=3
pkgdesc="An efficient multimedia viewer, browser and converter (using system libraries)."
url="http://www.xnview.com/en/xnviewmp/"
@@ -38,6 +38,11 @@ package() {
# Remove the bundled framework libs (Qt and icu).
rm "${pkgdir}/opt/${_pkgname}/lib/"lib*
+ # Since we are using system Qt libraries, we should also use the system Qt
+ # plugins. Remove the provided platform plugins and symlink the system ones
+ # instead.
+ rm -r "${pkgdir}/opt/${_pkgname}/lib/"platform{s,themes}
+ ln -s /usr/lib/qt/plugins/platform{s,themes} "${pkgdir}/opt/${_pkgname}/lib"
# XnView MP does a weird font lookup with random results under certain
# circumstances, when not using the bundled libs. It seems that forcing
# QT_QPA_PLATFORMTHEME to be the shipped platform theme solves the issue.