summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Brodsky2017-04-27 22:40:14 +0100
committerKevin Brodsky2017-04-27 22:40:14 +0100
commitbd0b15707dc329e342fdc93dc222c16c2123c610 (patch)
treec8089fd9244e13c09880e212b1403adfbabecba5
parent2b11f9530468cd4be7175cddc765b8ebd9019fe5 (diff)
downloadaur-bd0b15707dc329e342fdc93dc222c16c2123c610.tar.gz
updpkg: 0.86 + more library pruning
It turns out everything in lib/ should come from the system, so we can gain a bit more space by removing all the provided libraries (except those in Plugins/).
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af3c1cb6690e..d52cf1d212b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Apr 4 23:57:38 UTC 2017
+# Thu Apr 27 21:39:18 UTC 2017
pkgbase = xnviewmp-system-libs
pkgdesc = An efficient multimedia viewer, browser and converter (using system libraries).
- pkgver = 0.85
+ pkgver = 0.86
pkgrel = 1
url = http://www.xnview.com/en/xnviewmp/
arch = x86_64
@@ -17,10 +17,10 @@ pkgbase = xnviewmp-system-libs
conflicts = xnviewmp
source = xnviewmp.desktop
md5sums = 24f44d5a881b94daf48775213a57e4ec
- source_x86_64 = XnViewMP-linux-x64_0.85-rel1.tgz::http://download.xnview.com/XnViewMP-linux-x64.tgz
- md5sums_x86_64 = d38f9c051714342713750cbe818c4d93
- source_i686 = XnViewMP-linux_0.85-rel1.tgz::http://download.xnview.com/XnViewMP-linux.tgz
- md5sums_i686 = 1681b4d2597895bf50a3c12c63fc0a38
+ source_x86_64 = XnViewMP-linux-x64_0.86-rel1.tgz::http://download.xnview.com/XnViewMP-linux-x64.tgz
+ md5sums_x86_64 = 5a6ebf3495b8f333130f5e3f18c51433
+ source_i686 = XnViewMP-linux_0.86-rel1.tgz::http://download.xnview.com/XnViewMP-linux.tgz
+ md5sums_i686 = 36e1b668e052d5a2b30a120a129cbc80
pkgname = xnviewmp-system-libs
diff --git a/PKGBUILD b/PKGBUILD
index 394d34d0c3d5..12fb25fa0fdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=xnviewmp-system-libs
_pkgname=xnviewmp
-pkgver=0.85
+pkgver=0.86
srcrel=1 # Incremented when there is a new release for the same version number
pkgrel=1
pkgdesc="An efficient multimedia viewer, browser and converter (using system libraries)."
@@ -18,8 +18,8 @@ source=('xnviewmp.desktop')
source_x86_64=("XnViewMP-linux-x64_${pkgver}-rel${srcrel}.tgz::http://download.xnview.com/XnViewMP-linux-x64.tgz")
source_i686=("XnViewMP-linux_${pkgver}-rel${srcrel}.tgz::http://download.xnview.com/XnViewMP-linux.tgz")
md5sums=('24f44d5a881b94daf48775213a57e4ec')
-md5sums_x86_64=('d38f9c051714342713750cbe818c4d93')
-md5sums_i686=('1681b4d2597895bf50a3c12c63fc0a38')
+md5sums_x86_64=('5a6ebf3495b8f333130f5e3f18c51433')
+md5sums_i686=('36e1b668e052d5a2b30a120a129cbc80')
package() {
install -d -m755 "${pkgdir}/opt/${_pkgname}"
@@ -39,10 +39,16 @@ package() {
# Remove the bundled framework libs (Qt and icu).
rm "${pkgdir}/opt/${_pkgname}/lib/"lib*
# Since we are using system Qt libraries, we should also use the system Qt
- # plugins. Remove the provided platform plugins and symlink the system ones
- # instead.
- rm -r "${pkgdir}/opt/${_pkgname}/lib/"platform{s,themes}
- ln -s /usr/lib/qt/plugins/platform{s,themes} "${pkgdir}/opt/${_pkgname}/lib"
+ # plugins. Unfortunately using the system path doesn't quite work because of a
+ # bug when Qt's loader tries to use libqxcb-egl-integration.so, which is
+ # not provided by XnView.
+ # As a workaround, remove the provided plugin directories and symlink the
+ # system ones instead.
+ local dir
+ for dir in "${pkgdir}/opt/${_pkgname}/lib/"*; do
+ rm -r "${dir}"
+ ln -s "/usr/lib/qt/plugins/$(basename "${dir}")" "${dir}"
+ done
# XnView MP does a weird font lookup with random results under certain
# circumstances, when not using the bundled libs. It seems that forcing
# QT_QPA_PLATFORMTHEME to be the shipped platform theme solves the issue.