summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Gahan2015-10-30 03:56:08 -0400
committerChris Gahan2015-10-30 03:56:08 -0400
commit4cfce327ed99c700407389db159fdcdc3d2240eb (patch)
treebb1b92ae722ada331329155f02ab13a90c3c5cbc
downloadaur-4cfce327ed99c700407389db159fdcdc3d2240eb.tar.gz
Now using github repository
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD51
-rw-r--r--xombrero-git.install12
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..592ae88b7451
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = xombrero-git
+ pkgdesc = minimalist web browser
+ pkgver = 1.6.4.3.g15fb608
+ pkgrel = 1
+ url = http://opensource.conformal.com/wiki/xombrero
+ install = xombrero-git.install
+ arch = i686
+ arch = x86_64
+ license = custom:ISC
+ makedepends = git
+ depends = webkitgtk
+ depends = libbsd
+ depends = desktop-file-utils
+ provides = xombrero
+ conflicts = xxxterm
+ conflicts = xombrero
+ conflicts = xombrero3
+ source = git+https://github.com/conformal/xombrero.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = f3eeb6e8b70a3dcccb8ee57daf584c9e
+
+pkgname = xombrero-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f3cc75ccd1a1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,16 @@
+/*
+ * Copyright (c) 2010 Marco Peereboom <marco@peereboom.us>
+ *
+ * Permission to use, copy, modify, and distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e16535d825a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: Splex
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Jérémie Astor <astor.jeremie@wanadoo.fr>
+
+_pkgname=xombrero
+pkgname=xombrero-git
+pkgver=1.6.4.3.g15fb608
+pkgrel=1
+pkgdesc="minimalist web browser"
+arch=('i686' 'x86_64')
+url="http://opensource.conformal.com/wiki/xombrero"
+license=('custom:ISC')
+depends=('webkitgtk' 'libbsd' 'desktop-file-utils')
+makedepends=('git')
+install=$pkgname.install
+provides=('xombrero')
+conflicts=('xxxterm' 'xombrero' 'xombrero3')
+source=('git+https://github.com/conformal/xombrero.git'
+ 'LICENSE')
+md5sums=('SKIP'
+ 'f3eeb6e8b70a3dcccb8ee57daf584c9e')
+
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed -e 's|-|.|g' -e 's|XOMBRERO_||' -e 's|_|.|g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ sed -i 's|/etc/ssl/cert.pem|/etc/ssl/certs/ca-certificates.crt|' xombrero.conf
+ sed -i 's|https://www.cyphertite.com|http://archlinux.org|' xombrero.{c,conf,h}
+ sed -i 's|/usr/local|/usr|' xombrero.{h,conf}
+ cd "linux"
+ sed -i 's|LIBS= gtk+-2.0|& javascriptcoregtk-1.0|' Makefile
+ sed -i 's/gnutls/& libbsd/' Makefile
+}
+
+build() {
+ cd "$srcdir/$_pkgname/"
+ make PREFIX="/usr" -C linux GTK_VERSION=gtk3
+}
+
+package() {
+ cd "$srcdir/$_pkgname/"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install -C linux GTK-VERSION=gtk3
+ install -Dm644 xombrero.conf "$pkgdir/etc/skel/xombrero.conf"
+ install -Dm644 xombrero.desktop "$pkgdir/usr/share/applications/xombrero.desktop"
+ install -Dm755 config-checker.pl "$pkgdir/usr/bin/config-checker.pl"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/xombrero-git.install b/xombrero-git.install
new file mode 100644
index 000000000000..d3289ab64233
--- /dev/null
+++ b/xombrero-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+