aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortukoz2016-05-24 23:47:29 +0200
committertukoz2016-05-24 23:47:29 +0200
commit3f3e4278932523fb1739e36a7d4b94f400dda6dd (patch)
tree3be16f4a97d71a162996b8d16e906d9cebc97bc4
downloadaur-3f3e4278932523fb1739e36a7d4b94f400dda6dd.tar.gz
Initial upload: xombrero-gtk2-git 1.6.4.7.g28d1406-1
Renammed to xombrero-gtk2-git.
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD51
-rw-r--r--README.md13
4 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cc62d34cce4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue May 24 21:47:30 UTC 2016
+pkgbase = xombrero-gtk2-git
+ pkgdesc = Minimalist web browser - gtk2 version
+ pkgver = 1.6.4.7.g28d1406
+ pkgrel = 1
+ url = https://github.com/conformal/xombrero/wiki
+ arch = i686
+ arch = x86_64
+ license = custom:ISC
+ makedepends = git
+ depends = webkitgtk2
+ depends = libbsd
+ depends = desktop-file-utils
+ provides = xombrero
+ conflicts = xxxterm
+ conflicts = xombrero
+ conflicts = xombrero3
+ conflicts = xombrero-git
+ source = git+https://github.com/conformal/xombrero.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = f3eeb6e8b70a3dcccb8ee57daf584c9e
+
+pkgname = xombrero-gtk2-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f3cc75ccd1a1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,16 @@
+/*
+ * Copyright (c) 2010 Marco Peereboom <marco@peereboom.us>
+ *
+ * Permission to use, copy, modify, and distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ */
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76f917d47e44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: Splex
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Jérémie Astor <astor.jeremie@wanadoo.fr>
+# Contributor: Cyrille Laloy <dev at tukoz dot it>
+
+_pkgname=xombrero
+pkgname=xombrero-gtk2-git
+pkgver=1.6.4.7.g28d1406
+pkgrel=1
+pkgdesc="Minimalist web browser - gtk2 version"
+arch=('i686' 'x86_64')
+url="https://github.com/conformal/xombrero/wiki"
+license=('custom:ISC')
+depends=('webkitgtk2' 'libbsd' 'desktop-file-utils')
+makedepends=('git')
+provides=('xombrero')
+conflicts=('xxxterm' 'xombrero' 'xombrero3' 'xombrero-git')
+source=('git+https://github.com/conformal/xombrero.git'
+ 'LICENSE')
+md5sums=('SKIP'
+ 'f3eeb6e8b70a3dcccb8ee57daf584c9e')
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname/"
+ git describe --always | sed -e 's|-|.|g' -e 's|XOMBRERO_||' -e 's|_|.|g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname/"
+ sed -i 's|/etc/ssl/cert.pem|/etc/ssl/certs/ca-certificates.crt|' xombrero.conf
+ sed -i 's|https://www.cyphertite.com|http://archlinux.org|' xombrero.{c,conf,h}
+ sed -i 's|/usr/local|/usr|' xombrero.{h,conf}
+ cd "linux"
+ sed -i 's|LIBS= gtk+-2.0|& javascriptcoregtk-1.0|' Makefile
+ sed -i 's/gnutls/& libbsd/' Makefile
+}
+
+build() {
+ cd "$srcdir/$_pkgname/"
+ make PREFIX="/usr" -C linux GTK_VERSION=gtk2
+}
+
+package() {
+ cd "$srcdir/$_pkgname/"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install -C linux GTK-VERSION=gtk2
+ install -Dm644 xombrero.conf "$pkgdir/etc/skel/xombrero.conf"
+ install -Dm644 xombrero.desktop "$pkgdir/usr/share/applications/xombrero.desktop"
+ install -Dm755 config-checker.pl "$pkgdir/usr/bin/config-checker.pl"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..dad98f802261
--- /dev/null
+++ b/README.md
@@ -0,0 +1,13 @@
+xombrero-gtk2
+===============
+
+xombrero is an incredibly light and efficient browser.
+
+The graph below shows you CPU, RAM usage, load average... and *the time* needed to load ten pages for xombrero and seven other browsers on an Atom N450 netbook.
+
+![browsers effi for 10 pages, Atom box, 2016](http://pic.al/RHc.gif)
+
+This is a Gtk2 build for Arch linux, as it gives more real estate room and is a bit lighter on resources than the default Gtk3 build (does depends on *webkitgtk2* not *webkitgtk*/*gtk3*).
+Forked from [epitron's PKGBUILD](https://aur.archlinux.org/packages/xombrero-git/)
+
+Architectures: x86 and x86_64 (Maybe it can build on ARM as well? would be nice).