summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormnovick19882016-02-02 16:06:52 -0500
committermnovick19882016-02-02 16:06:52 -0500
commit8f0dbc1878ca5baa5b686548f55f8f59b693012c (patch)
treec77d1c56bf5ad5ce61074eba993eb8841a8623b6
downloadaur-8f0dbc1878ca5baa5b686548f55f8f59b693012c.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD33
-rw-r--r--xonotic-dedicated.desktop8
-rw-r--r--xonotic-glx.desktop8
-rw-r--r--xonotic-sdl.desktop8
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63489eef2ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 21:06:11 UTC 2016
+pkgbase = xonotic-desktop
+ pkgdesc = shortcuts for Xonotic(glx,sdl,dedicated)
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://xonotic.org
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = armv8h
+ license = GPL
+ depends = xonotic
+ depends = xonotic-icons
+ conflicts = xonotic-desktop
+ source = xonotic-dedicated.desktop
+ source = xonotic-glx.desktop
+ source = xonotic-sdl.desktop
+ md5sums = 3c9c1a7583ccade9025adca0d16cf88c
+ md5sums = 9b1cb355a24ccca159499cca49c432dc
+ md5sums = d720d62419e7faf080d17217582cfbf1
+
+pkgname = xonotic-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eff50152ac8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: M Novick <mnovick1988@gmail.com>
+# Maintainer: M Rawash <mrawash@gmail.com>
+# Contributor: MrBougo <bougospam at gmail dot com>
+# Contributor: wido <widomaker2k7@gmail.com>
+# Contributor: Alexander Suhoverhov <cy at ngs dot ru>
+
+pkgname=xonotic-desktop
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="shortcuts for Xonotic(glx,sdl,dedicated)"
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'armv8h')
+url="http://xonotic.org"
+license=('GPL')
+depends=('xonotic' 'xonotic-icons')
+conflicts=('xonotic-desktop')
+
+source=('xonotic-dedicated.desktop'
+'xonotic-glx.desktop'
+'xonotic-sdl.desktop'
+)
+md5sums=('3c9c1a7583ccade9025adca0d16cf88c'
+ '9b1cb355a24ccca159499cca49c432dc'
+ 'd720d62419e7faf080d17217582cfbf1')
+
+
+
+package() {
+ msg "Building Package..."
+ mkdir -p "$pkgdir"/usr/share/applications
+ install -m755 xonotic-glx.desktop "$pkgdir"/usr/share/applications
+ install -m755 xonotic-sdl.desktop "$pkgdir"/usr/share/applications
+ install -m755 xonotic-dedicated.desktop "$pkgdir"/usr/share/applications
+}
diff --git a/xonotic-dedicated.desktop b/xonotic-dedicated.desktop
new file mode 100644
index 000000000000..ee7c488e1ef2
--- /dev/null
+++ b/xonotic-dedicated.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Xonotic-dedicated
+Categories=Qt;KDE;Game;Xonotic;
+Exec=xonotic-dedicated
+Icon=xonotic_icon.svg
+Terminal=false
+StartupNotify=false
diff --git a/xonotic-glx.desktop b/xonotic-glx.desktop
new file mode 100644
index 000000000000..563f12b5b83c
--- /dev/null
+++ b/xonotic-glx.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Xonotic-glx
+Categories=Qt;KDE;Game;Xonotic;
+Exec=xonotic-glx
+Icon=xonotic_icon.svg
+Terminal=false
+StartupNotify=false \ No newline at end of file
diff --git a/xonotic-sdl.desktop b/xonotic-sdl.desktop
new file mode 100644
index 000000000000..74076152cf6f
--- /dev/null
+++ b/xonotic-sdl.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Xonotic-sdl
+Categories=Qt;KDE;Game;Xonotic;
+Exec=xonotic-sdl
+Icon=xonotic_icon.svg
+Terminal=false
+StartupNotify=false