summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2015-11-08 21:20:54 +0100
committerDaniel Milde2015-11-08 21:20:54 +0100
commit53d0526df9774011f367458fded5ee0d2de07ca5 (patch)
tree431589fd31ef84e706f16c609d5a1c2832a18319
parent48a793158eab19624cdc140eae11e3ab79f62fb5 (diff)
downloadaur-53d0526df9774011f367458fded5ee0d2de07ca5.tar.gz
patch for installation of jupyter hook
-rw-r--r--0001-installation-of-jupyter-hook-to-given-destination.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/0001-installation-of-jupyter-hook-to-given-destination.patch b/0001-installation-of-jupyter-hook-to-given-destination.patch
new file mode 100644
index 000000000000..2f0b6457e63d
--- /dev/null
+++ b/0001-installation-of-jupyter-hook-to-given-destination.patch
@@ -0,0 +1,50 @@
+From c650bc8a2b901a9e8d0c09f11f2482cfa6a1daee Mon Sep 17 00:00:00 2001
+From: Daniel Milde <daniel@milde.cz>
+Date: Sun, 8 Nov 2015 21:15:08 +0100
+Subject: [PATCH] installation of jupyter hook to given destination
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 2996546..83984ba 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,7 +19,7 @@ except ImportError:
+ HAVE_SETUPTOOLS = False
+
+ try:
+- from jupyter_client.kernelspec import install_kernel_spec
++ from jupyter_client.kernelspec import KernelSpecManager
+ HAVE_JUPYTER = True
+ except ImportError:
+ HAVE_JUPYTER = False
+@@ -49,7 +49,7 @@ def build_tables():
+ sys.path.pop(0)
+
+
+-def install_jupyter_hook():
++def install_jupyter_hook(root=None):
+ if not HAVE_JUPYTER:
+ print('Could not install Jupyter kernel spec, please install Jupyter/IPython.')
+ return
+@@ -73,13 +73,13 @@ def install_jupyter_hook():
+ with open(os.path.join(d, 'kernel.json'), 'w') as f:
+ json.dump(spec, f, sort_keys=True)
+ print('Installing Jupyter kernel spec...')
+- install_kernel_spec(d, 'xonsh', user=('--user' in sys.argv), replace=True)
++ KernelSpecManager().install_kernel_spec(d, 'xonsh', user=('--user' in sys.argv), replace=True, prefix=root)
+
+ class xinstall(install):
+ def run(self):
+ clean_tables()
+ build_tables()
+- install_jupyter_hook()
++ install_jupyter_hook(self.root if self.root else None)
+ install.run(self)
+
+
+--
+2.6.2
+