summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2023-04-06 21:41:25 +0200
committerMichał Wojdyła2023-04-06 21:41:25 +0200
commita62f14f9260fd8c8ecb2a46f7da90e0ae04e1eed (patch)
treeca13040e7aabe63e0eea46017b0caa7a78dcee32
downloadaur-a62f14f9260fd8c8ecb2a46f7da90e0ae04e1eed.tar.gz
upload
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e16dfd954c6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xorg-ico
+ pkgdesc = A simple animation program that may be used for testing various X11 operations and extensions.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = x86_64
+ groups = xorg-apps
+ groups = xorg
+ license = custom
+ depends = libx11
+ source = https://xorg.freedesktop.org/archive/individual/app/ico-1.0.6.tar.gz
+ sha512sums = d6b15e516d34aa201eaac2ab53bd911825fb85e516f1efe15d85e2fb309fdd6155b24b0fbb98552dd12d2c6c271047ff94d0e9525b297bd165fefa55565de550
+
+pkgname = xorg-ico
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4c16f4a1e7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+
+pkgname=xorg-ico
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A simple animation program that may be used for testing various X11 operations and extensions."
+arch=(x86_64)
+url="https://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11')
+groups=('xorg-apps' 'xorg')
+source=(https://xorg.freedesktop.org/archive/individual/app/ico-${pkgver}.tar.gz)
+sha512sums=('d6b15e516d34aa201eaac2ab53bd911825fb85e516f1efe15d85e2fb309fdd6155b24b0fbb98552dd12d2c6c271047ff94d0e9525b297bd165fefa55565de550')
+
+build() {
+ cd ico-${pkgver}
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd ico-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+