summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2017-02-23 13:01:20 +0300
committerkyak2017-02-23 13:01:20 +0300
commit34c81e1caf39a276b49022613f87a4b4e6aed358 (patch)
tree08cacfb176aaec519729f87fddb3e8f416bf62eb
parent59070690a1d29d9129063389740fc42b3ffe3362 (diff)
downloadaur-34c81e1caf39a276b49022613f87a4b4e6aed358.tar.gz
Really fix the patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rw-r--r--freedesktop-bug-865.patch11
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 339d1ab5bab1..fa1b1e1cb47d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Feb 23 08:40:04 UTC 2017
+# Thu Feb 23 10:01:05 UTC 2017
pkgbase = xorg-server-bug865
pkgver = 1.19.1
pkgrel = 5
@@ -70,7 +70,7 @@ pkgbase = xorg-server-bug865
sha256sums = 914a8d775b708f836ae3f0eeca553da3872727a2e4262190f4d5c01241cb14e8
sha256sums = ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9
sha256sums = 2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776
- sha256sums = 96dc3539013bc44f6ea9f6f0142a5f4b5ef5975ecbd163971829effe7da8c6c6
+ sha256sums = 460615227a7e42d124639d4ae02e55d1b2a250c7bdf539e018b46de71230364f
pkgname = xorg-server-bug865
pkgdesc = Xorg X server with the patch for freedesktop bug 865 (need to kick hotkeys on release, not press)
diff --git a/PKGBUILD b/PKGBUILD
index 852ecc626eb5..033572527b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ sha256sums=('79ae2cf39d3f6c4a91201d8dad549d1d774b3420073c5a70d390040aa965a7fb'
'914a8d775b708f836ae3f0eeca553da3872727a2e4262190f4d5c01241cb14e8'
'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
'2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776'
- '96dc3539013bc44f6ea9f6f0142a5f4b5ef5975ecbd163971829effe7da8c6c6')
+ '460615227a7e42d124639d4ae02e55d1b2a250c7bdf539e018b46de71230364f')
prepare() {
cd "xorg-server-${pkgver}"
diff --git a/freedesktop-bug-865.patch b/freedesktop-bug-865.patch
index dd836782de4d..1611bf2e2417 100644
--- a/freedesktop-bug-865.patch
+++ b/freedesktop-bug-865.patch
@@ -1,6 +1,6 @@
--- xorg-server-1.19.1/xkb/xkbActions.c.orig 2017-01-12 18:34:23.435568903 +0300
-+++ xorg-server-1.19.1/xkb/xkbActions.c 2017-02-23 11:37:52.119502755 +0300
-@@ -351,26 +351,82 @@
++++ xorg-server-1.19.1/xkb/xkbActions.c 2017-02-23 12:58:00.719948700 +0300
+@@ -351,26 +351,83 @@
return 1;
}
@@ -15,7 +15,8 @@
+ XkbGroupAction ga = pAction->group;
+ if (ga.flags&XkbSA_GroupAbsolute)
+ xkbi->state.locked_group= XkbSAGroup(&ga);
-+ else xkbi->state.locked_group+= XkbSAGroup(&ga);
++ else
++ xkbi->state.locked_group+= XkbSAGroup(&ga);
+}
+
+static XkbFilterPtr _XkbNextFreeFilter(XkbSrvInfoPtr xkbi);
@@ -92,12 +93,12 @@
filter->upAction = *pAction;
if (!(filter->upAction.mods.flags & XkbSA_LockNoLock))
xkbi->state.locked_mods |= pAction->mods.mask;
-@@ -1244,9 +1300,12 @@
+@@ -1244,9 +1301,12 @@
*sendEvent = _XkbFilterLatchState(xkbi, filter, key, act);
break;
case XkbSA_LockMods:
+ filter = _XkbNextFreeFilter(xkbi);
-+ sendEvent=_XkbFilterLockMods(xkbi, filter, key, act);
++ *sendEvent = _XkbFilterLockMods(xkbi, filter, key, act);
+ break;
case XkbSA_LockGroup:
filter = _XkbNextFreeFilter(xkbi);