summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyak2021-12-21 20:19:32 +0300
committerkyak2021-12-21 20:19:32 +0300
commit76185bbe5240dbe7436c230ff904191f5e2a83a3 (patch)
tree78bc742aa5124bc12f84d9a50af748c51598f255
parent7aa2a909dab94360f9002f83d7e763cfd9b3d3c7 (diff)
downloadaur-76185bbe5240dbe7436c230ff904191f5e2a83a3.tar.gz
upgpkg: xorg-server 21.1.2-2: fix FS#73075
-rw-r--r--.SRCINFO6
-rw-r--r--0001-xf86-logind-Fix-compilation-error-when-built-without.patch94
-rw-r--r--0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch74
-rw-r--r--PKGBUILD10
4 files changed, 182 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbc636426639..5661a835fc08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xorg-server-bug865
pkgver = 21.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://xorg.freedesktop.org
arch = x86_64
groups = xorg
@@ -40,12 +40,16 @@ pkgbase = xorg-server-bug865
source = https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-21.1.2.tar.xz.sig
source = xvfb-run
source = xvfb-run.1
+ source = 0001-xf86-logind-Fix-compilation-error-when-built-without.patch
+ source = 0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch
source = freedesktop-bug-865.patch
validpgpkeys = FD0004A26EADFE43A4C3F249C6F7AE200374452D
sha512sums = 6d7a0d29d5be09f80ed505c4d6ae964795127525a0ab73a4eab4f601788ab3627033143e5aeb4c2565c6683dd3402084d13acab5554606fbd519c4aec0a79def
sha512sums = SKIP
sha512sums = 4154dd55702b98083b26077bf70c60aa957b4795dbf831bcc4c78b3cb44efe214f0cf8e3c140729c829b5f24e7466a24615ab8dbcce0ac6ebee3229531091514
sha512sums = de5e2cb3c6825e6cf1f07ca0d52423e17f34d70ec7935e9dd24be5fb9883bf1e03b50ff584931bd3b41095c510ab2aa44d2573fd5feaebdcb59363b65607ff22
+ sha512sums = f4f04d4bf98104bf22861f1e0f7434a3c2aedf6a67ce0fe39ed7b4186f162a03979ae6659c40d6e6816c735801c0691e5362375250a58c742ca089d35513297d
+ sha512sums = 906d13faf041cfb0e27923edcea134d33836f798ba3ee5f815cb3da8e219f5a10f25e05255552366a30e267bb14c6d1fdc02ed678ce3a6fcaaf7a63cd3057f3b
sha512sums = c3b541c7ac95c94f682577cacedc06e79427003a870cde844056a7662087873b59dc06933552bb867b16fc0387f8a061672df780454769f26aa3e53b13a94edf
pkgname = xorg-server-bug865
diff --git a/0001-xf86-logind-Fix-compilation-error-when-built-without.patch b/0001-xf86-logind-Fix-compilation-error-when-built-without.patch
new file mode 100644
index 000000000000..67fe5ac38a0a
--- /dev/null
+++ b/0001-xf86-logind-Fix-compilation-error-when-built-without.patch
@@ -0,0 +1,94 @@
+From 9c66d910cae107cbcda02a8502ac5324a6eca052 Mon Sep 17 00:00:00 2001
+From: Jocelyn Falempe <jfalempe@redhat.com>
+Date: Thu, 16 Dec 2021 15:46:43 +0100
+Subject: [PATCH 1/2] xf86/logind: Fix compilation error when built without
+ logind/platform bus
+
+This was introduced by commit 8eb1396d
+
+Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1269
+Fixes: da9d012a9 - xf86/logind: Fix drm_drop_master before vt_reldisp
+
+Signed-off-by: Jocelyn Falempe <jfalempe@redhat.com>
+Reviewed-by: Hans de Goede <hdegoede@redhat.com>
+Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
+---
+ hw/xfree86/common/xf86Events.c | 9 +--------
+ hw/xfree86/os-support/linux/systemd-logind.c | 16 +++++++++++-----
+ include/systemd-logind.h | 4 ++--
+ 3 files changed, 14 insertions(+), 15 deletions(-)
+
+diff --git a/hw/xfree86/common/xf86Events.c b/hw/xfree86/common/xf86Events.c
+index 6076efa80..395bbc7b3 100644
+--- a/hw/xfree86/common/xf86Events.c
++++ b/hw/xfree86/common/xf86Events.c
+@@ -383,14 +383,7 @@ xf86VTLeave(void)
+ xf86GPUScreens[i]->LeaveVT(xf86GPUScreens[i]);
+
+ if (systemd_logind_controls_session()) {
+- for (i = 0; i < xf86_num_platform_devices; i++) {
+- if (xf86_platform_devices[i].flags & XF86_PDEV_SERVER_FD) {
+- int major, minor;
+- major = xf86_platform_odev_attributes(i)->major;
+- minor = xf86_platform_odev_attributes(i)->minor;
+- systemd_logind_drop_master(major, minor);
+- }
+- }
++ systemd_logind_drop_master();
+ }
+
+ if (!xf86VTSwitchAway())
+diff --git a/hw/xfree86/os-support/linux/systemd-logind.c b/hw/xfree86/os-support/linux/systemd-logind.c
+index 35d5cc75b..f6a223a55 100644
+--- a/hw/xfree86/os-support/linux/systemd-logind.c
++++ b/hw/xfree86/os-support/linux/systemd-logind.c
+@@ -308,13 +308,19 @@ cleanup:
+ * and ensure the drm_drop_master is done before
+ * VT_RELDISP when switching VT
+ */
+-void systemd_logind_drop_master(int _major, int _minor)
++void systemd_logind_drop_master(void)
+ {
+- struct systemd_logind_info *info = &logind_info;
+- dbus_int32_t major = _major;
+- dbus_int32_t minor = _minor;
++ int i;
++ for (i = 0; i < xf86_num_platform_devices; i++) {
++ if (xf86_platform_devices[i].flags & XF86_PDEV_SERVER_FD) {
++ dbus_int32_t major, minor;
++ struct systemd_logind_info *info = &logind_info;
+
+- systemd_logind_ack_pause(info, minor, major);
++ major = xf86_platform_odev_attributes(i)->major;
++ minor = xf86_platform_odev_attributes(i)->minor;
++ systemd_logind_ack_pause(info, minor, major);
++ }
++ }
+ }
+
+ static DBusHandlerResult
+diff --git a/include/systemd-logind.h b/include/systemd-logind.h
+index a8af2b96d..5c04d0130 100644
+--- a/include/systemd-logind.h
++++ b/include/systemd-logind.h
+@@ -33,7 +33,7 @@ int systemd_logind_take_fd(int major, int minor, const char *path, Bool *paus);
+ void systemd_logind_release_fd(int major, int minor, int fd);
+ int systemd_logind_controls_session(void);
+ void systemd_logind_vtenter(void);
+-void systemd_logind_drop_master(int major, int minor);
++void systemd_logind_drop_master(void);
+ #else
+ #define systemd_logind_init()
+ #define systemd_logind_fini()
+@@ -41,7 +41,7 @@ void systemd_logind_drop_master(int major, int minor);
+ #define systemd_logind_release_fd(major, minor, fd) close(fd)
+ #define systemd_logind_controls_session() 0
+ #define systemd_logind_vtenter()
+-#define systemd_logind_drop_master(major, minor)
++#define systemd_logind_drop_master()
+ #endif
+
+ #endif
+--
+2.34.1
+
diff --git a/0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch b/0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch
new file mode 100644
index 000000000000..e13f4bd114d4
--- /dev/null
+++ b/0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch
@@ -0,0 +1,74 @@
+From 38291fa86c00e1d3ee37612c9215b0c15da89051 Mon Sep 17 00:00:00 2001
+From: Jocelyn Falempe <jfalempe@redhat.com>
+Date: Fri, 17 Dec 2021 10:18:25 +0100
+Subject: [PATCH 2/2] xf86/logind: fix missing call to vtenter if the platform
+ device is not paused
+
+If there is one platform device, which is not paused nor resumed,
+systemd_logind_vtenter() will never get called.
+This break suspend/resume, and switching to VT on system with Nvidia
+proprietary driver.
+This is a regression introduced by f5bd039633fa83
+
+So now call systemd_logind_vtenter() if there are no paused
+platform devices.
+
+Closes: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1271
+Fixes: f5bd0396 - xf86/logind: fix call systemd_logind_vtenter after receiving drm device resume
+
+Signed-off-by: Jocelyn Falempe <jfalempe@redhat.com>
+Tested-by: Olivier Fourdan <ofourdan@redhat.com>
+Reviewed-by: Hans de Goede <hdegoede@redhat.com>
+Signed-off-by: Laurent Carlier <lordheavym@gmail.com>
+---
+ hw/xfree86/os-support/linux/systemd-logind.c | 17 +++++++++++++----
+ 1 file changed, 13 insertions(+), 4 deletions(-)
+
+diff --git a/hw/xfree86/os-support/linux/systemd-logind.c b/hw/xfree86/os-support/linux/systemd-logind.c
+index f6a223a55..dbb00cd85 100644
+--- a/hw/xfree86/os-support/linux/systemd-logind.c
++++ b/hw/xfree86/os-support/linux/systemd-logind.c
+@@ -316,6 +316,7 @@ void systemd_logind_drop_master(void)
+ dbus_int32_t major, minor;
+ struct systemd_logind_info *info = &logind_info;
+
++ xf86_platform_devices[i].flags |= XF86_PDEV_PAUSED;
+ major = xf86_platform_odev_attributes(i)->major;
+ minor = xf86_platform_odev_attributes(i)->minor;
+ systemd_logind_ack_pause(info, minor, major);
+@@ -323,6 +324,16 @@ void systemd_logind_drop_master(void)
+ }
+ }
+
++static Bool are_platform_devices_resumed(void) {
++ int i;
++ for (i = 0; i < xf86_num_platform_devices; i++) {
++ if (xf86_platform_devices[i].flags & XF86_PDEV_PAUSED) {
++ return FALSE;
++ }
++ }
++ return TRUE;
++}
++
+ static DBusHandlerResult
+ message_filter(DBusConnection * connection, DBusMessage * message, void *data)
+ {
+@@ -416,13 +427,11 @@ message_filter(DBusConnection * connection, DBusMessage * message, void *data)
+
+ if (pdev) {
+ pdev->flags &= ~XF86_PDEV_PAUSED;
+- systemd_logind_vtenter();
+ } else
+ systemd_logind_set_input_fd_for_all_devs(major, minor, fd,
+ info->vt_active);
+-
+- /* Always call vtenter(), only if there are only legacy video devs */
+- if (!xf86_num_platform_devices)
++ /* Call vtenter if all platform devices are resumed, or if there are no platform device */
++ if (are_platform_devices_resumed())
+ systemd_logind_vtenter();
+ }
+ return DBUS_HANDLER_RESULT_HANDLED;
+--
+2.34.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 91840a49f375..2fafd4a31743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=xorg-server-bug865
pkgname=xorg-server-bug865
pkgver=21.1.2
-pkgrel=1
+pkgrel=2
arch=('x86_64')
license=('custom')
groups=('xorg')
@@ -20,17 +20,25 @@ makedepends=('xorgproto' 'pixman' 'libx11' 'mesa' 'mesa-libgl' 'xtrans'
source=(https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-${pkgver}.tar.xz{,.sig}
xvfb-run # with updates from FC master
xvfb-run.1
+ 0001-xf86-logind-Fix-compilation-error-when-built-without.patch
+ 0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch
freedesktop-bug-865.patch)
validpgpkeys=('FD0004A26EADFE43A4C3F249C6F7AE200374452D') # Povilas Kanapickas <povilas@radix.lt>
sha512sums=('6d7a0d29d5be09f80ed505c4d6ae964795127525a0ab73a4eab4f601788ab3627033143e5aeb4c2565c6683dd3402084d13acab5554606fbd519c4aec0a79def'
'SKIP'
'4154dd55702b98083b26077bf70c60aa957b4795dbf831bcc4c78b3cb44efe214f0cf8e3c140729c829b5f24e7466a24615ab8dbcce0ac6ebee3229531091514'
'de5e2cb3c6825e6cf1f07ca0d52423e17f34d70ec7935e9dd24be5fb9883bf1e03b50ff584931bd3b41095c510ab2aa44d2573fd5feaebdcb59363b65607ff22'
+ 'f4f04d4bf98104bf22861f1e0f7434a3c2aedf6a67ce0fe39ed7b4186f162a03979ae6659c40d6e6816c735801c0691e5362375250a58c742ca089d35513297d'
+ '906d13faf041cfb0e27923edcea134d33836f798ba3ee5f815cb3da8e219f5a10f25e05255552366a30e267bb14c6d1fdc02ed678ce3a6fcaaf7a63cd3057f3b'
'c3b541c7ac95c94f682577cacedc06e79427003a870cde844056a7662087873b59dc06933552bb867b16fc0387f8a061672df780454769f26aa3e53b13a94edf')
prepare() {
cd "xorg-server-${pkgver}"
+ # FS#73075 - merged in trunk
+ patch -Np1 -i ../0001-xf86-logind-Fix-compilation-error-when-built-without.patch
+ patch -Np1 -i ../0002-xf86-logind-fix-missing-call-to-vtenter-if-the-platf.patch
+
# The patch for freedesktop bug 865
patch -Np1 -i "${srcdir}/freedesktop-bug-865.patch"
}