summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-10-17 11:53:06 +0300
committerDet2015-10-17 11:53:06 +0300
commitbbdade19554793bb7fec675e4d331c2cf1517a1c (patch)
tree729b6a47853a3f26e190c3997687d3b0530b9733
parentb3c75bcf25d9c4d5e874648e071f6d7f9cd1cd08 (diff)
downloadaur-bbdade19554793bb7fec675e4d331c2cf1517a1c.tar.gz
Remove old patches
-rw-r--r--.SRCINFO4
-rw-r--r--0001-glamor-make-current-in-prepare-paths.patch34
-rw-r--r--0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch63
-rw-r--r--PKGBUILD12
4 files changed, 2 insertions, 111 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e4f7817b3f5..d5038e459807 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -58,16 +58,12 @@ pkgbase = xorg-server-dev
source = xvfb-run
source = xvfb-run.1
source = 0001-systemd-logind-do-not-rely-on-directed-signals.patch
- source = 0001-glamor-make-current-in-prepare-paths.patch
- source = 0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch
sha256sums = d9efaf191f9dd4e84771de507ac00571d2a2f43bfae589fbf1b05706f83bb280
sha256sums = SKIP
sha256sums = af1c3d2ea5de7f6a6b5f7c60951a189a4749d1495e5462f3157ae7ac8fe1dc56
sha256sums = ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9
sha256sums = 2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776
sha256sums = 3d7edab3a54d647e7d924b29d29f91b50212f308fcb1853a5aacd3181f58276c
- sha256sums = 793579adbef979088cadc0fd9ce0c24df0455a6936d3de7a9356df537b7d9a81
- sha256sums = efc05c06af2bfdf588ef7a60b44c1d180fb353b1bffdfdf96415d63690b6e394
pkgname = xorg-server-dev
pkgdesc = Xorg X server - Bleeding edge version
diff --git a/0001-glamor-make-current-in-prepare-paths.patch b/0001-glamor-make-current-in-prepare-paths.patch
deleted file mode 100644
index 6167395d7459..000000000000
--- a/0001-glamor-make-current-in-prepare-paths.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 422a9f7f37eb6027fa4d20a4be208978832be6d6 Mon Sep 17 00:00:00 2001
-From: Dave Airlie <airlied@redhat.com>
-Date: Wed, 15 Jul 2015 17:54:03 +1000
-Subject: [PATCH] glamor: make current in prepare paths
-
-Lots of the accel paths only make current once they start
-doing someting, so a lot of them call the bail paths without
-make current, which means on PRIME systems for example
-we end up in the wrong context.
-
-Add a prepare pixmap in the prepare fallback path.
-
-Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=90667
-Signed-off-by: Dave Airlie <airlied@redhat.com>
----
- glamor/glamor_prepare.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/glamor/glamor_prepare.c b/glamor/glamor_prepare.c
-index 9bfc557..68fb58f 100644
---- a/glamor/glamor_prepare.c
-+++ b/glamor/glamor_prepare.c
-@@ -45,6 +45,8 @@ glamor_prep_pixmap_box(PixmapPtr pixmap, glamor_access_t access, BoxPtr box)
- if (!GLAMOR_PIXMAP_PRIV_HAS_FBO(priv))
- return TRUE;
-
-+ glamor_make_current(glamor_priv);
-+
- RegionInit(&region, box, 1);
-
- /* See if it's already mapped */
---
-2.4.3
-
diff --git a/0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch b/0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch
deleted file mode 100644
index b3a7d2ed5e00..000000000000
--- a/0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From 7cc7ffd25d5e50b54cb942d07d4cb160f20ff9c5 Mon Sep 17 00:00:00 2001
-From: Martin Peres <martin.peres@linux.intel.com>
-Date: Fri, 17 Jul 2015 17:21:26 +0300
-Subject: [PATCH] os: make sure the clientsWritable fd_set is initialized
- before use
-
-In WaitForSomething(), the fd_set clientsWritable may be used unitialized when
-the boolean AnyClientsWriteBlocked is set in the WakeupHandler(). This leads to
-a crash in FlushAllOutput() after x11proto's commit
-2c94cdb453bc641246cc8b9a876da9799bee1ce7.
-
-The problem did not manifest before because both the XFD_SIZE and the maximum
-number of clients were set to 256. As the connectionTranslation table was
-initalized for the 256 clients to 0, the test on the index not being 0 was
-aborting before dereferencing the client #0.
-
-As of commit 2c94cdb453bc641246cc8b9a876da9799bee1ce7 in x11proto, the XFD_SIZE
-got bumped to 512. This lead the OutputPending fd_set to have any fd above 256
-to be uninitialized which in turns lead to reading an index after the end of
-the ConnectionTranslation table. This index would then be used to find the
-client corresponding to the fd marked as pending writes and would also result
-to an out-of-bound access which would usually be the fatal one.
-
-Fix this by zeroing the clientsWritable fd_set at the beginning of
-WaitForSomething(). In this case, the bottom part of the loop, which would
-indirectly call FlushAllOutput, will not do any work but the next call to
-select will result in the execution of the right codepath. This is exactly what
-we want because we need to know the writable clients before handling them. In
-the end, it also makes sure that the fds above MaxClient are initialized,
-preventing the crash in FlushAllOutput().
-
-Thanks to everyone involved in tracking this one down!
-
-Reported-by: Karol Herbst <freedesktop@karolherbst.de>
-Reported-by: Tobias Klausmann <tobias.klausmann@mni.thm.de>
-Signed-off-by: Martin Peres <martin.peres@linux.intel.com>
-Tested-by: Martin Peres <martin.peres@linux.intel.com>
-Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=91316
-Cc: Ilia Mirkin <imirkin@alum.mit.edu>
-Cc: Martin Peres <martin.peres@linux.intel.com>
-Cc: Olivier Fourdan <ofourdan@redhat.com
-Cc: Adam Jackson <ajax@redhat.com>
-Cc: Alan Coopersmith <alan.coopersmith@oracle.com
-Cc: Chris Wilson <chris@chris-wilson.co.uk>
----
- os/WaitFor.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/os/WaitFor.c b/os/WaitFor.c
-index 431f1a6..993c14e 100644
---- a/os/WaitFor.c
-+++ b/os/WaitFor.c
-@@ -158,6 +158,7 @@ WaitForSomething(int *pClientsReady)
- Bool someReady = FALSE;
-
- FD_ZERO(&clientsReadable);
-+ FD_ZERO(&clientsWritable);
-
- if (nready)
- SmartScheduleStopTimer();
---
-2.4.5
-
diff --git a/PKGBUILD b/PKGBUILD
index 223b9d9d5ed3..5d4a4c346b27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,9 +19,7 @@ source=(${url}/releases/individual/xserver/${_pkgbase}-${pkgver}.tar.bz2{,.sig}
nvidia-drm-outputclass.conf
xvfb-run
xvfb-run.1
- 0001-systemd-logind-do-not-rely-on-directed-signals.patch
- 0001-glamor-make-current-in-prepare-paths.patch
- 0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch)
+ 0001-systemd-logind-do-not-rely-on-directed-signals.patch)
validpgpkeys=('7B27A3F1A6E18CD9588B4AE8310180050905E40C'
'C383B778255613DFDB409D91DB221A6900000011'
'DD38563A8A8224537D1F90E45B8A2D50A0ECD0D3')
@@ -30,9 +28,7 @@ sha256sums=('d9efaf191f9dd4e84771de507ac00571d2a2f43bfae589fbf1b05706f83bb280'
'af1c3d2ea5de7f6a6b5f7c60951a189a4749d1495e5462f3157ae7ac8fe1dc56'
'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
'2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776'
- '3d7edab3a54d647e7d924b29d29f91b50212f308fcb1853a5aacd3181f58276c'
- '793579adbef979088cadc0fd9ce0c24df0455a6936d3de7a9356df537b7d9a81'
- 'efc05c06af2bfdf588ef7a60b44c1d180fb353b1bffdfdf96415d63690b6e394')
+ '3d7edab3a54d647e7d924b29d29f91b50212f308fcb1853a5aacd3181f58276c')
prepare() {
cd "${_pkgbase}-${pkgver}"
@@ -40,10 +36,6 @@ prepare() {
msg2 "fix VT switching with kdbus; from upstream"
patch -Np1 -i ../0001-systemd-logind-do-not-rely-on-directed-signals.patch
- msg2 "fix FS#45009, merged upstream"
- patch -Np1 -i ../0001-glamor-make-current-in-prepare-paths.patch
- patch -Np1 -i ../0001-os-make-sure-the-clientsWritable-fd_set-is-initializ.patch
-
msg2 "Starting autoreconf..."
autoreconf -fvi
}