summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0strodamus2016-01-11 12:11:17 -0700
committer0strodamus2016-01-11 12:11:17 -0700
commit0fd88e2234c0fe43236b65bbbc9374e1404c6b0f (patch)
tree7a53afdbddb12bdd46f37db950c6f0569ff34832
parent0621b901d7c87beaf9d519fa4840830143c50396 (diff)
downloadaur-0fd88e2234c0fe43236b65bbbc9374e1404c6b0f.tar.gz
upgpkg: xorg-server-nosystemd 1.18.0-4
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch14
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b39cc86a634..2b7766630419 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Dec 18 20:36:32 UTC 2015
+# Mon Jan 11 19:10:55 UTC 2016
pkgbase = xorg-server-nosystemd
pkgver = 1.18.0
- pkgrel = 3
+ pkgrel = 4
url = http://xorg.freedesktop.org
arch = i686
arch = x86_64
@@ -59,11 +59,13 @@ pkgbase = xorg-server-nosystemd
source = xvfb-run
source = xvfb-run.1
source = v2-Xorg.wrap-activate-libdrm-based-detection-for-KMS-drivers.patch
+ source = xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch
sha256sums = 195670819695d9cedd8dde95fbe069be0d0f488a77797a2d409f9f702daf312e
sha256sums = SKIP
sha256sums = ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9
sha256sums = 2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776
sha256sums = c8addd0dc6d91797e82c51b539317efa271cd7997609e026c7c8e3884c5f601c
+ sha256sums = 1fe0c2c13bc3643a9a236bc45910e1e68d7b9cbe128204bcc1821752ed266e95
pkgname = xorg-server-nosystemd
pkgdesc = Xorg X server
diff --git a/PKGBUILD b/PKGBUILD
index e7572400a737..970d49b1aa89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=('xorg-server-nosystemd' 'xorg-server-xephyr-nosystemd' 'xorg-server-xdm
'xorg-server-xnest-nosystemd' 'xorg-server-xwayland-nosystemd' 'xorg-server-common-nosystemd' 'xorg-server-devel-nosystemd')
_pkgbase=xorg-server
pkgver=1.18.0
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
license=('custom')
url="http://xorg.freedesktop.org"
@@ -21,7 +21,8 @@ makedepends=('pixman' 'libx11' 'mesa-nosystemd' 'mesa-libgl-nosystemd' 'xf86drip
source=(${url}/releases/individual/xserver/${_pkgbase}-${pkgver}.tar.bz2{,.sig}
xvfb-run
xvfb-run.1
- v2-Xorg.wrap-activate-libdrm-based-detection-for-KMS-drivers.patch)
+ v2-Xorg.wrap-activate-libdrm-based-detection-for-KMS-drivers.patch
+ xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch)
validpgpkeys=('7B27A3F1A6E18CD9588B4AE8310180050905E40C'
'C383B778255613DFDB409D91DB221A6900000011'
'DD38563A8A8224537D1F90E45B8A2D50A0ECD0D3')
@@ -29,11 +30,15 @@ sha256sums=('195670819695d9cedd8dde95fbe069be0d0f488a77797a2d409f9f702daf312e'
'SKIP'
'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
'2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776'
- 'c8addd0dc6d91797e82c51b539317efa271cd7997609e026c7c8e3884c5f601c')
+ 'c8addd0dc6d91797e82c51b539317efa271cd7997609e026c7c8e3884c5f601c'
+ '1fe0c2c13bc3643a9a236bc45910e1e68d7b9cbe128204bcc1821752ed266e95')
prepare() {
+ cd "${_pkgbase}-${pkgver}"
# fix xorg only working with root FS#47061
patch -Np1 -i ../v2-Xorg.wrap-activate-libdrm-based-detection-for-KMS-drivers.patch
+ # disable debugging glamor messages in xorg log file
+ patch -Np1 -i ../xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch
autoreconf -fvi
}
diff --git a/xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch b/xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch
new file mode 100644
index 000000000000..41a67c74b33f
--- /dev/null
+++ b/xserver-glamor-Disable-debugging-messages-other-than-GL-API-errors.patch
@@ -0,0 +1,14 @@
+diff --git a/glamor/glamor.c b/glamor/glamor.c
+index 116d10c..81aba2d 100644
+--- a/glamor/glamor.c
++++ b/glamor/glamor.c
+@@ -393,6 +393,9 @@ glamor_setup_debug_output(ScreenPtr screen)
+ return;
+
+ glEnable(GL_DEBUG_OUTPUT_SYNCHRONOUS);
++ /* Disable debugging messages other than GL API errors */
++ glDebugMessageControl(GL_DONT_CARE, GL_DONT_CARE, GL_DONT_CARE, 0, NULL,
++ GL_FALSE);
+ glDebugMessageControl(GL_DEBUG_SOURCE_API,
+ GL_DEBUG_TYPE_ERROR,
+ GL_DONT_CARE,