summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-10-15 18:46:06 -0400
committerVincent Grande2020-10-15 18:46:06 -0400
commit81db4dbc7b45fa46e1926cd467b65ef54410efd9 (patch)
treedc33f06ff7f87f0ae8c51c9f4ba8aa7816d2a40f
downloadaur-81db4dbc7b45fa46e1926cd467b65ef54410efd9.tar.gz
initial upload
-rw-r--r--.SRCINFO100
-rw-r--r--PKGBUILD260
-rw-r--r--xorg-server-rootless-nosystemd-minimal.install12
-rw-r--r--xvfb-run200
-rw-r--r--xvfb-run.1282
5 files changed, 854 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bf66a077196
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,100 @@
+pkgbase = xorg-server-rootless-nosystemd-minimal
+ pkgver = 1.20.9
+ pkgrel = 1
+ url = http://xorg.freedesktop.org
+ arch = x86_64
+ groups = xorg
+ license = custom
+ makedepends = xorgproto
+ makedepends = pixman
+ makedepends = libx11
+ makedepends = mesa
+ makedepends = mesa-libgl
+ makedepends = xtrans
+ makedepends = libxkbfile
+ makedepends = libxfont2
+ makedepends = libpciaccess
+ makedepends = libxv
+ makedepends = libxmu
+ makedepends = libxrender
+ makedepends = libxi
+ makedepends = libxaw
+ makedepends = libxtst
+ makedepends = libxres
+ makedepends = xorg-xkbcomp
+ makedepends = xorg-util-macros
+ makedepends = xorg-font-util
+ makedepends = libepoxy
+ makedepends = xcb-util
+ makedepends = xcb-util-image
+ makedepends = xcb-util-renderutil
+ makedepends = xcb-util-wm
+ makedepends = xcb-util-keysyms
+ makedepends = libxshmfence
+ makedepends = meson
+ optdepends = wayland-protocols: xwayland support
+ optdepends = egl-wayland: xwayland support
+ source = https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-1.20.9.tar.bz2
+ source = xvfb-run
+ source = xvfb-run.1
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = xorg-server-rootless-nosystemd-minimal
+ pkgdesc = Xorg X server
+ install = xorg-server-rootless-nosystemd-minimal.install
+ depends = libepoxy
+ depends = libxfont2
+ depends = pixman
+ depends = xorg-server-common-rootless-nosystemd-minimal
+ depends = dbus
+ depends = libgl
+ depends = xf86-input-libinput
+ depends = nettle
+ depends = libpciaccess
+ depends = libdrm
+ depends = libxshmfence
+ optdepends = libunwind: unwind backtrace support
+ provides = X-ABI-VIDEODRV_VERSION=24.0
+ provides = X-ABI-XINPUT_VERSION=24.1
+ provides = X-ABI-EXTENSION_VERSION=10.0
+ provides = x-server
+ provides = xorg-server
+ conflicts = nvidia-utils<=331.20
+ conflicts = glamor-egl
+ conflicts = xf86-video-modesetting
+ conflicts = xorg-server
+ replaces = glamor-egl
+ replaces = xf86-video-modesetting
+
+pkgname = xorg-server-xwayland-rootless-nosystemd-minimal
+ pkgdesc = run X clients under wayland
+ depends = libxfont2
+ depends = libepoxy
+ depends = libgl
+ depends = pixman
+ depends = xorg-server-common-rootless-nosystemd-minimal
+ depends = nettle
+ depends = libtirpc
+ optdepends = libunwind: unwind backtrace support
+ provides = xorg-server-xwayland
+ conflicts = xorg-server-xwayland
+
+pkgname = xorg-server-common-rootless-nosystemd-minimal
+ pkgdesc = Xorg server common files
+ depends = xkeyboard-config
+ depends = xorg-xkbcomp
+ depends = xorg-setxkbmap
+ provides = xorg-server-common
+ conflicts = xorg-server-common
+
+pkgname = xorg-server-devel-rootless-nosystemd-minimal
+ pkgdesc = Development files for the X.Org X server
+ depends = xorgproto
+ depends = mesa
+ depends = libpciaccess
+ depends = xorg-util-macros
+ provides = xorg-server-devel
+ conflicts = xorg-server-devel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..684b6bd18a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,260 @@
+# Maintainer : Vincent Grande
+# Contributor : Eric Vidal <eric@obarun.org>
+# Contributor : Jean-Michel T.Dydak <jean-michel@obarun.org>
+
+pkgname=(
+ 'xorg-server-rootless-nosystemd-minimal'
+# 'xorg-server-xephyr-rootless-nosystemd-minimal'
+# 'xorg-server-xvfb-rootless-nosystemd-minimal'
+# 'xorg-server-xnest-rootless-nosystemd-minimal'
+ 'xorg-server-xwayland-rootless-nosystemd-minimal'
+ 'xorg-server-common-rootless-nosystemd-minimal'
+ 'xorg-server-devel-rootless-nosystemd-minimal')
+
+pkgver=1.20.9
+pkgrel=1
+url="http://xorg.freedesktop.org"
+source=("https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-${pkgver}.tar.bz2"
+ xvfb-run # with updates from FC master
+ xvfb-run.1)
+
+makedepends=(
+ 'xorgproto'
+ 'pixman'
+ 'libx11'
+ 'mesa'
+ 'mesa-libgl'
+ 'xtrans'
+ 'libxkbfile'
+ 'libxfont2'
+ 'libpciaccess'
+ 'libxv'
+ 'libxmu'
+ 'libxrender'
+ 'libxi'
+ 'libxaw'
+ 'libxtst'
+ 'libxres'
+ 'xorg-xkbcomp'
+ 'xorg-util-macros'
+ 'xorg-font-util'
+ 'libepoxy'
+ 'xcb-util'
+ 'xcb-util-image'
+ 'xcb-util-renderutil'
+ 'xcb-util-wm'
+ 'xcb-util-keysyms'
+ 'libxshmfence'
+# 'libunwind'
+# 'wayland-protocols'
+# 'egl-wayland'
+ 'meson')
+
+optdepends=('wayland-protocols: xwayland support'
+ 'egl-wayland: xwayland support')
+
+pkgver() {
+ cd xserver-$pkgver
+ # cutting off 'xorg.server.' prefix that presents in the git tag
+ git describe --long --tags| sed 's/^xorg.server.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
+ # With them, module fail to load with undefined symbol.
+ # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
+ export CFLAGS=${CFLAGS/-fno-plt}
+ export CXXFLAGS=${CXXFLAGS/-fno-plt}
+ export LDFLAGS=${LDFLAGS/,-z,now}
+
+
+ arch-meson xserver-$pkgver build \
+ -D os_vendor="Arch Linux" \
+ -D ipv6=false \
+ -D xcsecurity=true \
+ -D xorg=true \
+ -D xwayland=true \
+ -D xwayland_eglstream=true \
+ -D udev=true \
+ -D suid_wrapper=false \
+ -D xkb_dir=/usr/share/X11/xkb \
+ -D xkb_output_dir=/var/lib/xkb \
+ -D systemd_logind=false \
+ -D b_lto=false \
+ -D b_lundef=false \
+ -D xinerama=true \
+ -D screensaver=false \
+ -D dmx=false \
+ -D glamor=true \
+ -D linux_apm=false \
+ -D mitshm=true \
+ -D vgahw=false \
+ -D xdmcp=false \
+ -D xephyr=false \
+ -D xnest=false \
+ -D xquartz=false \
+ -D xv=true \
+ -D xvmc=false \
+ -D xvfb=false \
+ -D xwin=false \
+ -D xres=false \
+ -D libunwind=false \
+ -D debug=false
+
+# xinerama needed with nvidia blob
+# mitshm needed with nvidia blob
+# xv needed with nvidia blob
+# glamor needed for xwayland gaming
+
+ # Print config
+ meson configure build
+ ninja -C build
+
+ # fake installation to be seperated into packages
+ DESTDIR="${srcdir}/fakeinstall" ninja -C build install
+}
+
+_install() {
+ local src f dir
+ for src; do
+ f="${src#fakeinstall/}"
+ dir="${pkgdir}/${f%/*}"
+ install -m755 -d "${dir}"
+ mv -v "${src}" "${dir}/"
+ done
+}
+
+package_xorg-server-common-rootless-nosystemd-minimal() {
+ pkgdesc="Xorg server common files"
+ depends=(xkeyboard-config xorg-xkbcomp xorg-setxkbmap)
+ conflicts=('xorg-server-common')
+ provides=('xorg-server-common')
+
+
+ _install fakeinstall/usr/lib/xorg/protocol.txt
+ _install fakeinstall/usr/share/man/man1/Xserver.1
+
+# install -m644 -Dt "${pkgdir}/var/lib/xkb/" xserver/xkb/README.compiled
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+}
+
+package_xorg-server-rootless-nosystemd-minimal() {
+ pkgdesc="Xorg X server"
+ depends=(libepoxy libxfont2 pixman xorg-server-common-rootless-nosystemd-minimal
+ dbus libgl xf86-input-libinput nettle
+ libpciaccess libdrm libxshmfence) # FS#52949
+ optdepends=('libunwind: unwind backtrace support')
+
+ # see xorg-server-*/hw/xfree86/common/xf86Module.h for ABI versions - we provide major numbers that drivers can depend on
+ # and /usr/lib/pkgconfig/xorg-server.pc in xorg-server-devel pkg
+ provides=('X-ABI-VIDEODRV_VERSION=24.0' 'X-ABI-XINPUT_VERSION=24.1' 'X-ABI-EXTENSION_VERSION=10.0' 'x-server' 'xorg-server')
+ conflicts=('nvidia-utils<=331.20' 'glamor-egl' 'xf86-video-modesetting' 'xorg-server')
+ replaces=('glamor-egl' 'xf86-video-modesetting')
+ install=xorg-server-rootless-nosystemd-minimal.install
+
+
+ _install fakeinstall/usr/bin/{Xorg,cvt,gtf}
+ ln -s /usr/bin/Xorg "${pkgdir}/usr/bin/X"
+ #_install fakeinstall/usr/lib/Xorg{,.wrap}
+ _install fakeinstall/usr/lib/xorg/modules/*
+ _install fakeinstall/usr/share/X11/xorg.conf.d/10-quirks.conf
+ _install fakeinstall/usr/share/man/man1/{Xorg,cvt,gtf}.1
+ _install fakeinstall/usr/share/man/man4/{exa,fbdevhw,modesetting}.4
+ _install fakeinstall/usr/share/man/man5/{xorg.conf,xorg.conf.d}.5
+
+ # distro specific files must be installed in /usr/share/X11/xorg.conf.d
+ install -m755 -d "${pkgdir}/etc/X11/xorg.conf.d"
+
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+}
+
+#package_xorg-server-xephyr-rootless-nosystemd-minimal() {
+# pkgdesc="A nested X server that runs as an X application"
+# depends=(libxfont2 libgl libepoxy libxv pixman xorg-server-common-rootless-nosystemd-minimal
+# xcb-util-image xcb-util-renderutil xcb-util-wm xcb-util-keysyms
+# nettle libtirpc)
+# optdepends=('libunwind: unwind backtrace support')
+# conflicts=('xorg-server-xephyr')
+# provides=('xorg-server-xephyr')
+
+# _install fakeinstall/usr/bin/Xephyr
+# _install fakeinstall/usr/share/man/man1/Xephyr.1
+
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+#}
+
+#package_xorg-server-xvfb-rootless-nosystemd-minimal() {
+# pkgdesc="Virtual framebuffer X server"
+# depends=(libxfont2 pixman xorg-server-common-rootless-nosystemd-minimal xorg-xauth libgl nettle libtirpc)
+# optdepends=('libunwind: unwind backtrace support')
+# conflicts=('xorg-server-xvfb')
+# provides=('xorg-server-xvfb')
+
+# _install fakeinstall/usr/bin/Xvfb
+# _install fakeinstall/usr/share/man/man1/Xvfb.1
+
+# install -m755 "${srcdir}/xvfb-run" "${pkgdir}/usr/bin/"
+# install -m644 "${srcdir}/xvfb-run.1" "${pkgdir}/usr/share/man/man1/" # outda
+
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+#}
+
+#package_xorg-server-xnest-rootless-nosystemd-minimal() {
+# pkgdesc="A nested X server that runs as an X application"
+# depends=(libxfont2 libxext pixman xorg-server-common-rootless-nosystemd-minimal nettle libtirpc)
+# conflicts=('xorg-server-xnest')
+# provides=('xorg-server-xnest')
+
+# _install fakeinstall/usr/bin/Xnest
+# _install fakeinstall/usr/share/man/man1/Xnest.1
+
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+#}
+
+package_xorg-server-xwayland-rootless-nosystemd-minimal() {
+ pkgdesc="run X clients under wayland"
+ depends=(libxfont2 libepoxy libgl pixman xorg-server-common-rootless-nosystemd-minimal
+ nettle libtirpc)
+ optdepends=('libunwind: unwind backtrace support')
+ conflicts=('xorg-server-xwayland')
+ provides=('xorg-server-xwayland')
+
+ _install fakeinstall/usr/bin/Xwayland
+
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+}
+
+package_xorg-server-devel-rootless-nosystemd-minimal() {
+ pkgdesc="Development files for the X.Org X server"
+ depends=('xorgproto' 'mesa' 'libpciaccess'
+ # not technically required but almost every Xorg pkg needs it to build
+ 'xorg-util-macros')
+ conflicts=('xorg-server-devel')
+ provides=('xorg-server-devel')
+
+ _install fakeinstall/usr/include/xorg/*
+ _install fakeinstall/usr/lib/pkgconfig/xorg-server.pc
+ _install fakeinstall/usr/share/aclocal/xorg-server.m4
+
+ # license
+# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
+
+ # make sure there are no files left to install
+# find fakeinstall -depth -print0 | xargs -0 rmdir
+}
+
+arch=('x86_64')
+
+groups=('xorg')
+
+license=('custom')
+
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
diff --git a/xorg-server-rootless-nosystemd-minimal.install b/xorg-server-rootless-nosystemd-minimal.install
new file mode 100644
index 000000000000..7bce5839a2bb
--- /dev/null
+++ b/xorg-server-rootless-nosystemd-minimal.install
@@ -0,0 +1,12 @@
+post_install() {
+ chown -v :input /usr/bin/Xorg
+ chmod -v g+s /usr/bin/Xorg
+cat <<MSG
+>>> Xserver will fail to run if not launched from the same virtual
+ terminal as was used to log in.
+ Without root rights, log files will be in ~/.local/share/xorg/ directory.
+MSG
+}
+post_upgrade() {
+ post_install $1
+}
diff --git a/xvfb-run b/xvfb-run
new file mode 100644
index 000000000000..6aa4f3548bc7
--- /dev/null
+++ b/xvfb-run
@@ -0,0 +1,200 @@
+#!/bin/sh
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
+#
+# T2 SDE: package/.../xorg-server/xvfb-run.sh
+# Copyright (C) 2005 The T2 SDE Project
+# Copyright (C) XXXX - 2005 Debian
+#
+# More information can be found in the files COPYING and README.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License. A copy of the
+# GNU General Public License can be found in the file COPYING.
+# --- T2-COPYRIGHT-NOTE-END ---
+
+# $Id$
+# from: http://necrotic.deadbeast.net/xsf/XFree86/trunk/debian/local/xvfb-run
+
+# This script starts an instance of Xvfb, the "fake" X server, runs a command
+# with that server available, and kills the X server when done. The return
+# value of the command becomes the return value of this script.
+#
+# If anyone is using this to build a Debian package, make sure the package
+# Build-Depends on xvfb, xbase-clients, and xfonts-base.
+
+set -e
+
+PROGNAME=xvfb-run
+SERVERNUM=99
+AUTHFILE=
+ERRORFILE=/dev/null
+STARTWAIT=3
+XVFBARGS="-screen 0 640x480x24"
+LISTENTCP="-nolisten tcp"
+XAUTHPROTO=.
+
+# Query the terminal to establish a default number of columns to use for
+# displaying messages to the user. This is used only as a fallback in the event
+# the COLUMNS variable is not set. ($COLUMNS can react to SIGWINCH while the
+# script is running, and this cannot, only being calculated once.)
+DEFCOLUMNS=$(stty size 2>/dev/null | awk '{print $2}') || true
+if ! expr "$DEFCOLUMNS" : "[[:digit:]]\+$" >/dev/null 2>&1; then
+ DEFCOLUMNS=80
+fi
+
+# Display a message, wrapping lines at the terminal width.
+message () {
+ echo "$PROGNAME: $*" | fmt -t -w ${COLUMNS:-$DEFCOLUMNS}
+}
+
+# Display an error message.
+error () {
+ message "error: $*" >&2
+}
+
+# Display a usage message.
+usage () {
+ if [ -n "$*" ]; then
+ message "usage error: $*"
+ fi
+ cat <<EOF
+Usage: $PROGNAME [OPTION ...] COMMAND
+Run COMMAND (usually an X client) in a virtual X server environment.
+Options:
+-a --auto-servernum try to get a free server number, starting at
+ --server-num (deprecated, use --auto-display
+ instead)
+-d --auto-display use the X server to find a display number
+ automatically
+-e FILE --error-file=FILE file used to store xauth errors and Xvfb
+ output (default: $ERRORFILE)
+-f FILE --auth-file=FILE file used to store auth cookie
+ (default: ./.Xauthority)
+-h --help display this usage message and exit
+-n NUM --server-num=NUM server number to use (default: $SERVERNUM)
+-l --listen-tcp enable TCP port listening in the X server
+-p PROTO --xauth-protocol=PROTO X authority protocol name to use
+ (default: xauth command's default)
+-s ARGS --server-args=ARGS arguments (other than server number and
+ "-nolisten tcp") to pass to the Xvfb server
+ (default: "$XVFBARGS")
+-w DELAY --wait=DELAY delay in seconds to wait for Xvfb to start
+ before running COMMAND (default: $STARTWAIT)
+EOF
+}
+
+# Find a free server number by looking at .X*-lock files in /tmp.
+find_free_servernum() {
+ # Sadly, the "local" keyword is not POSIX. Leave the next line commented in
+ # the hope Debian Policy eventually changes to allow it in /bin/sh scripts
+ # anyway.
+ #local i
+
+ i=$SERVERNUM
+ while [ -f /tmp/.X$i-lock ]; do
+ i=$(($i + 1))
+ done
+ echo $i
+}
+
+# Parse the command line.
+ARGS=$(getopt --options +ade:f:hn:lp:s:w: \
+ --long auto-servernum,auto-display,error-file:auth-file:,help,server-num:,listen-tcp,xauth-protocol:,server-args:,wait: \
+ --name "$PROGNAME" -- "$@")
+GETOPT_STATUS=$?
+
+if [ $GETOPT_STATUS -ne 0 ]; then
+ error "internal error; getopt exited with status $GETOPT_STATUS"
+ exit 6
+fi
+
+eval set -- "$ARGS"
+
+while :; do
+ case "$1" in
+ -a|--auto-servernum) SERVERNUM=$(find_free_servernum) ;;
+ -d|--auto-display) AUTO_DISPLAY=1 ;;
+ -e|--error-file) ERRORFILE="$2"; shift ;;
+ -f|--auth-file) AUTHFILE="$2"; shift ;;
+ -h|--help) SHOWHELP="yes" ;;
+ -n|--server-num) SERVERNUM="$2"; shift ;;
+ -l|--listen-tcp) LISTENTCP="" ;;
+ -p|--xauth-protocol) XAUTHPROTO="$2"; shift ;;
+ -s|--server-args) XVFBARGS="$2"; shift ;;
+ -w|--wait) STARTWAIT="$2"; shift ;;
+ --) shift; break ;;
+ *) error "internal error; getopt permitted \"$1\" unexpectedly"
+ exit 6
+ ;;
+ esac
+ shift
+done
+
+if [ "$SHOWHELP" ]; then
+ usage
+ exit 0
+fi
+
+if [ -z "$*" ]; then
+ usage "need a command to run" >&2
+ exit 2
+fi
+
+if ! type xauth >/dev/null; then
+ error "xauth command not found"
+ exit 3
+fi
+
+# Set up the temp dir for the pid and X authorization file
+XVFB_RUN_TMPDIR="$(mktemp --directory --tmpdir $PROGNAME.XXXXXX)"
+# If the user did not specify an X authorization file to use, set up a temporary
+# directory to house one.
+if [ -z "$AUTHFILE" ]; then
+ AUTHFILE=$(mktemp -p "$XVFB_RUN_TMPDIR" Xauthority.XXXXXX)
+fi
+
+# Start Xvfb.
+MCOOKIE=$(mcookie)
+
+if [ -z "$AUTO_DISPLAY" ]; then
+ # Old style using a pre-computed SERVERNUM
+ XAUTHORITY=$AUTHFILE Xvfb ":$SERVERNUM" $XVFBARGS $LISTENTCP >>"$ERRORFILE" \
+ 2>&1 &
+ XVFBPID=$!
+else
+ # New style using Xvfb to provide a free display
+ PIDFILE=$(mktemp -p "$XVFB_RUN_TMPDIR" pid.XXXXXX)
+ SERVERNUM=$(XAUTHORITY=$AUTHFILE Xvfb -displayfd 1 $XVFBARGS $LISTENTCP \
+ 2>"$ERRORFILE" & echo $! > $PIDFILE)
+ XVFBPID=$(cat $PIDFILE)
+fi
+sleep "$STARTWAIT"
+
+XAUTHORITY=$AUTHFILE xauth source - << EOF >>"$ERRORFILE" 2>&1
+add :$SERVERNUM $XAUTHPROTO $MCOOKIE
+EOF
+
+# Start the command and save its exit status.
+set +e
+DISPLAY=:$SERVERNUM XAUTHORITY=$AUTHFILE "$@" 2>&1
+RETVAL=$?
+set -e
+
+# Kill Xvfb now that the command has exited.
+kill $XVFBPID
+
+# Clean up.
+XAUTHORITY=$AUTHFILE xauth remove ":$SERVERNUM" >"$ERRORFILE" 2>&1
+if [ -n "$XVFB_RUN_TMPDIR" ]; then
+ if ! rm -r "$XVFB_RUN_TMPDIR"; then
+ error "problem while cleaning up temporary directory"
+ exit 5
+ fi
+fi
+
+# Return the executed command's exit status.
+exit $RETVAL
+
+# vim:set ai et sts=4 sw=4 tw=80:
diff --git a/xvfb-run.1 b/xvfb-run.1
new file mode 100644
index 000000000000..137d3a1967e5
--- /dev/null
+++ b/xvfb-run.1
@@ -0,0 +1,282 @@
+.\" $Id: xvfb-run.1 2138 2005-01-17 23:40:27Z branden $
+.\"
+.\" Copyright 1998-2004 Branden Robinson <branden@debian.org>.
+.\"
+.\" This is free software; you may redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as
+.\" published by the Free Software Foundation; either version 2,
+.\" or (at your option) any later version.
+.\"
+.\" This is distributed in the hope that it will be useful, but
+.\" WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+.\" GNU General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License with
+.\" the Debian operating system, in /usr/share/common-licenses/GPL; if
+.\" not, write to the Free Software Foundation, Inc., 59 Temple Place,
+.\" Suite 330, Boston, MA 02111-1307 USA
+.\"
+.\" We need the URL macro from groff's www macro package, but also want
+.\" things to work all right for people who don't have it. So we define
+.\" our own URL macro and let the www macro package override it if it's
+.\" available.
+.de URL
+\\$2 \(laURL: \\$1 \(ra\\$3
+..
+.if \n[.g] .mso www.tmac
+.TH xvfb\-run 1 "2004\-11\-12" "Debian Project"
+.SH NAME
+xvfb\-run \- run specified X client or command in a virtual X server environment
+.SH SYNOPSIS
+.B xvfb\-run
+[
+.I options
+]
+.I command
+.SH DESCRIPTION
+.B xvfb\-run
+is a wrapper for the
+.BR Xvfb (1x)
+command which simplifies the task of running commands (typically an X
+client, or a script containing a list of clients to be run) within a virtual
+X server environment.
+.PP
+.B xvfb\-run
+sets up an X authority file (or uses an existing user\-specified one),
+writes a cookie to it (see
+.BR xauth (1x))
+and then starts the
+.B Xvfb
+X server as a background process.
+The process ID of
+.B Xvfb
+is stored for later use.
+The specified
+.I command
+is then run using the X display corresponding to the
+.B Xvfb
+server
+just started and the X authority file created earlier.
+.PP
+When the
+.I command
+exits, its status is saved, the
+.B Xvfb
+server is killed (using the process ID stored earlier), the X authority
+cookie removed, and the authority file deleted (if the user did not specify
+one to use).
+.B xvfb\-run
+then exits with the exit status of
+.IR command .
+.PP
+.B xvfb\-run
+requires the
+.B xauth
+command to function.
+.SH OPTIONS
+.TP
+.B \-a\fR,\fB \-\-auto\-servernum
+Try to get a free server number, starting at 99, or the argument to
+.BR \-\-server\-num .
+.TP
+.BI \-e\ file \fR,\fB\ \-\-error\-file= file
+Store output from
+.B xauth
+and
+.B Xvfb
+in
+.IR file .
+The default is
+.IR /dev/null .
+.TP
+.BI \-f\ file \fR,\fB\ \-\-auth\-file= file
+Store X authentication data in
+.IR file .
+By default, a temporary directory called
+.IR xvfb\-run. PID
+(where PID is the process ID of
+.B xvfb\-run
+itself) is created in the directory specified by the environment variable
+.B TMPDIR
+(or
+.I /tmp
+if that variable is null or unset), and the
+.BR tempfile (1)
+command is used to create a file in that temporary directory called
+.IR Xauthority .
+.TP
+.B \-h\fR,\fB \-\-help
+Display a usage message and exit.
+.TP
+.BI \-n\ servernumber \fR,\fB\ \-\-server\-num= servernumber
+Use
+.I servernumber
+as the server number (but see the
+.B \-a\fR,\fB \-\-auto\-servernum
+option above).
+The default is 99.
+.TP
+.B \-l\fR,\fB \-\-listen\-tcp
+Enable TCP port listening in the X server.
+For security reasons (to avoid denial\-of\-service attacks or exploits),
+TCP port listening is disabled by default.
+.TP
+.BI \-p\ protocolname \fR,\fB\ \-\-xauth\-protocol= protocolname
+Use
+.I protocolname
+as the X authority protocol to use.
+The default is \(oq.\(cq, which
+.B xauth
+interprets as its own default protocol, which is MIT\-MAGIC\-COOKIE\-1.
+.TP
+.BI \-s\ arguments \fR,\fB\ \-\-server\-args= arguments
+Pass
+.I arguments
+to the
+.B Xvfb
+server.
+Be careful to quote any whitespace characters that may occur within
+.I arguments
+to prevent them from regarded as separators for
+.BR xvfb\-run 's
+own arguments.
+Also, note that specification of \(oq\-nolisten tcp\(cq in
+.I arguments
+may override the function of
+.BR xvfb\-run 's
+own
+.B \-l\fR,\fB \-\-listen\-tcp
+option, and that specification of the server number (e.g., \(oq:1\(cq) may
+be ignored because of the way the X server parses its argument list.
+Use the
+.B xvfb\-run
+option
+.BI \-n\ servernumber \fR,\fB\ \-\-server\-num= servernumber
+to achieve the latter function.
+The default is \(oq\-screen 0 640x480x8\(cq.
+.TP
+.BI \-w\ delay \fR,\fB\ \-\-wait= delay
+Wait
+.I delay
+seconds after launching
+.B Xvfb
+before attempting to start the specified command.
+The default is 3.
+.SH ENVIRONMENT
+.TP
+.B COLUMNS
+indicates the width of the terminal device in character cells.
+This value is used for formatting diagnostic messages.
+If not set, the terminal is queried using
+.BR stty (1)
+to determine its width.
+If that fails, a value of \(oq80\(cq is assumed.
+.TP
+.B TMPDIR
+specifies the directory in which to place
+.BR xvfb\-run 's
+temporary directory for storage of the X authority file; only used if the
+.B \-f
+or
+.B \-\-auth\-file
+options are not specified.
+.SH "OUTPUT FILES"
+.PP
+Unless the
+.B \-f
+or
+.B \-\-auth\-file
+options are specified, a temporary
+directory and file within it are created (and deleted) to store the X
+authority cookies used by the
+.B Xvfb
+server and client(s) run under it.
+See
+.BR tempfile (1).
+If \-f or \-\-auth\-file are used, then the specified X authority file is
+only written to, not created or deleted (though
+.B xauth
+creates an authority file itself if told to use use that does not already
+exist).
+.PP
+An error file with a user\-specified name is also created if the
+.B \-e
+or
+.B \-\-error\-file
+options are specifed; see above.
+.SH "EXIT STATUS"
+.B xvfb\-run
+uses its exit status as well as output to standard error to communicate
+diagnostics.
+The exit status of \(oq1\(cq is not used, and should be interpreted as failure
+of the specified command.
+.TP
+0
+.B xvfb\-run
+only uses this exit status if the
+.B \-h\fR,\fB \-\-help
+option is given.
+In all other situations, this may be interpreted as success of the specified
+command.
+.TP
+2
+No command to run was specified.
+.TP
+3
+The
+.B xauth
+command is not available.
+.TP
+4
+The temporary directory that was going to be used already exists; since
+.B xvfb\-run
+produces a uniquely named directory, this may indicate an attempt by another
+process on the system to exploit a temporary file race condition.
+.TP
+5
+A problem was encountered while cleaning up the temporary directory.
+.TP
+6
+A problem was encountered while using
+.BR getopt (1)
+to parse the command\-line arguments.
+.SH EXAMPLES
+.TP
+.B xvfb\-run \-\-auto\-servernum \-\-server\-num=1 xlogo
+runs the
+.BR xlogo (1x)
+demonstration client inside the
+.B Xvfb
+X server on the first available server number greater than or equal to 1.
+.TP
+.B xvfb\-run \-\-server\-args="\-screen 0 1024x768x24" ico \-faces
+runs the
+.BR ico (1x)
+demonstration client (and passes it the
+.B \-faces
+argument) inside the
+.B Xvfb
+X server, configured with a root window of 1024 by 768 pixels and a color
+depth of 24 bits.
+.PP
+Note that the demo X clients used in the above examples will not exit on
+their own, so they will have to be killed before
+.B xvfb\-run
+will exit.
+.SH BUGS
+See
+.URL "http://bugs.debian.org/xvfb" "the Debian Bug Tracking System" .
+If you wish to report a bug in
+.BR xvfb\-run ,
+please use the
+.BR reportbug (1)
+command.
+.SH AUTHOR
+.B xfvb\-run
+was written by Branden Robinson and Jeff Licquia with sponsorship from
+Progeny Linux Systems.
+.SH "SEE ALSO"
+.BR Xvfb (1x),
+.BR xauth (1x)
+.\" vim:set et tw=80: