summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-10-11 22:45:07 -0400
committerVincent Grande2020-10-11 22:45:07 -0400
commit5cc713a66857110b6dba7041e1d8bcdff5019328 (patch)
treef6f89cc9f1774ee6e7c50d5d1d998853c8cfc3ef
parent2cfca31e77d96f5a6eac57434adb7913b0b93343 (diff)
downloadaur-5cc713a66857110b6dba7041e1d8bcdff5019328.tar.gz
xwayland fix
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 26 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abf9e3a075a1..6089c317e44e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -68,6 +68,19 @@ pkgname = xorg-server-rootless-nosystemd-minimal-git
replaces = glamor-egl
replaces = xf86-video-modesetting
+pkgname = xorg-server-xwayland-rootless-nosystemd-minimal-git
+ pkgdesc = run X clients under wayland
+ depends = libxfont2
+ depends = libepoxy
+ depends = libgl
+ depends = pixman
+ depends = xorg-server-common-rootless-nosystemd-minimal-git
+ depends = nettle
+ depends = libtirpc
+ optdepends = libunwind: unwind backtrace support
+ provides = xorg-server-xwayland
+ conflicts = xorg-server-xwayland
+
pkgname = xorg-server-common-rootless-nosystemd-minimal-git
pkgdesc = Xorg server common files
depends = xkeyboard-config
diff --git a/PKGBUILD b/PKGBUILD
index a8611c64a489..63ccb20b6f1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
# 'xorg-server-xephyr-rootless-nosystemd-minimal-git'
# 'xorg-server-xvfb-rootless-nosystemd-minimal-git'
# 'xorg-server-xnest-rootless-nosystemd-minimal-git'
-# 'xorg-server-xwayland-rootless-nosystemd-minimal-git'
+ 'xorg-server-xwayland-rootless-nosystemd-minimal-git'
'xorg-server-common-rootless-nosystemd-minimal-git'
'xorg-server-devel-rootless-nosystemd-minimal-git')
@@ -73,8 +73,8 @@ build() {
-D ipv6=false \
-D xcsecurity=true \
-D xorg=true \
- -D xwayland=false \
- -D xwayland_eglstream=false \
+ -D xwayland=true \
+ -D xwayland_eglstream=true \
-D udev=true \
-D suid_wrapper=false \
-D xkb_dir=/usr/share/X11/xkb \
@@ -216,19 +216,19 @@ package_xorg-server-rootless-nosystemd-minimal-git() {
# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
#}
-#package_xorg-server-xwayland-rootless-nosystemd-minimal-git() {
-# pkgdesc="run X clients under wayland"
-# depends=(libxfont2 libepoxy libgl pixman xorg-server-common-rootless-nosystemd-minimal-git
-# nettle libtirpc)
-# optdepends=('libunwind: unwind backtrace support')
-# conflicts=('xorg-server-xwayland')
-# provides=('xorg-server-xwayland')
+package_xorg-server-xwayland-rootless-nosystemd-minimal-git() {
+ pkgdesc="run X clients under wayland"
+ depends=(libxfont2 libepoxy libgl pixman xorg-server-common-rootless-nosystemd-minimal-git
+ nettle libtirpc)
+ optdepends=('libunwind: unwind backtrace support')
+ conflicts=('xorg-server-xwayland')
+ provides=('xorg-server-xwayland')
-# _install fakeinstall/usr/bin/Xwayland
+ _install fakeinstall/usr/bin/Xwayland
# license
# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
-#}
+}
package_xorg-server-devel-rootless-nosystemd-minimal-git() {
pkgdesc="Development files for the X.Org X server"
@@ -246,7 +246,7 @@ package_xorg-server-devel-rootless-nosystemd-minimal-git() {
# install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xorg-server/COPYING
# make sure there are no files left to install
- find fakeinstall -depth -print0 | xargs -0 rmdir
+# find fakeinstall -depth -print0 | xargs -0 rmdir
}
arch=('x86_64')