summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlxhillwind2015-11-29 15:38:17 +0800
committerlxhillwind2015-11-29 15:38:17 +0800
commite988a5c2a714cf1706e19e04af2597ea6ca8f631 (patch)
treea091adbf3e49d5aab4ffc46cd314c646191a6d91
downloadaur-e988a5c2a714cf1706e19e04af2597ea6ca8f631.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--percent_float_to_int.patch11
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b18dfd4c3c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xorg-xbacklight-lxhillwind-patch
+ pkgdesc = RandR-based backlight control application, with brightness represented as an integer.
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://xorg.freedesktop.org/
+ arch = i686
+ arch = x86_64
+ groups = xorg-apps
+ groups = xorg
+ license = custom
+ depends = xcb-util
+ conflicts = xorg-xbacklight
+ source = http://xorg.freedesktop.org/archive/individual/app/xbacklight-1.2.1.tar.bz2
+ source = percent_float_to_int.patch
+ sha256sums = 17f6cf51a35eaa918abec36b7871d28b712c169312e22a0eaf1ffe8d6468362b
+ sha256sums = b5b776f63c0ed95fd0cb1bb84cb831002304960b0d552114d807c0ad6582857b
+
+pkgname = xorg-xbacklight-lxhillwind-patch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a7ce2f227f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: lxhillwind <lxhillwind@gmail.com>
+
+pkgname=xorg-xbacklight-lxhillwind-patch
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="RandR-based backlight control application, with brightness represented as an integer."
+arch=('i686' 'x86_64')
+url="http://xorg.freedesktop.org/"
+license=('custom')
+depends=('xcb-util')
+conflicts=('xorg-xbacklight')
+groups=('xorg-apps' 'xorg')
+source=("http://xorg.freedesktop.org/archive/individual/app/xbacklight-${pkgver}.tar.bz2"
+ 'percent_float_to_int.patch')
+sha256sums=('17f6cf51a35eaa918abec36b7871d28b712c169312e22a0eaf1ffe8d6468362b'
+ 'b5b776f63c0ed95fd0cb1bb84cb831002304960b0d552114d807c0ad6582857b')
+
+build() {
+ cd xbacklight-${pkgver}
+ patch -Np0 -i $srcdir/percent_float_to_int.patch
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd xbacklight-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
diff --git a/percent_float_to_int.patch b/percent_float_to_int.patch
new file mode 100644
index 000000000000..49fedfef3b55
--- /dev/null
+++ b/percent_float_to_int.patch
@@ -0,0 +1,11 @@
+--- xbacklight.c 2013-10-08 11:40:38.000000000 +0800
++++ xbacklight.c 2015-11-29 14:39:46.453990196 +0800
+@@ -282,7 +282,7 @@
+ max = values[1];
+
+ if (op == Get) {
+- printf ("%f\n", (cur - min) * 100 / (max - min));
++ printf ("%d\n", (int)((cur - min) * 100 / (max - min)));
+ } else {
+ set = value * (max - min) / 100;
+ switch (op) {