summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-02-15 18:53:28 -0500
committerVincent Grande2021-02-15 18:53:28 -0500
commit8cce3eb74730ac7ce48f165675ba3da2174f60c9 (patch)
treeab58d5b3baad129d1eb208c0e68c4786a4b0adfa
downloadaur-8cce3eb74730ac7ce48f165675ba3da2174f60c9.tar.gz
initial upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36af6328cdd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xorg-xinput-git
+ pkgdesc = Small commandline tool to configure devices
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/
+ arch = x86_64
+ groups = xorg-apps
+ groups = xorg
+ license = custom
+ makedepends = xorg-util-macros
+ makedepends = xorgproto
+ makedepends = libxfixes
+ depends = libx11
+ depends = libxi>=1.5.99.2
+ depends = xorg-xrandr
+ depends = libxinerama
+ provides = xorg-xinput
+ conflicts = xorg-xinput
+ source = git+https://gitlab.freedesktop.org/xorg/app/xinput
+ sha512sums = SKIP
+
+pkgname = xorg-xinput-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f2bf1e6c7d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=xorg-xinput-git
+pkgver=1.6.3
+pkgrel=1
+pkgdesc="Small commandline tool to configure devices"
+arch=(x86_64)
+url="https://xorg.freedesktop.org/"
+license=('custom')
+depends=('libx11' 'libxi>=1.5.99.2' 'xorg-xrandr' 'libxinerama')
+makedepends=('xorg-util-macros' 'xorgproto' 'libxfixes')
+provides=(xorg-xinput)
+conflicts=(xorg-xinput)
+groups=('xorg-apps' 'xorg')
+source=(git+https://gitlab.freedesktop.org/xorg/app/xinput)
+sha512sums=('SKIP')
+#validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # "Peter Hutterer (Who-T) <office@who-t.net>"
+
+pkgver() {
+ cd xinput
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd xinput
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd xinput
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+}