summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-04-30 03:22:10 -0400
committerJames An2015-04-30 03:22:10 -0400
commit26109d12d7d9fab813a082fa373be3919cb0fa47 (patch)
tree2c6db9950d86b9759f68affacde8e14371a8a770
downloadaur-26109d12d7d9fab813a082fa373be3919cb0fa47.tar.gz
Updated xorg-xrandr-git to latest upstream version and fixed minor exceptions to packaging standards.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f74f68ee63c6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = xorg-xrandr-git
+ pkgdesc = Primitive command line interface to RandR extension. Git version.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://www.x.org/wiki/Projects/XRandR
+ arch = i686
+ arch = x86_64
+ groups = xorg-apps
+ groups = xorg
+ license = custom
+ makedepends = xorg-util-macros
+ makedepends = git
+ depends = libxrandr>=1.5.0
+ depends = libx11
+ provides = xorg-xrandr=1.5.0
+ conflicts = xorg-xrandr
+ source = xrandr::git+http://anongit.freedesktop.org/git/xorg/app/xrandr.git
+ md5sums = SKIP
+
+pkgname = xorg-xrandr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d92ac84968a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: James An <james@jamesan.ca>
+# Contributor: Nikita Mikhailov <nslqqq@gmail.com>
+
+_pkgname=xrandr
+pkgname=xorg-xrandr-git
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='Primitive command line interface to RandR extension. Git version.'
+arch=(i686 x86_64)
+url='http://www.x.org/wiki/Projects/XRandR'
+license=('custom')
+groups=('xorg-apps' 'xorg')
+depends=('libxrandr>=1.5.0' 'libx11')
+makedepends=('xorg-util-macros' 'git')
+provides=("xorg-$_pkgname=$pkgver")
+conflicts=("xorg-$_pkgname")
+source=("$_pkgname"::"git+http://anongit.freedesktop.org/git/xorg/app/xrandr.git")
+md5sums=('SKIP')
+
+#~ pkgver() {
+ #~ cd "$_pkgname"
+ #~ (
+ #~ set -o pipefail
+ #~ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ #~ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #~ )
+#~ }
+
+build() {
+ cd "$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"
+ rm -f "${pkgdir}/usr/bin/xkeystone"
+}