summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Décimo2020-12-12 19:38:02 +0100
committerAntonin Décimo2020-12-12 20:46:32 +0100
commit1ff3a386bee1c90a95a80132b6fb07e3afb42b22 (patch)
treeb03b11ddac7740b38fc27038b15c461974894ee7
downloadaur-1ff3a386bee1c90a95a80132b6fb07e3afb42b22.tar.gz
Create xorg-xwayland-git from xorg-xwayland 1.20.0.r792.g36e353bcf-5
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD76
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9aebc583eaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = xorg-xwayland-git
+ pkgdesc = run X clients under wayland
+ pkgver = 1.20.0.r795.gf95d81e88
+ pkgrel = 1
+ url = https://xorg.freedesktop.org
+ arch = x86_64
+ groups = xorg
+ license = custom
+ makedepends = meson
+ makedepends = git
+ makedepends = xorgproto
+ makedepends = xtrans
+ makedepends = pixman
+ makedepends = libxkbfile
+ makedepends = libxfont2
+ makedepends = dbus
+ makedepends = xorg-font-util
+ makedepends = wayland
+ makedepends = wayland-protocols
+ makedepends = libdrm
+ makedepends = libepoxy
+ makedepends = mesa-libgl
+ makedepends = systemd
+ makedepends = egl-wayland
+ depends = nettle
+ depends = libepoxy
+ depends = systemd-libs
+ depends = libxfont2
+ depends = pixman
+ depends = xorg-server-common
+ provides = xorg-xwayland
+ provides = xorg-server-xwayland
+ provides = xorg-server-xwayland-git
+ conflicts = xorg-xwayland
+ conflicts = xorg-server-xwayland
+ conflicts = xorg-server-xwayland-git
+ replaces = xorg-server-xwayland-git
+ source = xserver::git+https://gitlab.freedesktop.org/xorg/xserver.git
+ sha256sums = SKIP
+
+pkgname = xorg-xwayland-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29f88ca4e178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=xorg-xwayland-git
+pkgver=1.20.0.r795.gf95d81e88
+pkgrel=1
+arch=('x86_64')
+license=('custom')
+groups=('xorg')
+url="https://xorg.freedesktop.org"
+pkgdesc="run X clients under wayland"
+depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2'
+ 'pixman' 'xorg-server-common')
+makedepends=('meson' 'git'
+ 'xorgproto' 'xtrans'
+ 'pixman' 'libxkbfile' 'libxfont2' 'dbus'
+ 'xorg-font-util'
+ 'wayland' 'wayland-protocols'
+ 'libdrm' 'libepoxy' 'mesa-libgl'
+ 'systemd'
+ 'egl-wayland'
+)
+source=("xserver::git+https://gitlab.freedesktop.org/xorg/xserver.git")
+sha256sums=('SKIP')
+provides=('xorg-xwayland' 'xorg-server-xwayland' 'xorg-server-xwayland-git')
+conflicts=('xorg-xwayland' 'xorg-server-xwayland' 'xorg-server-xwayland-git')
+replaces=('xorg-server-xwayland-git')
+
+pkgver() {
+ cd xserver
+ git describe --tags | sed 's/^xorg.server.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
+ # With them, module fail to load with undefined symbol.
+ # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
+# export CFLAGS=${CFLAGS/-fno-plt}
+# export CXXFLAGS=${CXXFLAGS/-fno-plt}
+# export LDFLAGS=${LDFLAGS/,-z,now}
+
+ arch-meson xserver build \
+ -D os_vendor="Arch Linux" \
+ -D ipv6=true \
+ -D xvfb=false \
+ -D xnest=false \
+ -D xcsecurity=true \
+ -D xorg=false \
+ -D xephyr=false \
+ -D xwayland=true \
+ -D xwayland_eglstream=true \
+ -D xwin=false \
+ -D xquartz=false \
+ -D glamor=true \
+ -D udev=true \
+ -D systemd_logind=true \
+ -D suid_wrapper=true \
+ -D xkb_dir=/usr/share/X11/xkb \
+ -D xkb_output_dir=/var/lib/xkb
+
+ # Print config
+ meson configure build
+ ninja -C build
+}
+
+package() {
+
+ # bin + manpage + .pc file
+ install -m755 -Dt "${pkgdir}"/usr/bin build/hw/xwayland/Xwayland
+ install -m644 -Dt "${pkgdir}"/usr/share/man/man1 build/hw/xwayland/Xwayland.1
+ install -m644 -Dt "${pkgdir}"/usr/lib/pkgconfig build/hw/xwayland/xwayland.pc
+
+ # license
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xserver/COPYING
+}
+