summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonin Décimo2021-06-04 00:03:41 +0200
committerAntonin Décimo2021-06-04 00:03:41 +0200
commit9cf29e33f9bbe1621890cce3daed6bc0d58981b3 (patch)
treeef4ac199f90cb2a192da52d880a84e7e3e939c83
parenta48ee854816ddaf486a4d8d0e58e891636d97680 (diff)
downloadaur-9cf29e33f9bbe1621890cce3daed6bc0d58981b3.tar.gz
Accurate package version
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25c0ac3b14d6..4362f9b04ce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xorg-xwayland-git
pkgdesc = Run X clients under Wayland (git version)
- pkgver = 21.1.1.r0.gd4cc2e2db
+ pkgver = 21.1.1.r134.g8274dd664
pkgrel = 1
url = https://xorg.freedesktop.org
arch = x86_64
@@ -39,4 +39,3 @@ pkgbase = xorg-xwayland-git
sha256sums = SKIP
pkgname = xorg-xwayland-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3745f14ce58e..2f9388eb422f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: AndyRTR <andyrtr@archlinux.org>
pkgname=xorg-xwayland-git
-pkgver=21.1.1.r0.gd4cc2e2db
+pkgver=21.1.1.r134.g8274dd664
pkgrel=1
arch=('x86_64')
license=('custom')
@@ -28,9 +28,11 @@ replaces=('xorg-server-xwayland-git')
pkgver() {
cd xserver
- { git checkout xwayland-21.1; } > /dev/null
- git describe --long | sed 's/^xwayland.//;s/\([^-]*-g\)/r\1/;s/-/./g'
- { git checkout master; } > /dev/null
+ local branch=xwayland-21.1
+ local head=$(git rev-parse --short HEAD)
+ local tag=$(git describe --abbrev=0 "$branch")
+ local revisions=$(git rev-list "${tag}..HEAD" --count)
+ printf "%s.r%d.g%s" "$(echo "$tag" | sed 's/^xwayland.//')" "$revisions" "$head"
}
build() {