summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2024-04-28 04:28:31 +0900
committerXuanrui Qi2024-04-28 04:28:31 +0900
commita59ff209c969cf3f558da60baa68ae8833d9f9c2 (patch)
tree74c02511a62c361958565b3856d05b472056e050
parent2d1325df721f70c1760615b3837a94e57c4fad6b (diff)
downloadaur-a59ff209c969cf3f558da60baa68ae8833d9f9c2.tar.gz
Align the PKGBUILD with repo version
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD56
2 files changed, 60 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a27b36723546..4728005a4166 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,51 @@
pkgbase = xorg-xwayland-git
pkgdesc = Run X clients under Wayland (git version)
pkgver = 24.0.99.901.r102.g08113b892
- pkgrel = 1
+ pkgrel = 2
url = https://xorg.freedesktop.org
arch = x86_64
groups = xorg
- license = custom
+ license = LicenseRef-Adobe-Display-PostScript
+ license = BSD-3-Clause
+ license = LicenseRef-DEC-3-Clause
+ license = HPND
+ license = LicenseRef-HPND-sell-MIT-disclaimer-xserver
+ license = HPND-sell-variant
+ license = ICU
+ license = ISC
+ license = MIT
+ license = MIT-open-group
+ license = NTP
+ license = SGI-B-2.0
+ license = SMLNJ
+ license = X11
+ license = X11-distribute-modifications-variant
makedepends = meson
- makedepends = git
makedepends = xorgproto
makedepends = xtrans
makedepends = libxkbfile
makedepends = dbus
makedepends = xorg-font-util
- makedepends = wayland
makedepends = wayland-protocols
- makedepends = libdrm
+ makedepends = mesa-libgl
makedepends = systemd
+ makedepends = git
depends = nettle
- depends = libegl
depends = libepoxy
depends = systemd-libs
depends = libxfont2
depends = pixman
depends = xorg-server-common
depends = libxcvt
+ depends = mesa
+ depends = libglvnd
+ depends = libxau
+ depends = wayland
+ depends = libdrm
+ depends = libtirpc
+ depends = libei
+ depends = libxshmfence
+ depends = glibc
provides = xorg-xwayland
provides = xorg-server-xwayland
provides = xorg-server-xwayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 483a6e04957f..38f67620f225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,37 @@
-# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
+# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
+# Contributor: Antonin Décimo <antonin dot decimo at gmail dot com>
# Contributor: AndyRTR <andyrtr@archlinux.org>
pkgname=xorg-xwayland-git
pkgver=24.0.99.901.r102.g08113b892
-pkgrel=1
+pkgrel=2
arch=('x86_64')
-license=('custom')
+license=(
+ LicenseRef-Adobe-Display-PostScript
+ BSD-3-Clause
+ LicenseRef-DEC-3-Clause
+ HPND
+ LicenseRef-HPND-sell-MIT-disclaimer-xserver
+ HPND-sell-variant
+ ICU
+ ISC
+ MIT
+ MIT-open-group
+ NTP
+ SGI-B-2.0
+ SMLNJ
+ X11
+ X11-distribute-modifications-variant)
groups=('xorg')
url="https://xorg.freedesktop.org"
pkgdesc="Run X clients under Wayland (git version)"
-depends=('nettle' 'libegl' 'libepoxy' 'systemd-libs' 'libxfont2'
- 'pixman' 'xorg-server-common' 'libxcvt')
-makedepends=('meson' 'git'
- 'xorgproto'
- 'xtrans'
- 'libxkbfile' 'dbus'
- 'xorg-font-util'
- 'wayland'
- 'wayland-protocols'
- 'libdrm'
- 'systemd'
-)
+depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2'
+ 'pixman' 'xorg-server-common' 'libxcvt' 'mesa'
+ 'libglvnd' 'libxau' 'wayland' 'libdrm' 'libtirpc'
+ 'libei' 'libxshmfence' 'glibc')
+makedepends=('meson' 'xorgproto' 'xtrans' 'libxkbfile' 'dbus'
+ 'xorg-font-util' 'wayland-protocols' 'mesa-libgl'
+ 'systemd' 'git')
source=("xserver::git+https://gitlab.freedesktop.org/xorg/xserver.git")
sha256sums=('SKIP')
@@ -49,16 +60,15 @@ build() {
-D ipv6=true \
-D xvfb=false \
-D xnest=false \
+ -D xdmcp=false \
-D xcsecurity=true \
-D xorg=false \
-D xephyr=false \
-D xwayland=true \
-D xwin=false \
-D xquartz=false \
+ -D dri3=true \
-D glamor=true \
- -D udev=true \
- -D systemd_logind=true \
- -D suid_wrapper=true \
-D xkb_dir=/usr/share/X11/xkb \
-D xkb_output_dir=/var/lib/xkb
@@ -66,11 +76,11 @@ build() {
}
package() {
-
- # bin + manpage + .pc file
- install -m755 -Dt "${pkgdir}"/usr/bin build/hw/xwayland/Xwayland
- install -m644 -Dt "${pkgdir}"/usr/share/man/man1 build/hw/xwayland/Xwayland.1
- install -m644 -Dt "${pkgdir}"/usr/lib/pkgconfig build/meson-private/xwayland.pc
+ DESTDIR="${pkgdir}" ninja -C build install
+ # xorg-server-common file /usr/lib/xorg/protocol.txt
+ rm "${pkgdir}"/usr/lib/xorg/protocol.txt
+ rmdir "${pkgdir}"/usr/lib/xorg
+ rm "${pkgdir}"/usr/share/man/man1/Xserver.1
# license
install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xserver/COPYING