summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2022-09-08 01:17:36 +0800
committerq234rty2022-09-08 01:17:36 +0800
commit4c2e2b3ffc0cdd2c9c856995338fa661b345724f (patch)
tree9d2d0ce032e237d588a834a67dae085d067660be
downloadaur-4c2e2b3ffc0cdd2c9c856995338fa661b345724f.tar.gz
Initial commit
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD62
-rw-r--r--hidpi.patch497
3 files changed, 601 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f98dd1b0253c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = xorg-xwayland-hidpi-xprop
+ pkgdesc = run X clients under wayland, with !733 HiDPI patch
+ pkgver = 22.1.3
+ pkgrel = 1
+ url = https://xorg.freedesktop.org
+ arch = x86_64
+ license = custom
+ makedepends = meson
+ makedepends = xorgproto
+ makedepends = xtrans
+ makedepends = libxkbfile
+ makedepends = dbus
+ makedepends = xorg-font-util
+ makedepends = wayland
+ makedepends = wayland-protocols
+ makedepends = libdrm
+ makedepends = mesa-libgl
+ makedepends = systemd
+ makedepends = egl-wayland
+ depends = nettle
+ depends = libepoxy
+ depends = systemd-libs
+ depends = libxfont2
+ depends = pixman
+ depends = xorg-server-common
+ depends = libxcvt
+ provides = xorg-server-xwayland
+ provides = xorg-xwayland
+ conflicts = xorg-server-xwayland
+ conflicts = xorg-xwayland
+ replaces = xorg-server-xwayland
+ options = debug
+ options = strip
+ source = https://xorg.freedesktop.org/archive/individual/xserver/xwayland-22.1.3.tar.xz
+ source = https://xorg.freedesktop.org/archive/individual/xserver/xwayland-22.1.3.tar.xz.sig
+ source = hidpi.patch
+ validpgpkeys = 67DC86F2623FC5FD4BB5225D14706DBE1E4B4540
+ sha512sums = be15cb398f9a8aad70352d09b0745c827d4766d5996e817b92c828b5ede27b10186c7ee319901abdc5e141da97170a3ace039269146461d4e2ceb5002a7c35b4
+ sha512sums = SKIP
+ sha512sums = d0e7dfe38157947dc4b3a3e7ac0c867d06eeb8d760035227a7cb4aca987a91053cc3c7c4f50d4ade6f1eb7fad631a173ceb75c6b9a896dc22a3aba2221264131
+
+pkgname = xorg-xwayland-hidpi-xprop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43364631e10e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: q234 rty <q23456yuiop at gmail dot com>
+# Contributor: lilydjwg <lilydjwg@gmail.com>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+
+pkgname=xorg-xwayland-hidpi-xprop
+pkgver=22.1.3
+pkgrel=1
+arch=('x86_64')
+license=('custom')
+url="https://xorg.freedesktop.org"
+pkgdesc="run X clients under wayland, with !733 HiDPI patch"
+depends=('nettle' 'libepoxy' 'systemd-libs' 'libxfont2'
+ 'pixman' 'xorg-server-common' 'libxcvt')
+makedepends=('meson' 'xorgproto' 'xtrans' 'libxkbfile' 'dbus'
+ 'xorg-font-util'
+ 'wayland' 'wayland-protocols'
+ 'libdrm' 'mesa-libgl'
+ 'systemd'
+ 'egl-wayland'
+)
+source=(https://xorg.freedesktop.org/archive/individual/xserver/xwayland-$pkgver.tar.xz{,.sig} hidpi.patch)
+sha512sums=('be15cb398f9a8aad70352d09b0745c827d4766d5996e817b92c828b5ede27b10186c7ee319901abdc5e141da97170a3ace039269146461d4e2ceb5002a7c35b4'
+ 'SKIP' d0e7dfe38157947dc4b3a3e7ac0c867d06eeb8d760035227a7cb4aca987a91053cc3c7c4f50d4ade6f1eb7fad631a173ceb75c6b9a896dc22a3aba2221264131)
+provides=('xorg-server-xwayland' 'xorg-xwayland')
+conflicts=('xorg-server-xwayland' 'xorg-xwayland')
+replaces=('xorg-server-xwayland')
+#validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # "Michel Daenzer <michel@daenzer.net>"
+validpgpkeys=('67DC86F2623FC5FD4BB5225D14706DBE1E4B4540') # "Olivier Fourdan <fourdan@xfce.org>"
+options=('debug' 'strip')
+
+prepare() {
+ cd "${srcdir}/xwayland-$pkgver"
+ patch -Np1 < ../hidpi.patch
+}
+
+build() {
+ arch-meson xwayland-$pkgver build \
+ -D ipv6=true \
+ -D xvfb=false \
+ -D xdmcp=false \
+ -D xcsecurity=true \
+ -D dri3=true \
+ -D xwayland_eglstream=true \
+ -D glamor=true \
+ -D xkb_dir=/usr/share/X11/xkb \
+ -D xkb_output_dir=/var/lib/xkb
+
+ # Print config
+ meson configure build
+ ninja -C build
+}
+
+package() {
+
+ # bin + manpage + .pc file
+ install -m755 -Dt "${pkgdir}"/usr/bin build/hw/xwayland/Xwayland
+ install -m644 -Dt "${pkgdir}"/usr/share/man/man1 build/hw/xwayland/Xwayland.1
+ install -m644 -Dt "${pkgdir}"/usr/lib/pkgconfig build/hw/xwayland/xwayland.pc
+
+ # license
+ install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" xwayland-$pkgver/COPYING
+}
diff --git a/hidpi.patch b/hidpi.patch
new file mode 100644
index 000000000000..80f1ecf8f4f2
--- /dev/null
+++ b/hidpi.patch
@@ -0,0 +1,497 @@
+diff --git a/hw/xwayland/xwayland-cursor.c b/hw/xwayland/xwayland-cursor.c
+index c4457cc2a..4a33e1f33 100644
+--- a/hw/xwayland/xwayland-cursor.c
++++ b/hw/xwayland/xwayland-cursor.c
+@@ -171,6 +171,8 @@ xwl_cursor_attach_pixmap(struct xwl_seat *xwl_seat,
+ }
+
+ wl_surface_attach(xwl_cursor->surface, buffer, 0, 0);
++ wl_surface_set_buffer_scale(xwl_cursor->surface,
++ xwl_seat->xwl_screen->global_output_scale);
+ xwl_surface_damage(xwl_seat->xwl_screen, xwl_cursor->surface, 0, 0,
+ xwl_seat->x_cursor->bits->width,
+ xwl_seat->x_cursor->bits->height);
+@@ -190,6 +192,7 @@ xwl_cursor_attach_pixmap(struct xwl_seat *xwl_seat,
+ void
+ xwl_seat_set_cursor(struct xwl_seat *xwl_seat)
+ {
++ struct xwl_screen *xwl_screen = xwl_seat->xwl_screen;
+ struct xwl_cursor *xwl_cursor = &xwl_seat->cursor;
+ PixmapPtr pixmap;
+ CursorPtr cursor;
+@@ -220,8 +223,8 @@ xwl_seat_set_cursor(struct xwl_seat *xwl_seat)
+ wl_pointer_set_cursor(xwl_seat->wl_pointer,
+ xwl_seat->pointer_enter_serial,
+ xwl_cursor->surface,
+- xwl_seat->x_cursor->bits->xhot,
+- xwl_seat->x_cursor->bits->yhot);
++ xwl_scale_to(xwl_screen, xwl_seat->x_cursor->bits->xhot),
++ xwl_scale_to(xwl_screen, xwl_seat->x_cursor->bits->yhot));
+
+ xwl_cursor_attach_pixmap(xwl_seat, xwl_cursor, pixmap);
+ }
+@@ -230,6 +233,7 @@ void
+ xwl_tablet_tool_set_cursor(struct xwl_tablet_tool *xwl_tablet_tool)
+ {
+ struct xwl_seat *xwl_seat = xwl_tablet_tool->seat;
++ struct xwl_screen *xwl_screen = xwl_seat->xwl_screen;
+ struct xwl_cursor *xwl_cursor = &xwl_tablet_tool->cursor;
+ PixmapPtr pixmap;
+ CursorPtr cursor;
+@@ -258,9 +262,9 @@ xwl_tablet_tool_set_cursor(struct xwl_tablet_tool *xwl_tablet_tool)
+ zwp_tablet_tool_v2_set_cursor(xwl_tablet_tool->tool,
+ xwl_tablet_tool->proximity_in_serial,
+ xwl_cursor->surface,
+- xwl_seat->x_cursor->bits->xhot,
+- xwl_seat->x_cursor->bits->yhot);
+-
++ xwl_scale_to(xwl_screen, xwl_seat->x_cursor->bits->xhot),
++ xwl_scale_to(xwl_screen, xwl_seat->x_cursor->bits->yhot));
++ wl_surface_set_buffer_scale(xwl_cursor->surface, xwl_screen->global_output_scale);
+ xwl_cursor_attach_pixmap(xwl_seat, xwl_cursor, pixmap);
+ }
+
+diff --git a/hw/xwayland/xwayland-input.c b/hw/xwayland/xwayland-input.c
+index 26b3630c7..55cd8d466 100644
+--- a/hw/xwayland/xwayland-input.c
++++ b/hw/xwayland/xwayland-input.c
+@@ -412,8 +412,8 @@ pointer_handle_enter(void *data, struct wl_pointer *pointer,
+ DeviceIntPtr dev = get_pointer_device(xwl_seat);
+ DeviceIntPtr master;
+ int i;
+- int sx = wl_fixed_to_int(sx_w);
+- int sy = wl_fixed_to_int(sy_w);
++ int sx = wl_fixed_to_int(sx_w) * xwl_seat->xwl_screen->global_output_scale;
++ int sy = wl_fixed_to_int(sy_w) * xwl_seat->xwl_screen->global_output_scale;
+ int dx, dy;
+ ScreenPtr pScreen = xwl_seat->xwl_screen->screen;
+ ValuatorMask mask;
+@@ -592,13 +592,14 @@ pointer_handle_motion(void *data, struct wl_pointer *pointer,
+ uint32_t time, wl_fixed_t sx_w, wl_fixed_t sy_w)
+ {
+ struct xwl_seat *xwl_seat = data;
++ int32_t scale = xwl_seat->xwl_screen->global_output_scale;
+
+ if (!xwl_seat->focus_window)
+ return;
+
+ xwl_seat->pending_pointer_event.has_absolute = TRUE;
+- xwl_seat->pending_pointer_event.x = sx_w;
+- xwl_seat->pending_pointer_event.y = sy_w;
++ xwl_seat->pending_pointer_event.x = sx_w * scale;
++ xwl_seat->pending_pointer_event.y = sy_w * scale;
+
+ if (wl_proxy_get_version((struct wl_proxy *) xwl_seat->wl_pointer) < 5)
+ dispatch_pointer_motion_event(xwl_seat);
+@@ -672,7 +673,8 @@ pointer_handle_axis(void *data, struct wl_pointer *pointer,
+ xorg_list_del(&pending->l);
+ free(pending);
+ } else {
+- valuator_mask_set_double(&mask, index, wl_fixed_to_double(value) / divisor);
++ double scaled_value = wl_fixed_to_double(value);
++ valuator_mask_set_double(&mask, index, scaled_value / divisor);
+ }
+
+ QueuePointerEvents(get_pointer_device(xwl_seat),
+@@ -740,12 +742,13 @@ relative_pointer_handle_relative_motion(void *data,
+ wl_fixed_t dy_unaccelf)
+ {
+ struct xwl_seat *xwl_seat = data;
++ int32_t scale = xwl_seat->xwl_screen->global_output_scale;
+
+ xwl_seat->pending_pointer_event.has_relative = TRUE;
+- xwl_seat->pending_pointer_event.dx = wl_fixed_to_double(dxf);
+- xwl_seat->pending_pointer_event.dy = wl_fixed_to_double(dyf);
+- xwl_seat->pending_pointer_event.dx_unaccel = wl_fixed_to_double(dx_unaccelf);
+- xwl_seat->pending_pointer_event.dy_unaccel = wl_fixed_to_double(dy_unaccelf);
++ xwl_seat->pending_pointer_event.dx = wl_fixed_to_double(dxf) * scale;
++ xwl_seat->pending_pointer_event.dy = wl_fixed_to_double(dyf) * scale;
++ xwl_seat->pending_pointer_event.dx_unaccel = wl_fixed_to_double(dx_unaccelf) * scale;
++ xwl_seat->pending_pointer_event.dy_unaccel = wl_fixed_to_double(dy_unaccelf) * scale;
+
+ if (!xwl_seat->focus_window)
+ return;
+@@ -1057,8 +1060,8 @@ touch_handle_down(void *data, struct wl_touch *wl_touch,
+
+ xwl_touch->window = wl_surface_get_user_data(surface);
+ xwl_touch->id = id;
+- xwl_touch->x = wl_fixed_to_int(sx_w);
+- xwl_touch->y = wl_fixed_to_int(sy_w);
++ xwl_touch->x = wl_fixed_to_int(sx_w) * xwl_seat->xwl_screen->global_output_scale;
++ xwl_touch->y = wl_fixed_to_int(sy_w) * xwl_seat->xwl_screen->global_output_scale;
+ xorg_list_add(&xwl_touch->link_touch, &xwl_seat->touches);
+
+ xwl_touch_send_event(xwl_touch, xwl_seat, XI_TouchBegin);
+@@ -1094,8 +1097,8 @@ touch_handle_motion(void *data, struct wl_touch *wl_touch,
+ if (!xwl_touch)
+ return;
+
+- xwl_touch->x = wl_fixed_to_int(sx_w);
+- xwl_touch->y = wl_fixed_to_int(sy_w);
++ xwl_touch->x = wl_fixed_to_int(sx_w) * xwl_seat->xwl_screen->global_output_scale;;
++ xwl_touch->y = wl_fixed_to_int(sy_w) * xwl_seat->xwl_screen->global_output_scale;;
+ xwl_touch_send_event(xwl_touch, xwl_seat, XI_TouchUpdate);
+ }
+
+@@ -1726,8 +1729,8 @@ tablet_tool_motion(void *data, struct zwp_tablet_tool_v2 *tool,
+ struct xwl_tablet_tool *xwl_tablet_tool = data;
+ struct xwl_seat *xwl_seat = xwl_tablet_tool->seat;
+ int32_t dx, dy;
+- double sx = wl_fixed_to_double(x);
+- double sy = wl_fixed_to_double(y);
++ double sx = wl_fixed_to_double(x) * xwl_seat->xwl_screen->global_output_scale;
++ double sy = wl_fixed_to_double(y) * xwl_seat->xwl_screen->global_output_scale;
+
+ if (!xwl_seat->tablet_focus_window)
+ return;
+@@ -2714,6 +2717,7 @@ xwl_pointer_warp_emulator_set_fake_pos(struct xwl_pointer_warp_emulator *warp_em
+ int x,
+ int y)
+ {
++ struct xwl_screen *xwl_screen;
+ struct zwp_locked_pointer_v1 *locked_pointer =
+ warp_emulator->locked_pointer;
+ WindowPtr window;
+@@ -2725,6 +2729,7 @@ xwl_pointer_warp_emulator_set_fake_pos(struct xwl_pointer_warp_emulator *warp_em
+ if (!warp_emulator->xwl_seat->focus_window)
+ return;
+
++ xwl_screen = warp_emulator->xwl_seat->xwl_screen;
+ window = warp_emulator->xwl_seat->focus_window->window;
+ if (x >= window->drawable.x ||
+ y >= window->drawable.y ||
+@@ -2733,8 +2738,8 @@ xwl_pointer_warp_emulator_set_fake_pos(struct xwl_pointer_warp_emulator *warp_em
+ sx = x - window->drawable.x;
+ sy = y - window->drawable.y;
+ zwp_locked_pointer_v1_set_cursor_position_hint(locked_pointer,
+- wl_fixed_from_int(sx),
+- wl_fixed_from_int(sy));
++ wl_fixed_from_int(xwl_scale_to(xwl_screen, sx)),
++ wl_fixed_from_int(xwl_scale_to(xwl_screen, sy)));
+ wl_surface_commit(warp_emulator->xwl_seat->focus_window->surface);
+ }
+ }
+diff --git a/hw/xwayland/xwayland-output.c b/hw/xwayland/xwayland-output.c
+index ef705bc01..b8f6cd51b 100644
+--- a/hw/xwayland/xwayland-output.c
++++ b/hw/xwayland/xwayland-output.c
+@@ -191,6 +191,9 @@ update_screen_size(struct xwl_output *xwl_output, int width, int height)
+ {
+ struct xwl_screen *xwl_screen = xwl_output->xwl_screen;
+
++ width *= xwl_screen->global_output_scale;
++ height *= xwl_screen->global_output_scale;
++
+ if (xwl_screen->root_clip_mode == ROOT_CLIP_FULL)
+ SetRootClip(xwl_screen->screen, ROOT_CLIP_NONE);
+
+@@ -497,14 +500,15 @@ xwl_output_set_emulated_mode(struct xwl_output *xwl_output, ClientPtr client,
+ xwl_output_set_randr_emu_props(xwl_output->xwl_screen, client);
+ }
+
+-static void
+-apply_output_change(struct xwl_output *xwl_output)
++void
++xwl_output_apply_changes(struct xwl_output *xwl_output)
+ {
+ struct xwl_screen *xwl_screen = xwl_output->xwl_screen;
+ struct xwl_output *it;
+ int mode_width, mode_height, count;
+ int width = 0, height = 0, has_this_output = 0;
+ RRModePtr *randr_modes;
++ int32_t scale = xwl_screen->global_output_scale;
+
+ /* Clear out the "done" received flags */
+ xwl_output->wl_output_done = FALSE;
+@@ -523,10 +527,10 @@ apply_output_change(struct xwl_output *xwl_output)
+ }
+
+ /* Build a fresh modes array using the current refresh rate */
+- randr_modes = output_get_rr_modes(xwl_output, mode_width, mode_height, &count);
++ randr_modes = output_get_rr_modes(xwl_output, mode_width * scale, mode_height * scale, &count);
+ RROutputSetModes(xwl_output->randr_output, randr_modes, count, 1);
+ RRCrtcNotify(xwl_output->randr_crtc, randr_modes[0],
+- xwl_output->x, xwl_output->y,
++ xwl_output->x * scale, xwl_output->y * scale,
+ xwl_output->rotation, NULL, 1, &xwl_output->randr_output);
+ /* RROutputSetModes takes ownership of the passed in modes, so we only
+ * have to free the pointer array.
+@@ -567,7 +571,7 @@ output_handle_done(void *data, struct wl_output *wl_output)
+ */
+ if (xwl_output->xdg_output_done || !xwl_output->xdg_output ||
+ zxdg_output_v1_get_version(xwl_output->xdg_output) >= 3)
+- apply_output_change(xwl_output);
++ xwl_output_apply_changes(xwl_output);
+ }
+
+ static void
+@@ -610,7 +614,7 @@ xdg_output_handle_done(void *data, struct zxdg_output_v1 *xdg_output)
+ xwl_output->xdg_output_done = TRUE;
+ if (xwl_output->wl_output_done &&
+ zxdg_output_v1_get_version(xdg_output) < 3)
+- apply_output_change(xwl_output);
++ xwl_output_apply_changes(xwl_output);
+ }
+
+ static void
+@@ -678,6 +682,8 @@ xwl_output_create(struct xwl_screen *xwl_screen, uint32_t id)
+ RROutputSetConnection(xwl_output->randr_output, RR_Connected);
+ RRTellChanged(xwl_screen->screen);
+
++ xwl_output->scale = 1;
++
+ /* We want the output to be in the list as soon as created so we can
+ * use it when binding to the xdg-output protocol...
+ */
+diff --git a/hw/xwayland/xwayland-output.h b/hw/xwayland/xwayland-output.h
+index 02b983108..ec089757f 100644
+--- a/hw/xwayland/xwayland-output.h
++++ b/hw/xwayland/xwayland-output.h
+@@ -53,7 +53,7 @@ struct xwl_output {
+ struct wl_output *output;
+ struct zxdg_output_v1 *xdg_output;
+ uint32_t server_output_id;
+- int32_t x, y, width, height, refresh;
++ int32_t x, y, width, height, scale, refresh;
+ Rotation rotation;
+ Bool wl_output_done;
+ Bool xdg_output_done;
+@@ -77,6 +77,8 @@ void xwl_output_set_emulated_mode(struct xwl_output *xwl_output,
+ void xwl_output_set_window_randr_emu_props(struct xwl_screen *xwl_screen,
+ WindowPtr window);
+
++void xwl_output_apply_changes(struct xwl_output *xwl_output);
++
+ void xwl_screen_init_xdg_output(struct xwl_screen *xwl_screen);
+
+ #endif /* XWAYLAND_OUTPUT_H */
+diff --git a/hw/xwayland/xwayland-present.c b/hw/xwayland/xwayland-present.c
+index c9cf8c2f5..5be0c208c 100644
+--- a/hw/xwayland/xwayland-present.c
++++ b/hw/xwayland/xwayland-present.c
+@@ -680,6 +680,8 @@ xwl_present_flip(WindowPtr present_window,
+
+ /* We can flip directly to the main surface (full screen window without clips) */
+ wl_surface_attach(xwl_window->surface, buffer, 0, 0);
++ wl_surface_set_buffer_scale(xwl_window->surface,
++ xwl_window->xwl_screen->global_output_scale);
+
+ if (!xwl_window->frame_callback)
+ xwl_window_create_frame_callback(xwl_window);
+diff --git a/hw/xwayland/xwayland-screen.c b/hw/xwayland/xwayland-screen.c
+index bb18e5c94..4ec2de7d1 100644
+--- a/hw/xwayland/xwayland-screen.c
++++ b/hw/xwayland/xwayland-screen.c
+@@ -51,6 +51,7 @@
+ #include "xwayland-pixmap.h"
+ #include "xwayland-present.h"
+ #include "xwayland-shm.h"
++#include "xwayland-window-buffers.h"
+
+ #ifdef MITSHM
+ #include "shmint.h"
+@@ -110,6 +111,12 @@ xwl_screen_has_resolution_change_emulation(struct xwl_screen *xwl_screen)
+ return xwl_screen->rootless && xwl_screen_has_viewport_support(xwl_screen);
+ }
+
++int
++xwl_scale_to(struct xwl_screen *xwl_screen, int value)
++{
++ return value / (double)xwl_screen->global_output_scale + 0.5;
++}
++
+ /* Return the output @ 0x0, falling back to the first output in the list */
+ struct xwl_output *
+ xwl_screen_get_first_output(struct xwl_screen *xwl_screen)
+@@ -127,6 +134,37 @@ xwl_screen_get_first_output(struct xwl_screen *xwl_screen)
+ return xorg_list_first_entry(&xwl_screen->output_list, struct xwl_output, link);
+ }
+
++static void
++xwl_screen_set_global_scale_from_property(struct xwl_screen *screen,
++ PropertyPtr prop)
++{
++ CARD32 *propdata;
++
++ if (prop->type != XA_CARDINAL || prop->format != 32 || prop->size != 1) {
++ // TODO: handle warnings more cleanly.
++ LogMessageVerb(X_WARNING, 0, "Bad value for property %s.\n",
++ NameForAtom(prop->propertyName));
++ return;
++ }
++
++ propdata = prop->data;
++ xwl_screen_set_global_scale(screen, propdata[0]);
++}
++
++static void
++xwl_screen_update_property(struct xwl_screen *screen,
++ PropertyStateRec *propstate)
++{
++ switch (propstate->state) {
++ case PropertyNewValue:
++ xwl_screen_set_global_scale_from_property(screen, propstate->prop);
++ break;
++ case PropertyDelete:
++ xwl_screen_set_global_scale(screen, 1);
++ break;
++ }
++}
++
+ static void
+ xwl_property_callback(CallbackListPtr *pcbl, void *closure,
+ void *calldata)
+@@ -134,19 +172,24 @@ xwl_property_callback(CallbackListPtr *pcbl, void *closure,
+ ScreenPtr screen = closure;
+ PropertyStateRec *rec = calldata;
+ struct xwl_screen *xwl_screen;
+- struct xwl_window *xwl_window;
+
+ if (rec->win->drawable.pScreen != screen)
+ return;
+
+- xwl_window = xwl_window_get(rec->win);
+- if (!xwl_window)
+- return;
+-
+ xwl_screen = xwl_screen_get(screen);
+
+- if (rec->prop->propertyName == xwl_screen->allow_commits_prop)
++ if (rec->prop->propertyName == xwl_screen->allow_commits_prop) {
++ struct xwl_window *xwl_window;
++
++ xwl_window = xwl_window_get(rec->win);
++ if (!xwl_window)
++ return;
++
+ xwl_window_update_property(xwl_window, rec);
++ }
++ else if (rec->prop->propertyName == xwl_screen->global_output_scale_prop) {
++ xwl_screen_update_property(xwl_screen, rec);
++ }
+ }
+
+ Bool
+@@ -521,8 +564,14 @@ void xwl_surface_damage(struct xwl_screen *xwl_screen,
+ {
+ if (wl_surface_get_version(surface) >= WL_SURFACE_DAMAGE_BUFFER_SINCE_VERSION)
+ wl_surface_damage_buffer(surface, x, y, width, height);
+- else
++ else {
++ x = xwl_scale_to(xwl_screen, x);
++ y = xwl_scale_to(xwl_screen, y);
++ width = xwl_scale_to(xwl_screen, width);
++ height = xwl_scale_to(xwl_screen, height);
++
+ wl_surface_damage(surface, x, y, width, height);
++ }
+ }
+
+ void
+@@ -538,10 +587,34 @@ xwl_screen_roundtrip(struct xwl_screen *xwl_screen)
+ xwl_give_up("could not connect to wayland server\n");
+ }
+
++void
++xwl_screen_set_global_scale(struct xwl_screen *xwl_screen, int32_t scale)
++{
++ struct xwl_output *it;
++ struct xwl_window *xwl_window;
++
++ xwl_screen->global_output_scale = scale;
++
++ /* change randr resolutions and positions */
++ xorg_list_for_each_entry(it, &xwl_screen->output_list, link) {
++ xwl_output_apply_changes(it);
++ }
++
++ if (!xwl_screen->rootless && xwl_screen->screen->root) {
++ /* Clear all the buffers, so that they'll be remade with the new sizes
++ * (this doesn't occur automatically because as far as Xorg is
++ * concerned, the window's size is the same) */
++ xorg_list_for_each_entry(xwl_window, &xwl_screen->window_list, link_window) {
++ xwl_window_buffers_recycle(xwl_window);
++ }
++ }
++}
++
+ Bool
+ xwl_screen_init(ScreenPtr pScreen, int argc, char **argv)
+ {
+ static const char allow_commits[] = "_XWAYLAND_ALLOW_COMMITS";
++ static const char global_output_scale[] = "_XWAYLAND_GLOBAL_OUTPUT_SCALE";
+ struct xwl_screen *xwl_screen;
+ Pixel red_mask, blue_mask, green_mask;
+ int ret, bpc, green_bpc, i;
+@@ -573,6 +646,7 @@ xwl_screen_init(ScreenPtr pScreen, int argc, char **argv)
+ #ifdef XWL_HAS_GLAMOR
+ xwl_screen->glamor = 1;
+ #endif
++ xwl_screen->global_output_scale = 1;
+
+ for (i = 1; i < argc; i++) {
+ if (strcmp(argv[i], "-rootless") == 0) {
+@@ -743,6 +817,12 @@ xwl_screen_init(ScreenPtr pScreen, int argc, char **argv)
+ if (xwl_screen->allow_commits_prop == BAD_RESOURCE)
+ return FALSE;
+
++ xwl_screen->global_output_scale_prop = MakeAtom(global_output_scale,
++ strlen(global_output_scale),
++ TRUE);
++ if (xwl_screen->global_output_scale_prop == BAD_RESOURCE)
++ return FALSE;
++
+ AddCallback(&PropertyStateCallback, xwl_property_callback, pScreen);
+
+ xwl_screen_roundtrip(xwl_screen);
+diff --git a/hw/xwayland/xwayland-screen.h b/hw/xwayland/xwayland-screen.h
+index b965dddd7..7446829d0 100644
+--- a/hw/xwayland/xwayland-screen.h
++++ b/hw/xwayland/xwayland-screen.h
+@@ -72,6 +72,8 @@ struct xwl_screen {
+ struct xorg_list damage_window_list;
+ struct xorg_list window_list;
+
++ int32_t global_output_scale;
++
+ int wayland_fd;
+ struct wl_display *display;
+ struct wl_registry *registry;
+@@ -107,6 +109,7 @@ struct xwl_screen {
+ struct glamor_context *glamor_ctx;
+
+ Atom allow_commits_prop;
++ Atom global_output_scale_prop;
+
+ /* The preferred GLVND vendor. If NULL, "mesa" is assumed. */
+ const char *glvnd_vendor;
+@@ -134,5 +137,7 @@ void xwl_screen_roundtrip (struct xwl_screen *xwl_screen);
+ void xwl_surface_damage(struct xwl_screen *xwl_screen,
+ struct wl_surface *surface,
+ int32_t x, int32_t y, int32_t width, int32_t height);
++int xwl_scale_to(struct xwl_screen *xwl_screen, int value);
++void xwl_screen_set_global_scale(struct xwl_screen *xwl_screen, int32_t scale);
+
+ #endif /* XWAYLAND_SCREEN_H */
+diff --git a/hw/xwayland/xwayland-window.c b/hw/xwayland/xwayland-window.c
+index 00f161eda..ed3903853 100644
+--- a/hw/xwayland/xwayland-window.c
++++ b/hw/xwayland/xwayland-window.c
+@@ -470,7 +470,8 @@ ensure_surface_for_window(WindowPtr window)
+ }
+
+ wl_region_add(region, 0, 0,
+- window->drawable.width, window->drawable.height);
++ xwl_scale_to(xwl_screen, window->drawable.width),
++ xwl_scale_to(xwl_screen, window->drawable.height));
+ wl_surface_set_opaque_region(xwl_window->surface, region);
+ wl_region_destroy(region);
+ }
+@@ -820,6 +821,7 @@ xwl_window_post_damage(struct xwl_window *xwl_window)
+ #endif
+
+ wl_surface_attach(xwl_window->surface, buffer, 0, 0);
++ wl_surface_set_buffer_scale(xwl_window->surface, xwl_screen->global_output_scale);
+
+ /* Arbitrary limit to try to avoid flooding the Wayland
+ * connection. If we flood it too much anyway, this could