summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJat2021-04-01 23:17:27 +0800
committerJat2021-04-01 23:17:27 +0800
commitf892c311b6726c040d1658c8afac3e3eb8d461c0 (patch)
treecea918ae98c7fe720e47d2928ed3ed4a08f12a87
downloadaur-f892c311b6726c040d1658c8afac3e3eb8d461c0.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
-rw-r--r--xorgxrdp-nvidia-git.install15
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6463931e7b71
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xorgxrdp-nvidia-git
+ pkgdesc = Xorg drivers for xrdp, with NVIDIA GPU support.
+ pkgver = 0.2.15
+ pkgrel = 1
+ url = https://github.com/neutrinolabs/xorgxrdp
+ install = xorgxrdp-nvidia-git.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = nasm
+ makedepends = xorg-server-devel
+ makedepends = xrdp-git
+ depends = nvidia
+ provides = xorgxrdp
+ conflicts = xorgxrdp
+ options = staticlibs
+ source = git+https://github.com/Nexarian/xorgxrdp.git#branch=resize_wyhash_egfx_nvidia_features
+ sha256sums = SKIP
+
+pkgname = xorgxrdp-nvidia-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd8b49c41f30
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!xorgxrdp-nvidia-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b5490957083
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jat <chat@jat.email>
+
+_pkgname=xorgxrdp
+pkgname=xorgxrdp-nvidia-git
+pkgver=0.2.15
+pkgrel=1
+pkgdesc="Xorg drivers for xrdp, with NVIDIA GPU support."
+arch=('i686' 'x86_64')
+url="https://github.com/neutrinolabs/xorgxrdp"
+license=('MIT')
+provides=('xorgxrdp')
+conflicts=('xorgxrdp')
+depends=('nvidia')
+makedepends=('git' 'nasm' 'xorg-server-devel' 'xrdp-git')
+options=('staticlibs')
+source=('git+https://github.com/Nexarian/xorgxrdp.git#branch=resize_wyhash_egfx_nvidia_features')
+sha256sums=('SKIP')
+install="$pkgname.install"
+
+prepare() {
+ cd "$_pkgname"
+
+ busid=$(nvidia-xconfig --query-gpu-info | grep -im1 busid | awk '{print $NF}')
+ sed -i 's/Identifier "layout"/Identifier "X11 Server"/
+ /Section "ServerFlags"/a \ \ Option "DefaultServerLayout" "X11 Server"
+ s/BusID "PCI:2:0:0"/BusID "'"$busid"'/' xrdpdev/xorg_nvidia.conf
+}
+
+build() {
+ cd "$_pkgname"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "$_pkgname"
+
+ #make check
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/$_pkgname"
+}
diff --git a/xorgxrdp-nvidia-git.install b/xorgxrdp-nvidia-git.install
new file mode 100644
index 000000000000..223999c81dda
--- /dev/null
+++ b/xorgxrdp-nvidia-git.install
@@ -0,0 +1,15 @@
+post_install() {
+echo -e '\033[1;33mxorgxrdp-nvidia only use the first gpu,' \
+'if you need multi gpus support,' \
+'edit /etc/X11/xrdp/xorg_nvidia.conf manually.'
+
+echo -e '\033[0;31mremember to edit "/etc/xrdp/sesman.ini",' \
+'change "param=xrdp/xorg.conf" to "param=xrdp/xorg_nvidia.conf"' \
+'in the section "[Xorg]"'
+
+echo -en '\033[0m'
+}
+
+post_upgrade() {
+post_install
+}