summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Terrien2016-06-25 22:12:06 -0700
committerKyle Terrien2016-06-25 22:12:06 -0700
commitf6c1ee7cce14d71b57756fb24ecb678d07329ee3 (patch)
tree2cb8e0455540ceccba9ab898e1fe07ca0a9812ea
parent526119a9c4cd336de026e2f535e7a41d5031ee6c (diff)
downloadaur-f6c1ee7cce14d71b57756fb24ecb678d07329ee3.tar.gz
Builds on gcc 6
-rw-r--r--.SRCINFO7
-rw-r--r--001-acpitemp.patch18
-rw-r--r--PKGBUILD15
3 files changed, 34 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 642a47610190..145c1085d0a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jun 26 05:10:22 UTC 2016
pkgbase = xosview
pkgdesc = Displays system stats such as cpu, memory, swap, and network usage
pkgver = 1.17
- pkgrel = 1
+ pkgrel = 2
url = http://www.pogo.org.uk/~mark/xosview/
arch = i686
arch = x86_64
license = GPL
- depends = gcc-libs
depends = libxpm
source = http://www.pogo.org.uk/~mark/xosview/releases/xosview-1.17.tar.gz
+ source = 001-acpitemp.patch
sha256sums = 640998e7bd23b875e2556a97b9149a4cca0ac255889f484489b13a888c19b3f1
+ sha256sums = 8b8047303f4e36b881d45b4e92847c38b01fc455f5d7d6740b8a784a45cef08a
pkgname = xosview
diff --git a/001-acpitemp.patch b/001-acpitemp.patch
new file mode 100644
index 000000000000..794d099b6b8c
--- /dev/null
+++ b/001-acpitemp.patch
@@ -0,0 +1,18 @@
+diff -ur a/linux/acpitemp.cc b/linux/acpitemp.cc
+--- a/linux/acpitemp.cc 2015-09-23 06:28:14.000000000 -0700
++++ b/linux/acpitemp.cc 2016-06-25 21:40:07.514257919 -0700
+@@ -118,12 +118,12 @@
+ std::ifstream high_file(_highfile);
+
+ if (!temp_file) {
+- std::cerr << "Can not open file : " << temp_file << std::endl;
++ std::cerr << "Can not open file : " << _tempfile << std::endl;
+ parent_->done(1);
+ return;
+ }
+ if (!high_file) {
+- std::cerr << "Can not open file : " << high_file << std::endl;
++ std::cerr << "Can not open file : " << _highfile << std::endl;
+ parent_->done(1);
+ return;
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 6b506d198b78..87c4913037aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,21 @@
pkgname=xosview
pkgver=1.17
-pkgrel=1
+pkgrel=2
pkgdesc="Displays system stats such as cpu, memory, swap, and network usage"
arch=(i686 x86_64)
-depends=('gcc-libs' 'libxpm')
+depends=('libxpm')
license=('GPL')
-source=(http://www.pogo.org.uk/~mark/$pkgname/releases/$pkgname-$pkgver.tar.gz)
+source=(http://www.pogo.org.uk/~mark/$pkgname/releases/$pkgname-$pkgver.tar.gz
+ 001-acpitemp.patch)
url="http://www.pogo.org.uk/~mark/xosview/"
-sha256sums=('640998e7bd23b875e2556a97b9149a4cca0ac255889f484489b13a888c19b3f1')
+sha256sums=('640998e7bd23b875e2556a97b9149a4cca0ac255889f484489b13a888c19b3f1'
+ '8b8047303f4e36b881d45b4e92847c38b01fc455f5d7d6740b8a784a45cef08a')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -p1 < "$srcdir/001-acpitemp.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"