summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2016-04-26 20:12:39 +0200
committerMorten Linderud2016-04-26 20:12:39 +0200
commit53830bf89c529b101841173013cdb2643805af04 (patch)
tree4b6b25f981cab0d52b431c177153172309856eee
downloadaur-53830bf89c529b101841173013cdb2643805af04.tar.gz
Added xoutputd-git package
Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c46d01d8a6dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Apr 26 18:08:09 UTC 2016
+pkgbase = xoutputd-git
+ pkgdesc = Change screenlayout when connecting/disconnecting monitors
+ pkgver = v0.1.r0.gc7ac198
+ pkgrel = 1
+ url = https://github.com/jlpc/xoutputd.git
+ arch = any
+ license = MIT
+ makedepends = libx11
+ makedepends = libxrandr
+ makedepends = flex
+ provides = xoutputd
+ conflicts = xoutputd
+ source = git+https://github.com/jlpc/xoutputd.git
+ sha256sums = SKIP
+
+pkgname = xoutputd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d705e8752019
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Morten Linderud <morten@linderud.pw>
+
+pkgname=xoutputd-git
+_pkgname=xoutputd
+pkgver=v0.1.r0.gc7ac198
+pkgrel=1
+pkgdesc='Change screenlayout when connecting/disconnecting monitors'
+arch=('any')
+url="https://github.com/jlpc/xoutputd.git"
+license=('MIT')
+makedepends=('libx11' 'libxrandr' 'flex')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/jlpc/xoutputd.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build () {
+ sed -i -e 's/-ll -ly/-lfl/' ${srcdir}/${_pkgname}/Makefile
+ make -C "$srcdir/$_pkgname" PREFIX=/usr
+}
+
+package () {
+ install -Dm655 "${srcdir}/${_pkgname}/xoutputd" "${pkgdir}/usr/bin/xoutputd"
+}
+
+# vim: et ts=2 sw=2